summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCalvin Lee2020-07-24 09:12:57 -0600
committerCalvin Lee2020-07-24 09:38:36 -0600
commitd3f99f67e0e0ee4e0b1868e4847f842937add44a (patch)
treec24549f34ad7a7ef9b39d59ceb1c65e2aba03abe
downloadaur-d3f99f67e0e0ee4e0b1868e4847f842937add44a.tar.gz
Initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--Allow-bitmap-fonts.patch44
-rw-r--r--PKGBUILD53
3 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59993368d19b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = kitty-bitmap
+ pkgdesc = A modern, hackable, featureful, OpenGL-based terminal emulator. Patched to support bitmap fonts.
+ pkgver = 0.18.1
+ pkgrel = 1
+ url = https://github.com/kovidgoyal/kitty
+ arch = x86_64
+ license = GPL3
+ makedepends = libxinerama
+ makedepends = libxcursor
+ makedepends = libxrandr
+ makedepends = wayland-protocols
+ makedepends = python-sphinx
+ depends = python3
+ depends = freetype2
+ depends = fontconfig
+ depends = wayland
+ depends = libx11
+ depends = libxkbcommon-x11
+ depends = libxi
+ depends = hicolor-icon-theme
+ depends = libgl
+ depends = libcanberra
+ depends = dbus
+ depends = kitty-terminfo
+ optdepends = imagemagick: viewing images with icat
+ provides = kitty
+ conflicts = kitty
+ source = kitty-0.18.1.tar.gz::https://github.com/kovidgoyal/kitty/archive/v0.18.1.tar.gz
+ source = Allow-bitmap-fonts.patch
+ sha512sums = 8eb5d16c342be8ba88aaadc591e2a04df01b1f5c87b5b5a04026acdf60c4770e07f43d88f82eca70f0c310e93432c8f25d5ccd6d6e83b49f0e2f735aac61e630
+ sha512sums = SKIP
+
+pkgname = kitty-bitmap
+
diff --git a/Allow-bitmap-fonts.patch b/Allow-bitmap-fonts.patch
new file mode 100644
index 000000000000..0d9e2507d403
--- /dev/null
+++ b/Allow-bitmap-fonts.patch
@@ -0,0 +1,44 @@
+diff --git a/kitty/fast_data_types.pyi b/kitty/fast_data_types.pyi
+index e69d7fa8..ad68c866 100644
+--- a/kitty/fast_data_types.pyi
++++ b/kitty/fast_data_types.pyi
+@@ -423,7 +423,7 @@ class FontConfigPattern(TypedDict):
+
+ def fc_list(
+ spacing: int = -1,
+- allow_bitmapped_fonts: bool = False
++ allow_bitmapped_fonts: bool = True
+ ) -> Tuple[FontConfigPattern, ...]:
+ pass
+
+@@ -433,7 +433,7 @@ def fc_match(
+ bold: bool = False,
+ italic: bool = False,
+ spacing: int = FC_MONO,
+- allow_bitmapped_fonts: bool = False,
++ allow_bitmapped_fonts: bool = True,
+ size_in_pts: float = 0.,
+ dpi: float = 0.
+ ) -> FontConfigPattern:
+diff --git a/kitty/fontconfig.c b/kitty/fontconfig.c
+index 7156d9ee..6444d6bc 100644
+--- a/kitty/fontconfig.c
++++ b/kitty/fontconfig.c
+@@ -84,7 +84,7 @@ font_set(FcFontSet *fs) {
+
+ static PyObject*
+ fc_list(PyObject UNUSED *self, PyObject *args) {
+- int allow_bitmapped_fonts = 0, spacing = -1;
++ int allow_bitmapped_fonts = 1, spacing = -1;
+ PyObject *ans = NULL;
+ FcObjectSet *os = NULL;
+ FcPattern *pat = NULL;
+@@ -148,7 +148,7 @@ end:
+ static PyObject*
+ fc_match(PyObject UNUSED *self, PyObject *args) {
+ char *family = NULL;
+- int bold = 0, italic = 0, allow_bitmapped_fonts = 0, spacing = FC_MONO;
++ int bold = 0, italic = 0, allow_bitmapped_fonts = 1, spacing = FC_MONO;
+ double size_in_pts = 0, dpi = 0;
+ FcPattern *pat = NULL;
+ PyObject *ans = NULL;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..638636eb8ce2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Calvin Lee <calvins.lee@utah.edu>
+# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
+# Contributor: Maxim Baz <$pkgname at maximbaz dot com>
+# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Maximilian Kindshofer <maximilian@kindshofer.net>
+
+pkgname=(kitty-bitmap)
+pkgver=0.18.1
+pkgrel=1
+pkgdesc="A modern, hackable, featureful, OpenGL-based terminal emulator. Patched to support bitmap fonts."
+arch=('x86_64')
+url="https://github.com/kovidgoyal/kitty"
+license=('GPL3')
+depends=('python3' 'freetype2' 'fontconfig' 'wayland' 'libx11' 'libxkbcommon-x11' 'libxi' 'hicolor-icon-theme' 'libgl' 'libcanberra' 'dbus' 'kitty-terminfo')
+makedepends=('libxinerama' 'libxcursor' 'libxrandr' 'wayland-protocols' 'python-sphinx')
+optdepends=('imagemagick: viewing images with icat')
+provides=('kitty')
+conflicts=('kitty')
+source=("${pkgname/-bitmap}-${pkgver}.tar.gz::https://github.com/kovidgoyal/${pkgname/-bitmap/}/archive/v$pkgver.tar.gz" "Allow-bitmap-fonts.patch")
+sha512sums=('8eb5d16c342be8ba88aaadc591e2a04df01b1f5c87b5b5a04026acdf60c4770e07f43d88f82eca70f0c310e93432c8f25d5ccd6d6e83b49f0e2f735aac61e630' 'SKIP')
+
+prepare() {
+ cd "$srcdir/${pkgname/-bitmap}-$pkgver"
+ patch --strip=1 --input="${srcdir}/Allow-bitmap-fonts.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname/-bitmap}-$pkgver"
+ python3 setup.py linux-package --update-check-interval=0
+}
+
+package() {
+
+ cd "$srcdir/${pkgname/-bitmap}-$pkgver"
+
+ cp -r linux-package "${pkgdir}"/usr
+
+ # completions
+ python __main__.py + complete setup bash | install -Dm644 /dev/stdin "${pkgdir}"/usr/share/bash-completion/completions/kitty
+ python __main__.py + complete setup fish | install -Dm644 /dev/stdin "${pkgdir}"/usr/share/fish/vendor_completions.d/kitty.fish
+ # doesn't know how to http://zsh.sourceforge.net/Doc/Release/Completion-System.html#Autoloaded-files
+ # so we write our own header
+ {
+ echo "#compdef kitty"
+ python __main__.py + complete setup zsh
+ } | install -Dm644 /dev/stdin "${pkgdir}"/usr/share/zsh/site-functions/_kitty
+
+ install -Dm644 "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/kitty.png "${pkgdir}"/usr/share/pixmaps/kitty.png
+
+ rm -r "$pkgdir"/usr/share/terminfo
+
+ install -Dm644 docs/generated/conf/kitty.conf "${pkgdir}"/usr/share/doc/${pkgname}/kitty.conf
+}