summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-08-17 16:21:39 +0200
committerFabioLolix2020-08-17 16:21:39 +0200
commitd41f7c8f0d0ad58fe3a1e5978209982b1f470a27 (patch)
treed3521f74de743d48ae1975586bcae469815fadbf
parent483c98b1be33ebb820dc1849964b922c33dd114b (diff)
downloadaur-d41f7c8f0d0ad58fe3a1e5978209982b1f470a27.tar.gz
revision
-rwxr-xr-x.SRCINFO19
-rwxr-xr-xPKGBUILD61
2 files changed, 45 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed9bd57e2454..4c6f37f59f1c 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,32 @@
pkgbase = qomp
pkgdesc = Quick(Qt) Online Music Player
pkgver = 1.4
- pkgrel = 1
- url = http://qomp.sourceforge.net/
+ pkgrel = 2
+ url = https://qomp.sourceforge.net/
arch = i686
arch = x86_64
license = GPL2
makedepends = git
makedepends = cmake
+ makedepends = qt5-tools
depends = taglib
depends = qt5-base
- depends = qt5-tools
depends = qt5-x11extras
depends = qt5-multimedia
depends = qt5-xmlpatterns
depends = gstreamer
depends = libcue
depends = gst-plugins-good
- optdepends = gst-plugins-bad
- optdepends = gst-plugins-ugly
- source = git+https://github.com/qomp/qomp.git#commit=3cbc6ccc5653737b3e1e0b4884bb370e67144604
+ optdepends = gst-libav: additional codecs
+ optdepends = gst-plugins-bad: additional codecs
+ optdepends = gst-plugins-ugly: additional codecs
+ source = git+https://github.com/qomp/qomp#tag=1.4
+ source = git+https://github.com/qomp/translations
+ source = git+https://github.com/qomp/themes
+ source = git+https://github.com/wadealer/SingleApplication
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = qomp
diff --git a/PKGBUILD b/PKGBUILD
index 5b2405881a53..f8a52039cd0d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,51 @@
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
-# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
# Contributor: alex korobtsov <korobcoff@gmail.com>
# Contributor: Alexander Bantyev <balsoft@yandex.ru>
pkgname=qomp
pkgver=1.4
-pkgrel=1
+pkgrel=2
pkgdesc="Quick(Qt) Online Music Player"
-arch=('i686' 'x86_64')
-url="http://qomp.sourceforge.net/"
-license=('GPL2')
-depends=('taglib' 'qt5-base' 'qt5-tools' 'qt5-x11extras'
- 'qt5-multimedia' 'qt5-xmlpatterns'
- 'gstreamer' 'libcue' 'gst-plugins-good')
-optdepends=('gst-plugins-bad'
- 'gst-plugins-ugly')
-makedepends=('git' 'cmake')
-_commit=3cbc6ccc5653737b3e1e0b4884bb370e67144604 #tag 1.4.0
-source=(git+https://github.com/qomp/qomp.git#commit=$_commit)
-sha256sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
+arch=(i686 x86_64)
+url="https://qomp.sourceforge.net/"
+license=(GPL2)
+depends=(taglib qt5-base qt5-x11extras
+ qt5-multimedia qt5-xmlpatterns
+ gstreamer libcue gst-plugins-good)
+optdepends=('gst-libav: additional codecs'
+ 'gst-plugins-bad: additional codecs'
+ 'gst-plugins-ugly: additional codecs')
+makedepends=(git cmake qt5-tools)
+source=("git+https://github.com/qomp/qomp#tag=${pkgver}"
+ "git+https://github.com/qomp/translations"
+ "git+https://github.com/qomp/themes"
+ "git+https://github.com/wadealer/SingleApplication")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
+ cd "${srcdir}/${pkgname}"
- cd "$srcdir/$pkgname"
- git submodule init
- git submodule update
+ git submodule init
+ git config 'submodule.translations.url' "${srcdir}/translations"
+ git config 'submodule.themes.url' "${srcdir}/themes"
+ git config 'submodule.src/singleapplication.url' "${srcdir}/SingleApplication"
+ git submodule update
}
build() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr/ \
+ -DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}/" install
}
-
-