summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSematre2020-11-02 20:52:12 +0100
committerSematre2020-11-02 20:52:12 +0100
commitd44c18658418804d0616912b61d84bb9f5584759 (patch)
treea838a370b2b29580c0a98e949eb21aefea5ec265
downloadaur-d44c18658418804d0616912b61d84bb9f5584759.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ba60e370787
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = piknik-bin
+ pkgdesc = Copy/paste anything over the network.
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://github.com/jedisct1/piknik
+ arch = x86_64
+ license = BSD
+ provides = piknik
+ conflicts = piknik
+ source = piknik-0.9.1.tar.gz::https://github.com/jedisct1/piknik/releases/download/0.9.1/piknik-linux_x86_64-0.9.1.tar.gz
+ sha256sums = 6343075652835a0508bbc3e6404529d5abdb6c835508a91cfaeddfb759e86f73
+
+pkgname = piknik-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcc2f6fd19ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Sematre <sematre at gmx dot de>
+pkgname=piknik-bin
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Copy/paste anything over the network."
+arch=('x86_64')
+url="https://github.com/jedisct1/${pkgname%-bin}"
+license=('BSD')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/${pkgname%-bin}-linux_x86_64-${pkgver}.tar.gz")
+sha256sums=('6343075652835a0508bbc3e6404529d5abdb6c835508a91cfaeddfb759e86f73')
+
+package() {
+ install -Dm 755 "linux-x86_64/${pkgname%-bin}" -t "$pkgdir/usr/bin"
+}