summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2021-12-15 12:25:46 -0500
committerTed Alff2021-12-15 12:25:46 -0500
commitd47d1f2fa37b25b065693d17f9c64a8dd1c842ef (patch)
tree062e498fb4d37302b9bb843346fbdc91fbdbf09d
parent9318a0ddb019229ee2b96931d43791a85f5137ba (diff)
downloadaur-d47d1f2fa37b25b065693d17f9c64a8dd1c842ef.tar.gz
Add patch for python 3.10
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
-rw-r--r--python3.10_fix.patch12
3 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e40a68e1200..668d6ff414d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-system_hotkey
pkgdesc = Python library for system wide hotkeys
- pkgver = 1.0.2+10+9541587
- pkgrel = 1
+ pkgver = 1.0.2+12+37073bb
+ pkgrel = 2
url = https://github.com/timeyyy/system_hotkey
arch = any
license = BSD
@@ -9,7 +9,8 @@ pkgbase = python-system_hotkey
makedepends = git
depends = python-xcffib
source = python-system_hotkey::git+https://github.com/timeyyy/system_hotkey
+ source = python3.10_fix.patch
sha256sums = SKIP
+ sha256sums = 2f15f1ebeb95e1b3e9cccfeac6f05da1af98b634834d912d02e807c3cc0a0df2
pkgname = python-system_hotkey
-
diff --git a/PKGBUILD b/PKGBUILD
index f91fc64337a1..10a80ec30341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,27 @@
pkgname=python-system_hotkey
_pkgver=1.0.2
-pkgver=1.0.2+10+9541587
-pkgrel=1
+pkgver=1.0.2+12+37073bb
+pkgrel=2
pkgdesc="Python library for system wide hotkeys"
arch=('any')
url="https://github.com/timeyyy/system_hotkey"
license=('BSD')
depends=('python-xcffib')
makedepends=('python-setuptools' 'git')
-source=("${pkgname}::git+https://github.com/timeyyy/system_hotkey")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://github.com/timeyyy/system_hotkey"
+ 'python3.10_fix.patch')
+sha256sums=('SKIP'
+ '2f15f1ebeb95e1b3e9cccfeac6f05da1af98b634834d912d02e807c3cc0a0df2')
_release_commit='f30711752d0d4510cda2a213e4ec9c665677e167'
#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/timeyyy/${pkgname/python-/}/archive/${pkgver}.tar.gz")
#sha256sums=('4d6e06bf359efecf4bea251e330c852f83b9150f503df28fd94239499f4ff606')
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -uNp2 -r- -i ../python3.10_fix.patch
+}
+
pkgver() {
# cd "${srcdir}/${pkgname/python-/}-${pkgver}"
cd "${srcdir}/${pkgname}"
diff --git a/python3.10_fix.patch b/python3.10_fix.patch
new file mode 100644
index 000000000000..d93efc78b9af
--- /dev/null
+++ b/python3.10_fix.patch
@@ -0,0 +1,12 @@
+diff -Naur ./python-system_hotkey.orig/system_hotkey/system_hotkey.py ./python-system_hotkey/system_hotkey/system_hotkey.py
+--- ./python-system_hotkey.orig/system_hotkey/system_hotkey.py 2021-12-15 12:22:51.996228526 -0500
++++ ./python-system_hotkey/system_hotkey/system_hotkey.py 2021-12-15 12:23:31.192184801 -0500
+@@ -285,7 +285,7 @@
+
+ thread safe
+ '''
+- assert isinstance(hotkey, collections.Iterable) and type(hotkey) not in (str, bytes)
++ assert isinstance(hotkey, collections.abc.Iterable) and type(hotkey) not in (str, bytes)
+ if self.consumer == 'callback' and not callback:
+ raise TypeError('Function register requires callback argument in non sonsumer mode')
+