summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2021-11-10 22:42:59 +0100
committerj.r2021-11-10 22:42:59 +0100
commitd48d69405908dbbd128e100819df72a0e7fb05f5 (patch)
treed4fbee0241d2216614dd6179d3ecd848bf01d4bd
parentf01d67b831cec666ea2302b907f5e44a9dda4957 (diff)
downloadaur-d48d69405908dbbd128e100819df72a0e7fb05f5.tar.gz
gnome-shell-extension-topicons-plus: add GNOME 41
Add patch to support GNOME 41
-rw-r--r--.SRCINFO7
-rw-r--r--0001-fix-compatibility-with-gnome40_41.diff (renamed from 0001-fix-compatibility-with-gnome40.patch)24
-rw-r--r--PKGBUILD8
3 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3cf61d08a47..3cbfb114d1c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = gnome-shell-extension-topicons-plus
pkgdesc = Moves legacy tray icons to the top panel
pkgver = 27
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/phocean/TopIcons-plus
arch = any
license = GPL2
depends = gnome-shell
source = gnome-shell-extension-topicons-plus-27.tar.gz::https://github.com/phocean/TopIcons-plus/archive/27.tar.gz
- source = 0001-fix-compatibility-with-gnome40.patch
+ source = 0001-fix-compatibility-with-gnome40_41.diff
sha256sums = 51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8
- sha256sums = e4cb4ec7b74d6e1d4f5323e3d607dc56aca984fbde87590bc4e44c216c8504f8
+ sha256sums = 0a1f5537c1fe985e666858d40edc1c8a9849bd74c0ea6b4a94ea21c838dad54c
pkgname = gnome-shell-extension-topicons-plus
-
diff --git a/0001-fix-compatibility-with-gnome40.patch b/0001-fix-compatibility-with-gnome40_41.diff
index 2b9a6c443e7d..fded01e3e7a8 100644
--- a/0001-fix-compatibility-with-gnome40.patch
+++ b/0001-fix-compatibility-with-gnome40_41.diff
@@ -1,31 +1,18 @@
-From 98cd17aa324a031e2ee3d344582dfdafd1e4642f Mon Sep 17 00:00:00 2001
-From: Tiramisu Mokka <kofemann@gmail.com>
-Date: Fri, 19 Mar 2021 19:00:32 +0100
-Subject: [PATCH] fix compatibility with gnome40
-
----
- metadata.json | 5 ++---
- prefs.js | 6 ++----
- 2 files changed, 4 insertions(+), 7 deletions(-)
-
diff --git a/metadata.json b/metadata.json
-index e4c9691..8a07918 100644
+index e4c9691..c5d8a70 100644
--- a/metadata.json
+++ b/metadata.json
-@@ -3,11 +3,10 @@
+@@ -3,8 +3,8 @@
"name": "TopIcons Plus",
"gettext-domain": "TopIcons-Plus",
"shell-version": [
- "3.34",
- "3.36"
-+ "40"
++ "40",
++ "41"
],
"settings-schema": "org.gnome.shell.extensions.topicons",
"url": "https://github.com/phocean/TopIcons-plus",
- "uuid": "TopIcons@phocean.net",
-- "version": 27
-+ "version": 28
- }
diff --git a/prefs.js b/prefs.js
index bd372d2..f6b1277 100644
--- a/prefs.js
@@ -49,6 +36,3 @@ index bd372d2..f6b1277 100644
- return widget;
}
---
-2.31.1
-
diff --git a/PKGBUILD b/PKGBUILD
index f504195d9a01..7b4abf73acda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,21 @@
pkgname=gnome-shell-extension-topicons-plus
pkgver=27
-pkgrel=3
+pkgrel=4
pkgdesc="Moves legacy tray icons to the top panel"
arch=('any')
url="https://github.com/phocean/TopIcons-plus"
license=('GPL2')
depends=('gnome-shell')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phocean/TopIcons-plus/archive/${pkgver}.tar.gz"
- "0001-fix-compatibility-with-gnome40.patch")
+ "0001-fix-compatibility-with-gnome40_41.diff")
sha256sums=('51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8'
- 'e4cb4ec7b74d6e1d4f5323e3d607dc56aca984fbde87590bc4e44c216c8504f8')
+ '0a1f5537c1fe985e666858d40edc1c8a9849bd74c0ea6b4a94ea21c838dad54c')
prepare() {
cd "${srcdir}/TopIcons-plus-${pkgver}"
- patch -p1 -i ${srcdir}/0001-fix-compatibility-with-gnome40.patch
+ patch -p1 -i ${srcdir}/0001-fix-compatibility-with-gnome40_41.diff
}
build(){