summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph R. Quinn2019-10-30 11:36:49 -0400
committerJoseph R. Quinn2019-10-30 11:36:49 -0400
commitd4cbb3fef664b5925be8c1c35c306aff815e6db7 (patch)
tree71f6379b3c00a3c65cf34ff3f3abfa1737b38f79
parentf2dc4c500bbc2c76193f78820ebb1c48809402f9 (diff)
downloadaur-d4cbb3fef664b5925be8c1c35c306aff815e6db7.tar.gz
Correcting LICENSE (again), removing GCC makedepends as a C-compiler should be present
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efd8e4a5ce95..24f3d8924d76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = php-psr
pkgdesc = PHP extension providing the accepted PSR interfaces.
pkgver = 0.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jbboehr/php-psr
arch = any
license = BSD
- makedepends = gcc>=4.4
- depends = php
+ depends = php>=5.5
provides = php-psr
backup = etc/php/conf.d/psr.ini
source = https://github.com/jbboehr/php-psr/archive/v0.7.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 9854b998ba69..1df8eefeecaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
# Maintainer: Joseph R. Quinn <quinn.josephr@protonmail.com>
pkgname=php-psr
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="PHP extension providing the accepted PSR interfaces."
arch=('any')
url="https://github.com/jbboehr/php-psr"
license=('BSD')
-depends=('php')
-makedepends=('gcc>=4.4')
+depends=('php>=5.5')
provides=("$pkgname")
backup=('etc/php/conf.d/psr.ini')
source=("https://github.com/jbboehr/$pkgname/archive/v$pkgver.tar.gz"
@@ -18,7 +17,7 @@ sha1sums=('9d44acc24a37e90e08cf74c02817a80d750cd1b9'
build() {
cd "$pkgname-$pkgver"
- phpize
+ phpize
./configure --prefix=/usr
make
}
@@ -27,5 +26,5 @@ package() {
cd "$pkgname-$pkgver"
make INSTALL_ROOT="$pkgdir/" install
install -Dm644 "$srcdir/psr.ini" "$pkgdir/etc/php/conf.d/psr.ini"
- install -Dm644 "$srcdir/LICENSE.md" "$pkgdir/usr/share/licenses/php-psr/LICENSE"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/php-psr/LICENSE"
}