summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip2016-07-07 23:38:47 +0200
committerJosip2016-07-07 23:38:47 +0200
commitd4f3421812fa161ca6c40c8a2bc0d1280d0f0e0e (patch)
tree10ef58d20457c654153ba67c7a2f14f8a0488fe0
downloadaur-d4f3421812fa161ca6c40c8a2bc0d1280d0f0e0e.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31b133e8fe7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = krill-git
+ pkgdesc = Read and filter web feeds.
+ pkgver = v0.3.0.r1.ga1031ea
+ pkgrel = 1
+ url = https://github.com/p-e-w/krill
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-blessings
+ depends = python-feedparser
+ depends = python-requests
+ provides = krill
+ conflicts = krill
+ source = git+https://github.com/p-e-w/krill.git
+ sha256sums = SKIP
+
+pkgname = krill-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd914309f172
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+
+pkgname=krill-git
+pkgver=v0.3.0.r1.ga1031ea
+pkgrel=1
+pkgdesc="Read and filter web feeds."
+arch=('any')
+url="https://github.com/p-e-w/krill"
+license=('GPL3')
+depends=('python-beautifulsoup4' 'python-blessings' 'python-feedparser' 'python-requests')
+makedepends=('git' 'python-setuptools')
+provides=('krill')
+conflicts=('krill')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd krill
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd krill
+ python setup.py build
+}
+
+package() {
+ cd krill
+ python setup.py install --root="$pkgdir/" --optimize=1
+}