summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormach62018-08-31 18:21:16 -0400
committermach62018-08-31 18:21:16 -0400
commitd4f3ef53fa284fd761e14acc95689a3c06bc398b (patch)
tree406d6bd2e71c4ff2485302b11dcf15b8f43f0e50
parent6775349cc367fd3f12f6490f57b4095abe888684 (diff)
downloadaur-d4f3ef53fa284fd761e14acc95689a3c06bc398b.tar.gz
Fix compatability with coolfluid
-rw-r--r--.SRCINFO2
-rw-r--r--0001-Fix-some-issues-with-CMake.patch23
-rw-r--r--PKGBUILD2
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d730683149e9..a97ad47f9d15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,7 @@ pkgbase = mutationpp-git
source = mutationpp::git+https://sync.vki.ac.be/mpp/mutationpp.git
source = 0001-Fix-some-issues-with-CMake.patch
sha256sums = SKIP
- sha256sums = d5dbbdbc394eb5725cdc7637768fb3bd6fc189784a4d2ef77cdd4811613565ff
+ sha256sums = 3471a798bc7a046d3b74c067ede3a953bdaeadae9b37f7a98898a31ff5ea09e2
pkgname = mutationpp-git
diff --git a/0001-Fix-some-issues-with-CMake.patch b/0001-Fix-some-issues-with-CMake.patch
index 8ef2f7d49c47..375bcc1ecbe3 100644
--- a/0001-Fix-some-issues-with-CMake.patch
+++ b/0001-Fix-some-issues-with-CMake.patch
@@ -1,4 +1,4 @@
-From b93afe7395e2c011945d910821e09d55fbfd06d6 Mon Sep 17 00:00:00 2001
+From 2b4a7f5d03dc605a9e2c0273d5e8c0d8c4777c07 Mon Sep 17 00:00:00 2001
From: Han Luo <han.luo@gmail.com>
Date: Fri, 31 Aug 2018 02:25:58 -0400
Subject: [PATCH] Fix some issues with CMake - Replace the absolute path
@@ -9,8 +9,8 @@ Subject: [PATCH] Fix some issues with CMake - Replace the absolute path
---
CMakeLists.txt | 6 ++++--
src/CMakeLists.txt | 5 +++++
- src/general/Errors.h | 4 ++--
- 3 files changed, 11 insertions(+), 4 deletions(-)
+ src/general/Errors.h | 8 ++++++--
+ 3 files changed, 15 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3781ef4..22ca3b1 100644
@@ -60,10 +60,21 @@ index d9437f8..8326ffe 100644
endforeach()
# append to global property
diff --git a/src/general/Errors.h b/src/general/Errors.h
-index 615989a..96377de 100644
+index 615989a..81988f7 100644
--- a/src/general/Errors.h
+++ b/src/general/Errors.h
-@@ -392,7 +392,7 @@ public:
+@@ -27,6 +27,10 @@
+ #ifndef ERRORS_H
+ #define ERRORS_H
+
++#ifndef __FILENAME__
++#define __FILENAME__ __FILE__
++#endif
++
+ //#include <algorithm>
+ #include <cstdlib>
+ #include <exception>
+@@ -392,7 +396,7 @@ public:
}
}; // class LogicError
@@ -72,7 +83,7 @@ index 615989a..96377de 100644
/// Reports a "function not implemented" error. Includes file, line number, and
-@@ -424,7 +424,7 @@ public:
+@@ -424,7 +428,7 @@ public:
}
};
diff --git a/PKGBUILD b/PKGBUILD
index 356c3ef10fbe..e9354639e84a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ makedepends=('git' 'gcc' 'cmake' 'gcc-fortran')
source=("$_pkgname::git+https://sync.vki.ac.be/mpp/mutationpp.git"
0001-Fix-some-issues-with-CMake.patch)
sha256sums=('SKIP'
- 'd5dbbdbc394eb5725cdc7637768fb3bd6fc189784a4d2ef77cdd4811613565ff')
+ '3471a798bc7a046d3b74c067ede3a953bdaeadae9b37f7a98898a31ff5ea09e2')
export MAKEFLAGS="-j"$(cat /proc/cpuinfo | awk '/^processor/{print $3}' | wc -l)
pkgver() {