summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2015-06-13 00:28:47 -0500
committerXavierCLL2015-06-13 00:28:47 -0500
commitd4fd25eff32ed3dc513c9e4ead6201d68af4752a (patch)
tree88c9ac3d6a29dcd3b42cb010a2b4930e96df30cb
downloadaur-d4fd25eff32ed3dc513c9e4ead6201d68af4752a.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bfa3b2c1815
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libqxt
+ pkgdesc = provides a suite of cross-platform utility classes to add functionality not readily available in the Qt toolkit
+ pkgver = 0.6.2
+ pkgrel = 4
+ url = http://www.libqxt.org
+ arch = i686
+ arch = x86_64
+ license = CPL
+ depends = qt4
+ depends = openssl
+ depends = db
+ optdepends = avahi
+ source = http://bitbucket.org/libqxt/libqxt/get/v0.6.2.tar.bz2
+ md5sums = a859a1757dc0aaf010df1a0783e3e001
+
+pkgname = libqxt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abdb1da61768
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
+# Contributor: Roberto Alsina <ralsina@kde.org>
+# Contributor: Tim Besard <tim.besard@gmail.com>
+
+pkgname=libqxt
+pkgver=0.6.2
+pkgrel=4
+pkgdesc="provides a suite of cross-platform utility classes to add functionality not readily available in the Qt toolkit"
+arch=('i686' 'x86_64')
+url="http://www.libqxt.org"
+license=('CPL')
+depends=('qt4' 'openssl' 'db')
+optdepends=('avahi')
+source=(http://bitbucket.org/libqxt/libqxt/get/v$pkgver.tar.bz2)
+md5sums=('a859a1757dc0aaf010df1a0783e3e001')
+
+build() {
+ cd $srcdir/$pkgname-*
+ ./configure -prefix /usr -qmake-bin "/usr/bin/qmake-qt4"
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-*
+ make INSTALL_ROOT=$pkgdir install
+}