summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiancarlo Razzolini2016-03-18 16:03:48 -0300
committerGiancarlo Razzolini2016-03-18 16:03:48 -0300
commitd50ac27f89a40fe89f09a8f99c9b400a29ccbeee (patch)
tree38ab0636378278574031e5c53dd2aca8cd894e95
parenta55790c3b3f4bb5df235fe699873b5519ad0d3ce (diff)
downloadaur-d50ac27f89a40fe89f09a8f99c9b400a29ccbeee.tar.gz
* Version 0.0.3.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--mkinitcpio-netconf.install15
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 997decf6992c..4f704bad4cca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Mar 18 19:03:36 UTC 2016
pkgbase = mkinitcpio-netconf
pkgdesc = Archlinux mkinitcpio hook for configuring early userspace networking
- pkgver = 0.0.2
+ pkgver = 0.0.3
pkgrel = 1
url = https://github.com/grazzolini/mkinitcpio-netconf
install = mkinitcpio-netconf.install
@@ -9,8 +11,8 @@ pkgbase = mkinitcpio-netconf
license = BSD
depends = mkinitcpio-nfs-utils
depends = iproute2
- source = https://github.com/grazzolini/mkinitcpio-netconf/archive/v0.0.2.tar.gz
- sha512sums = d63b763dd5093ac6f18042ce3c9971c0293bc4dcf364bfb4fb33cdfafc8b4eaed705cc90148e972bf8d8e5b34e636fe854b4c8613fa5e2f7a2859fa247434951
+ source = https://github.com/grazzolini/mkinitcpio-netconf/archive/v0.0.3.tar.gz
+ sha512sums = d526ced87ef13d6a4c22c22810b0024ca51095a82a28c210fc202e73499ca8aa7a16d3f45c3c549996fbd4ed220afa15df178f93aaacfc4a547d9042f69fa760
pkgname = mkinitcpio-netconf
diff --git a/PKGBUILD b/PKGBUILD
index c8d5a803dee8..0123725441cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Giancarlo Razzolini <grazzolini@gmail.com>
pkgname=mkinitcpio-netconf
-pkgver=0.0.2
+pkgver=0.0.3
pkgrel=1
pkgdesc="Archlinux mkinitcpio hook for configuring early userspace networking"
arch=('any')
@@ -10,7 +10,7 @@ depends=('mkinitcpio-nfs-utils' 'iproute2')
install=$pkgname.install
source=($url/archive/v$pkgver.tar.gz)
changelog='Changelog'
-sha512sums=('d63b763dd5093ac6f18042ce3c9971c0293bc4dcf364bfb4fb33cdfafc8b4eaed705cc90148e972bf8d8e5b34e636fe854b4c8613fa5e2f7a2859fa247434951')
+sha512sums=('d526ced87ef13d6a4c22c22810b0024ca51095a82a28c210fc202e73499ca8aa7a16d3f45c3c549996fbd4ed220afa15df178f93aaacfc4a547d9042f69fa760')
package() {
install -Dm644 "$srcdir/$pkgname-$pkgver/netconf_hook" "$pkgdir/usr/lib/initcpio/hooks/netconf"
diff --git a/mkinitcpio-netconf.install b/mkinitcpio-netconf.install
index c9940afc326e..c9e04f887c80 100644
--- a/mkinitcpio-netconf.install
+++ b/mkinitcpio-netconf.install
@@ -5,9 +5,11 @@ post_install() {
This hook will parse the ip= kernel command line variable and configure any
interfaces specified using ipconfig found in the mkinitcpio-nfs-utils package.
It is meant to be used alongside other hooks that need early userspace networking
- such as, mkinitcpio-dropbear. This hook doesn't support yet systemd enabled
- initramfs images. To use it, add the netconf hook before any other hook that need
- networking in "/etc/mkinitcpio.conf" and rebuild the initramfs.
+ such as, mkinitcpio-dropbear. There is also an optional netconf_timeout kernel
+ command line argument that can be used when obtaining the ip address using dhcp, so
+ that ipconfig will not hang forever waiting for an IP addres. To use this hook
+ add the netconf hook before any other hook that need networking in
+ "/etc/mkinitcpio.conf" and rebuild the initramfs.
INSTALLEOF
}
@@ -20,5 +22,10 @@ REMOVEEOF
}
post_upgrade() {
- post_install
+ cat<<UPGRADEEOF
+ There is now an optiona kernel command line parameter named netconf_timeout that
+ is used to pass the timeout option to ipconfig. This is means that when using
+ ip=dhcp as a kernel command line parameter, ipconfig will not hang forever if the
+ dhcp server is unavailable.
+UPGRADEEOF
}