summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhirui Dai2024-04-28 14:46:12 -0700
committerZhirui Dai2024-04-28 14:46:12 -0700
commitd50da057c737ca4954fc0cd3ecc9afa760cc94ba (patch)
tree591e86b940e41d0470b8087c3888b66e66a580f7
parent12446f3455c38a11fa0737b7465c740ce72e313f (diff)
downloadaur-d50da057c737ca4954fc0cd3ecc9afa760cc94ba.tar.gz
apply patch from upstream
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 26 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fe273096297..cf86035c54ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,13 @@ pkgbase = python-colcon-test-result
arch = any
license = Apache
makedepends = python-setuptools
+ makedepends = flake8
depends = python-colcon-core
- source = https://files.pythonhosted.org/packages/source/c/colcon-test-result/colcon-test-result-0.3.8.tar.gz
- sha256sums = aa5225716a5bdd9f1df721e7a04f1e02150def8c86dd070793cb62e747c36ed3
+ source = https://github.com/colcon/colcon-test-result/archive/refs/tags/0.3.8.tar.gz
+ source = upstream.path::https://github.com/colcon/colcon-test-result/compare/0.3.8...master.patch
+ source = https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz
+ sha256sums = b10643fd8de667e320843558aafbf7dd4f756b6addbbe7e03e08f5de6e375d06
+ sha256sums = 35986bb5ddcf824b113792504c273cceb25bc4c385e80d63fd810349775b531c
+ sha256sums = 04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082
pkgname = python-colcon-test-result
-
diff --git a/PKGBUILD b/PKGBUILD
index c4aaf9a87d21..59d08f7fa017 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,28 @@ arch=(any)
url="https://pypi.org/project/colcon-test-result"
license=('Apache')
depends=('python-colcon-core')
-makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
-sha256sums=('aa5225716a5bdd9f1df721e7a04f1e02150def8c86dd070793cb62e747c36ed3')
+makedepends=('python-setuptools' 'flake8')
+source=(
+ https://github.com/colcon/colcon-test-result/archive/refs/tags/${pkgver}.tar.gz
+ upstream.path::https://github.com/colcon/colcon-test-result/compare/0.3.8...master.patch
+ https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz)
+sha256sums=('b10643fd8de667e320843558aafbf7dd4f756b6addbbe7e03e08f5de6e375d06'
+ '35986bb5ddcf824b113792504c273cceb25bc4c385e80d63fd810349775b531c'
+ '04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082')
+build() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m build --wheel --no-isolation
+}
-package() {
+check() {
cd ${srcdir}/${_name}-${pkgver}
+ export PYTHONPATH="${srcdir}/scspell-2.2"
+ ls test*.py | xargs -I {} pytest {}
+}
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+package() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}