summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2021-04-07 22:54:18 -0400
committerAndrew O'Neill2021-04-07 22:54:18 -0400
commitd53c0d6c9c6de0c049b6eeb310858f58f136815c (patch)
treed09fcbd7baddf775f31738f881e87163c79822ee
parent64a2d82dd4325a7e208e726f88f2800b78f39629 (diff)
downloadaur-d53c0d6c9c6de0c049b6eeb310858f58f136815c.tar.gz
Adopt and upgrade
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD33
4 files changed, 35 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1709d823b94d..9bddc48195f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = ruby-jwt
pkgdesc = JSON Web Token implementation in Ruby
- pkgver = 2.2.1
+ pkgver = 2.2.2
pkgrel = 1
- url = http://github.com/jwt/ruby-jwt
- arch = any
+ url = https://github.com/jwt/ruby-jwt
+ arch = x86_64
license = MIT
+ makedepends = ruby-rake
depends = ruby
- noextract = jwt-2.2.1.gem
- options = !emptydirs
- source = https://rubygems.org/downloads/jwt-2.2.1.gem
- sha1sums = 383136036dc768c7dcae69f2722ef23c9efbbc15
+ depends = ruby-rdoc
+ source = https://rubygems.org/downloads/jwt-2.2.2.gem
+ source = LICENSE
+ sha256sums = 56a47115e514b9cfba93b8067332462a74ecbcea843a0784bc7a208203f6d693
+ sha256sums = b9f95c496bd9dba93a2b6ee6382f4692918e8648f2d9dab03e93457f8b71ac4c
pkgname = ruby-jwt
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 05c6d4d4c97b..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!.gitignore
-!.SRCINFO
-!PKGBUILD
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..927c375f49d2
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Copyright (c) 2011 Jeff Lindsay
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 15c0b9a2b93d..fbf65b639cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
-# Maintainer: farawayer <farwayer@gmail.com>
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Contributor: farawayer <farwayer@gmail.com>
_gemname=jwt
-pkgname=ruby-$_gemname
-pkgver=2.2.1
+pkgname=ruby-${_gemname}
+pkgver=2.2.2
pkgrel=1
pkgdesc='JSON Web Token implementation in Ruby'
-arch=(any)
-url='http://github.com/jwt/ruby-jwt'
-license=(MIT)
-depends=(ruby)
-options=(!emptydirs)
-source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
-noextract=($_gemname-$pkgver.gem)
-sha1sums=('383136036dc768c7dcae69f2722ef23c9efbbc15')
+arch=('x86_64')
+url='https://github.com/jwt/ruby-jwt'
+license=('MIT')
+depends=('ruby' 'ruby-rdoc')
+makedepends=('ruby-rake')
+source=("https://rubygems.org/downloads/${_gemname}-${pkgver}.gem"
+ "LICENSE")
+sha256sums=('56a47115e514b9cfba93b8067332462a74ecbcea843a0784bc7a208203f6d693'
+ 'b9f95c496bd9dba93a2b6ee6382f4692918e8648f2d9dab03e93457f8b71ac4c')
package() {
+ cd "${srcdir}"
+
local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
- rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
- install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ gem install --ignore-dependencies --no-user-install -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" ${_gemname}-${pkgver}.gem
+ rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+