summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-16 11:39:43 -0600
committerMark Wagie2021-10-16 11:39:43 -0600
commitd5cd4a8ab3038749c79a3e94eb12128f477f17f3 (patch)
tree89c72ee6db7afa13024be788dac161224a92a9d9
downloadaur-d5cd4a8ab3038749c79a3e94eb12128f477f17f3.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD37
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..796bc79c4cc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hidpi-daemon-git
+ pkgdesc = Daemon to manage HiDPI and LoDPI monitors on X
+ pkgver = 18.04.6.r1.g8f165bb
+ pkgrel = 1
+ url = https://github.com/pop-os/hidpi-daemon
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = acpid
+ depends = libnotify
+ depends = python-gobject
+ depends = python-pydbus
+ depends = python-xlib
+ provides = hidpi-daemon
+ conflicts = hidpi-daemon
+ conflicts = system76-hidpi-daemon
+ replaces = system76-hidpi-daemon-git
+ source = git+https://github.com/pop-os/hidpi-daemon.git
+ sha256sums = SKIP
+
+pkgname = hidpi-daemon-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afcb2f903c0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=hidpi-daemon-git
+pkgver=18.04.6.r1.g8f165bb
+pkgrel=1
+pkgdesc="Daemon to manage HiDPI and LoDPI monitors on X"
+arch=('any')
+url="https://github.com/pop-os/hidpi-daemon"
+license=('GPL2')
+depends=('acpid' 'libnotify' 'python-gobject' 'python-pydbus' 'python-xlib')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" "system76-${pkgname%-git}")
+replaces=("system76-$pkgname")
+source=('git+https://github.com/pop-os/hidpi-daemon.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm755 "${pkgname%-git}" hidpi-notification prime-dialog -t \
+ "$pkgdir/usr/lib/${pkgname%-git}"
+ install -Dm644 "${pkgname%-git}.desktop" hidpi-frontend.desktop -t \
+ "$pkgdir/etc/xdg/autostart"
+ install -Dm644 com.system76.hidpi.gschema.xml -t "$pkgdir/usr/share/glib-2.0/schemas"
+ install -d "$pkgdir/var/lib/${pkgname%-git}"
+}