aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrognon2016-10-22 07:55:14 +0200
committergrognon2016-10-22 07:55:14 +0200
commitd60c109d3d21fb10f77ed3662941a4e621ee8b0d (patch)
treeed2bb6069dde10d276cb3026f66e44e25365e853
downloadaur-d60c109d3d21fb10f77ed3662941a4e621ee8b0d.tar.gz
First commit to Aur
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
-rw-r--r--brother-dcpj140w.install27
-rw-r--r--fix_lp.patch11
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f842f725dc04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Oct 21 20:40:47 UTC 2016
+pkgbase = brother-dcpj140w
+ pkgdesc = Driver for the Brother DCP-J315W wifi multifuncional printer
+ pkgver = 1.1.3
+ pkgrel = 3
+ url = http://solutions.brother.com/linux/en_us/index.html
+ install = brother-dcpj140w.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ makedepends = rpmextract
+ depends = a2ps
+ depends = cups
+ source = fix_lp.patch
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj140wlpr-1.1.3-6.i386.rpm
+ source = http://www.brother.com/pub/bsc/linux/dlf/dcpj140wcupswrapper-1.1.3-6.i386.rpm
+ md5sums = 69229583e5d43d82e5655f74729c05ba
+ md5sums = 599a7667f2c805d5dbc2fa655832f17c
+ md5sums = fa2d50677492bfc83e27184f316061c3
+
+pkgname = brother-dcpj140w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88f1996cebde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Alessio Bianchi <venator85@gmail.com>
+# Contributor: Jacek Roszkowski <j.roszk@gmail.com>
+# Contributor: Javier Cordero <jneight@gmail.com>
+# Contributor: Vieux Grognon <vieux@grognon.net>
+# Maintainer: Vieux Grognon <vieux@grognon.net>
+
+pkgname=brother-dcpj140w
+pkgver=1.1.3
+pkgrel=3
+pkgdesc="Driver for the Brother DCP-J315W wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install="brother-dcpj140w.install"
+arch=('i686' 'x86_64')
+
+md5sums=('69229583e5d43d82e5655f74729c05ba'
+ '599a7667f2c805d5dbc2fa655832f17c'
+ 'fa2d50677492bfc83e27184f316061c3')
+
+source=(
+ "fix_lp.patch" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj140wlpr-$pkgver-6.i386.rpm" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj140wcupswrapper-$pkgver-6.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+post_install() {
+ /opt/brother/Printers/dcpj140w/cupswrapper/cupswrapperdcpj140w
+}
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj140w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+}
diff --git a/brother-dcpj140w.install b/brother-dcpj140w.install
new file mode 100644
index 000000000000..51bfdab082e5
--- /dev/null
+++ b/brother-dcpj140w.install
@@ -0,0 +1,27 @@
+post_install() {
+ # lpr
+ /opt/brother/Printers/dcpj140w/inf/setupPrintcapij dcpj140w -i
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj140w/cupswrapper/cupswrapperdcpj140w
+
+ systemctl restart org.cups.cupsd.service
+}
+
+post_upgrade() {
+ /bin/true
+}
+
+pre_remove() {
+ # lpr
+ /opt/brother/Printers/dcpj140w/inf/setupPrintcapij dcpj140w -e
+
+ # cupswrapper
+ /opt/brother/Printers/dcpj140w/cupswrapper/cupswrapperdcpj140w -e
+}
+
+op=$1
+shift
+
+$op "$@"
+
diff --git a/fix_lp.patch b/fix_lp.patch
new file mode 100644
index 000000000000..a3cb76cdee33
--- /dev/null
+++ b/fix_lp.patch
@@ -0,0 +1,11 @@
+--- opt/brother/Printers/dcpj140w/inf/setupPrintcapij.old 2008-09-15 22:01:07.000000000 +0200
++++ opt/brother/Printers/dcpj140w/inf/setupPrintcapij 2008-09-15 22:01:26.000000000 +0200
+@@ -34,7 +34,7 @@
+ if [ ! -d $SPOOLER_NAME ]; then
+ mkdir $SPOOLER_NAME
+ fi
+- chown lp $SPOOLER_NAME
++ chown root $SPOOLER_NAME
+ chgrp lp $SPOOLER_NAME
+ chmod 700 $SPOOLER_NAME
+