summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2021-02-13 20:20:32 +0100
committerD3SOX2021-02-13 20:20:32 +0100
commitd614cd00547cb02525409888f6311e56c5d1a12a (patch)
tree675f4f3cf9d4fe5276f42d3b1ac673a80d7bd3b2
downloadaur-d614cd00547cb02525409888f6311e56c5d1a12a.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cee80abc4906
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tunnelto-bin
+ pkgdesc = Expose your local web server to the internet with a public URL.
+ pkgver = 0.1.12
+ pkgrel = 1
+ url = https://tunnelto.dev/
+ arch = any
+ license = MIT
+ makedepends = cargo
+ provides = tunnelto
+ conflicts = tunnelto
+ source = https://github.com/agrinman/tunnelto/releases/download/0.1.12/tunnelto-linux.tar.gz
+ sha256sums = 21169fe2bacf3e60db4a8ac95b96491df8e1ff9608ab1154d6178fa1774df0f7
+
+pkgname = tunnelto-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..27ab922b9914
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nico <d3sox at protonmail dot com>
+pkgname=tunnelto-bin
+_gitname=${pkgname%-bin}
+pkgver=0.1.12
+pkgrel=1
+pkgdesc="Expose your local web server to the internet with a public URL."
+arch=('any')
+url="https://tunnelto.dev/"
+license=('MIT')
+makedepends=('cargo')
+conflicts=('tunnelto')
+provides=('tunnelto')
+source=("https://github.com/agrinman/$_gitname/releases/download/$pkgver/tunnelto-linux.tar.gz")
+sha256sums=('21169fe2bacf3e60db4a8ac95b96491df8e1ff9608ab1154d6178fa1774df0f7')
+
+package() {
+ # install binary
+ install -Dm 755 "${srcdir}/tunnelto" -t "${pkgdir}/usr/bin"
+}