summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkillermoehre2015-06-26 21:28:50 +0200
committerkillermoehre2015-06-26 21:28:50 +0200
commitd62ecc86b7ed042b4bc74fa4f05b9d692e4146d0 (patch)
treee805fc189c1820a2fff9954548cf97a527fa9825
downloadaur-d62ecc86b7ed042b4bc74fa4f05b9d692e4146d0.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
-rw-r--r--xfce4-hotcorner-plugin.install13
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62b33c8cc64d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = xfce4-hotcorner-plugin-git
+ pkgdesc = Provides an easy way to set up hot corners in the Xfce desktop environment
+ pkgver = 0.0.1.r0.g8faf057
+ pkgrel = 1
+ url = https://github.com/brianhsu/xfce4-hotcorner-plugin
+ install = xfce4-hotcorner-plugin.install
+ arch = i686
+ arch = x86_64
+ groups = xfce4
+ license = GPL2
+ makedepends = cmake
+ makedepends = xfce4-dev-tools
+ makedepends = git
+ depends = xfce4-panel
+ depends = libwnck
+ conflicts = xfce4-hotcorner-plugin
+ source = xfce4-hotcorner-plugin::git+https://github.com/brianhsu/xfce4-hotcorner-plugin.git
+ sha256sums = SKIP
+
+pkgname = xfce4-hotcorner-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dea490864b52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Silvio Knizek <killermoehre@gmx.net>
+
+_pkgname=xfce4-hotcorner-plugin
+pkgname="${_pkgname}-git"
+pkgver=0.0.1.r0.g8faf057
+pkgrel=1
+pkgdesc="Provides an easy way to set up hot corners in the Xfce desktop environment"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="https://github.com/brianhsu/xfce4-hotcorner-plugin"
+groups=("xfce4")
+depends=('xfce4-panel' 'libwnck')
+makedepends=('cmake' 'xfce4-dev-tools' 'git')
+provides=("${_pgname}")
+conflicts=("${_pkgname}")
+install="${_pkgname}.install"
+source=("${_pkgname}::git+https://github.com/brianhsu/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -r "s/^${_pkgname}-//;s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/xfce4-hotcorner-plugin.install b/xfce4-hotcorner-plugin.install
new file mode 100644
index 000000000000..e4f8fd06c1ed
--- /dev/null
+++ b/xfce4-hotcorner-plugin.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: