summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112019-01-01 19:32:15 +0100
committerjose17112019-01-01 19:32:15 +0100
commitd6485b8f35d4a1e5def9c1b2c9eea619ec5e9f24 (patch)
tree2102ce8698e0609fdc22637736f9e0e0cc2bdb5e
downloadaur-d6485b8f35d4a1e5def9c1b2c9eea619ec5e9f24.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07731085a0cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Jan 1 18:32:11 UTC 2019
+pkgbase = lib32-rrdtool
+ pkgdesc = Data logging and graphing application (32-bit - binaries and libs only)
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = http://www.rrdtool.org
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = intltool
+ depends = lib32-glibc
+ depends = lib32-libxml2
+ depends = lib32-pango
+ depends = ttf-dejavu
+ options = !emptydirs
+ options = !makeflags
+ source = http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.7.0.tar.gz
+ sha1sums = 15a2009e2ee67eb41a2598d1a0f1f7cf1a651c78
+
+pkgname = lib32-rrdtool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a0643933a43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=lib32-rrdtool
+_pkgname=rrdtool
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="Data logging and graphing application (32-bit - binaries and libs only)"
+arch=('x86_64')
+url="http://www.rrdtool.org"
+license=('GPL' 'custom')
+depends=('lib32-glibc' 'lib32-libxml2' 'lib32-pango' 'ttf-dejavu')
+makedepends=('intltool')
+options=('!emptydirs' '!makeflags')
+source=(http://oss.oetiker.ch/rrdtool/pub/rrdtool-${pkgver}.tar.gz)
+sha1sums=('15a2009e2ee67eb41a2598d1a0f1f7cf1a651c78')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ export CC="gcc -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ aclocal
+ automake
+}
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ export CC="gcc -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ ./configure --prefix=/usr --localstatedir=/var --disable-rpath \
+ --disable-perl --disable-perl-site-install \
+ --disable-ruby --disable-ruby-site-install --disable-python \
+ --disable-lua --disable-lua-site-install --disable-tcl --disable-libwrap \
+ --disable-examples --libdir=/usr/lib32 --disable-docs --disable-nls --disable-librados
+ make LIBS+="-lglib-2.0"
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install-exec
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.32bit"
+ for bin in "${pkgdir}"/usr/bin/*
+ do
+ mv "${bin}" "${bin}_32"
+ done
+}