summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2016-03-22 22:00:06 -0700
committerDavid McInnis2016-03-22 22:00:06 -0700
commitd64c0fdc0a78f112ef3f3cdbcb477f52d1b2d3b3 (patch)
tree2e1088ddf56a7af573afcc819b4f672eeba61059
downloadaur-d64c0fdc0a78f112ef3f3cdbcb477f52d1b2d3b3.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9f62684b0fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Mar 23 04:59:43 UTC 2016
+pkgbase = python-pydot-ng
+ pkgdesc = Python interface to Graphviz's Dot Language, updated version
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/pydot/pydot-ng
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-pyparsing
+ depends = python-pygraphviz
+ source = https://pypi.python.org/packages/source/p/pydot-ng/pydot_ng-1.0.0.tar.gz
+ source = LICENSE.txt::https://github.com/pydot/pydot-ng/blob/master/LICENSE?raw=true
+ sha256sums = c420ecd08ec34c76bec98fbc1956d58a8f0bbd7b4e1d2dc90664d9fd29471341
+ sha256sums = 6c5d9398c6a89864f5765375fd34529df9d6c929ca532a4e076b7451dfcec357
+
+pkgname = python-pydot-ng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac2ff53fb893
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+#Maintainer: David McInnis <davidm@eagles.ewu.edu>
+
+pkgname=('python-pydot-ng')
+_module='pydot_ng'
+pkgver='1.0.0'
+pkgrel=1
+pkgdesc="Python interface to Graphviz's Dot Language, updated version"
+url="https://github.com/pydot/pydot-ng"
+depends=('python-pyparsing' 'python-pygraphviz')
+makedepends=('python-setuptools')
+#checkdepends=('python-unittest2py3k' 'python-pytest') Test doesn't work current release
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/p/pydot-ng/pydot_ng-${pkgver}.tar.gz"
+ "LICENSE.txt::https://github.com/pydot/pydot-ng/blob/master/LICENSE?raw=true")
+sha256sums=('c420ecd08ec34c76bec98fbc1956d58a8f0bbd7b4e1d2dc90664d9fd29471341'
+ '6c5d9398c6a89864f5765375fd34529df9d6c929ca532a4e076b7451dfcec357')
+
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 ../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}