summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAustin Cross2023-09-25 19:26:11 -0500
committerAustin Cross2023-09-25 19:26:15 -0500
commitd66b4b25bc3164b464f29e0c46899a8c81f7401a (patch)
tree51413fb7eedbece01b180195c3b9c2ccd247be90
parent1f34bb5e54b91e29c86706b62ddf5032c20a16b9 (diff)
downloadaur-d66b4b25bc3164b464f29e0c46899a8c81f7401a.tar.gz
Upgrade to v1.7.0
- New NWS EMC distribution of g2c library using CMake build system - Switch from old NWS tarball distribution to GitHub release - Switch from NWS public domain license to LGPL per GitHub repo
-rw-r--r--.SRCINFO12
-rw-r--r--NWS_license.txt55
-rw-r--r--PKGBUILD31
3 files changed, 16 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 896481cec5f4..e7b024ee1214 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = g2clib
pkgdesc = GRIB2 encoder/decoder (C version)
- pkgver = 1.6.0
- pkgrel = 2
+ pkgver = 1.7.0
+ pkgrel = 1
url = http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2
arch = i686
arch = x86_64
- license = custom:NWS
+ license = LGPL3
depends = jasper
depends = libpng
provides = g2clib
options = staticlibs
- source = http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2/g2clib-1.6.0.tar
- source = NWS_license.txt
- md5sums = 8f088bb3a831bb4e7835d0a67c28873c
- md5sums = 64f9f7f5ad383df409986d8a67d2fa78
+ source = https://github.com/NOAA-EMC/NCEPLIBS-g2c/archive/refs/tags/v1.7.0.tar.gz
+ md5sums = 8bfdce4e3494d6502b14d6abd599e8d8
pkgname = g2clib
diff --git a/NWS_license.txt b/NWS_license.txt
deleted file mode 100644
index 7c30166a5a22..000000000000
--- a/NWS_license.txt
+++ /dev/null
@@ -1,55 +0,0 @@
-http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2
-
-NCEP codes for decoding and encoding data in GRIB2 format
-
-Note: These codes are provided as is for the use of NCEP data users. NCEP does
-not and can not provide any support for them.
-
-http://www.weather.gov/disclaimer
-
-Disclaimer
- National Weather Service
- National Headquarters
-[...]
-
-Use of Data and Products
-
- The information on National Weather Service (NWS) Web pages are in the public
- domain, unless specifically noted otherwise, and may be used without charge
- for any lawful purpose so long as you do not: 1) claim it is your own (e.g.,
- by claiming copyright for NWS information -- see below), 2) use it in a
- manner that implies an endorsement or affiliation with NOAA/NWS, or 3)
- modify its content and then present it as official government material. You
- also cannot present information of your own in a way that makes it appear to
- be official government information.
-
- Use of the NWS name ("National Weather Service") and/or visual identifier
- are protected under trademark law and may not be used without permission
- from the NWS. Use of the NWS name and/ or visual identifier to identify
- unaltered NWS content or links to NWS web sites are allowable uses.
- Permission may be requested for this use at
- http://www.weather.gov/logorequest. Permission is not required to display
- unaltered NWS products which include the NWS name or NWS/NOAA visual
- identifier as part of the original product. Neither the name nor visual
- identifier may be used, however, in a manner that implies an endorsement or
- affiliation with NOAA/NWS.
-
- Before using information obtained from any NWS Web page special attention
- should be given to the date and time of the data and products being
- displayed.
-
- The user assumes the entire risk related to its use of information on NWS
- Web pages. NWS is provides such information "as is," and NWS disclaims any
- and all warranties, whether express or implied, including (without
- limitation) any implied warranties of merchantability or fitness for a
- particular purpose. In no event will NWS be liable to you or to any third
- party for any direct, indirect, incidental, consequential, special or
- exemplary damages or lost profit resulting from any use or misuse of this
- data.
-
- As required by 17 U.S.C. ยง 403, third parties producing copyrighted works
- consisting predominantly of the material appearing in NWS Web pages must
- provide notice with such work(s) identifying the NWS material incorporated
- and stating that such material is not subject to copyright protection.
-
-[...]
diff --git a/PKGBUILD b/PKGBUILD
index 816e2a98d886..3e0eecade827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,28 @@
# Contributor: Graziano Giuliani
# Maintainer : Austin Cross <austincross@gmail.com>
pkgname=g2clib
-pkgver=1.6.0
-pkgrel=2
+pkgver=1.7.0
+pkgrel=1
pkgdesc="GRIB2 encoder/decoder (C version)"
url="http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2"
-license=("custom:NWS")
+license=("LGPL3")
arch=('i686' 'x86_64')
provides=(g2clib)
depends=(jasper libpng)
options=('staticlibs')
-source=(http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2/${pkgname}-${pkgver}.tar
- NWS_license.txt)
-md5sums=('8f088bb3a831bb4e7835d0a67c28873c'
- '64f9f7f5ad383df409986d8a67d2fa78')
+source=(https://github.com/NOAA-EMC/NCEPLIBS-g2c/archive/refs/tags/v${pkgver}.tar.gz)
+md5sums=('8bfdce4e3494d6502b14d6abd599e8d8')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- export CFLAGS="${CFLAGS} -fPIC"
- export CXXFLAGS="${CXXFLAGS} -fPIC"
- sed -i makefile -e 's/-X64//' -e '/CFLAGS=/d' -e '/CC=/d'
- sed -i 's/image.inmem_.*=.*1;//' enc_jpeg2000.c
- CC=gcc CFLAGS="$CFLAGS -DUSE_JPEG2000 -DUSE_PNG" make
+ cmake -B build -S "NCEPLIBS-g2c-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- mkdir -p ${pkgdir}/usr/{lib,include,share/licenses/${pkgname}}
- install -m 644 libg2c_v1.6.0.a ${pkgdir}/usr/lib/libg2c_v1.6.0.a
- ln -sf libg2c_v1.6.0.a ${pkgdir}/usr/lib/libg2c.a
- install -m 644 *.h ${pkgdir}/usr/include
- install -m 644 ${srcdir}/NWS_license.txt \
- ${pkgdir}/usr/share/licenses/${pkgname}/NWS
+ DESTDIR="$pkgdir" cmake --install build
}
# vim:set ts=2 sw=2 et: