summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2021-07-08 12:01:24 -0700
committerKyle Manna2021-07-08 12:14:10 -0700
commitd6b7aedc94cfa7a3e524c0159707bdd8bbe08b0c (patch)
tree3a78c099ee8bb25598d029b02f80b5d3512d66eb
parentc6369a53feb7f67c33438a573eec4178d8248beb (diff)
downloadaur-d6b7aedc94cfa7a3e524c0159707bdd8bbe08b0c.tar.gz
release: v1.6.4
* Bump release and include patch to work around dependency issue. * Add missing make depends for chroot: * clang -> bindgen-0.57.0 * cmake -> h3ron-h3-sys-0.10.0
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
3 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d690eb323cf..b3da78d079a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = helium-wallet
pkgdesc = Helium Wallet
- pkgver = 1.5.2
+ pkgver = 1.6.4
pkgrel = 1
url = https://github.com/helium/helium-wallet-rs
arch = x86_64
@@ -8,8 +8,9 @@ pkgbase = helium-wallet
depends = rust
depends = cargo
depends = openssl
- source = https://github.com/helium/helium-wallet-rs/archive/refs/tags/v1.5.2.tar.gz
- sha512sums = 1897a335aac68c5488e23c786eed5849f22f0293d117cc3cadb6b4de49d782452bec72fcd3f7e1a71355329bff61f2157bb22a1f877faf8fcdea43850ac2420c
+ source = https://github.com/helium/helium-wallet-rs/archive/refs/tags/v1.6.4.tar.gz
+ source = https://github.com/helium/helium-wallet-rs/pull/172/commits/818f1648f6f532ee529db3354579b1219d2b2a52.patch
+ sha512sums = dddb5867e5238681658c9cc0d50a3a5fc7f48734cc21a2d3e6fedf508c0410f0b5b5be48935b6a8c2b475a8fc29d3452630d3eeb234c92ccc89ef3b80ff485dd
+ sha512sums = 2868cdbba25b76fca5fc3570f6a6b41348710179a15a36afd0c53580eb0cad8b42aa0c5c0ace17382c3dfa7ee9b0b7f371e3fcf7bd42ddac0698a3b7191ed14e
pkgname = helium-wallet
-
diff --git a/.gitignore b/.gitignore
index 39a7534dd9ea..8452f11b6d5b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,5 @@
*.tar.zst
/pkg
/src
+/*.patch
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
index affe256b493f..4e938a2668e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname=helium-wallet-rs
pkgdesc='Helium Wallet'
license=('Apache')
url='https://github.com/helium/helium-wallet-rs'
-pkgver=1.5.2
+pkgver=1.6.4
pkgrel=1
arch=('x86_64')
depends=(
@@ -13,19 +13,32 @@ depends=(
'cargo'
'openssl'
)
+makedepends=(
+ 'cmake'
+ 'clang'
+)
source=(
"https://github.com/helium/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
+ "https://github.com/helium/helium-wallet-rs/pull/172/commits/818f1648f6f532ee529db3354579b1219d2b2a52.patch"
)
-sha512sums=('1897a335aac68c5488e23c786eed5849f22f0293d117cc3cadb6b4de49d782452bec72fcd3f7e1a71355329bff61f2157bb22a1f877faf8fcdea43850ac2420c')
+sha512sums=('dddb5867e5238681658c9cc0d50a3a5fc7f48734cc21a2d3e6fedf508c0410f0b5b5be48935b6a8c2b475a8fc29d3452630d3eeb234c92ccc89ef3b80ff485dd'
+ '2868cdbba25b76fca5fc3570f6a6b41348710179a15a36afd0c53580eb0cad8b42aa0c5c0ace17382c3dfa7ee9b0b7f371e3fcf7bd42ddac0698a3b7191ed14e')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ # Drop this on v1.6.5 or later release, this fixes dependency breakage
+ # which is still not tagged.
+ patch --forward --strip=1 --input="${srcdir}/818f1648f6f532ee529db3354579b1219d2b2a52.patch"
+}
build() {
cd ${_pkgname}-${pkgver}
+ RUSTUP_TOOLCHAIN=stable cargo build --release --locked --all-features --target-dir=target
+}
- # Test with rustup:
- # info: latest update on 2021-03-25, rust version 1.51.0 (2fd73fabe 2021-03-23)
- # `rustup update`
- cargo update --workspace
- cargo build --release
+check() {
+ cd ${_pkgname}-${pkgver}
+ RUSTUP_TOOLCHAIN=stable cargo test --locked --target-dir=target
}
package() {