summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-03-02 00:04:49 +0100
committerJohannes Dewender2013-03-02 00:04:49 +0100
commitd6c3f51ac62cecad7e177c070baca1d45f3e7cd2 (patch)
tree27d8d5e8eff469f1453eac2a98da6850797a81d4
parentc92945f44407eaa6c1ce343a9d3821776b19473d (diff)
downloadaur-d6c3f51ac62cecad7e177c070baca1d45f3e7cd2.tar.gz
holyspirit-svn: add qt-includes.patch
It compiles without errors now.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--qt-includes.patch16
3 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df3b11432355..3fdfdbdb2358 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,9 +19,11 @@ pkgbase = holyspirit-svn
source = holyspirit.sh
source = config_crash.patch
source = backspace.patch
+ source = qt-includes.patch
md5sums = c2fa4f8768d35c54a95dec924e50c75f
md5sums = c0fd6d1ede2cb6afbcf082aaae0cc60b
md5sums = 4967f1cd4216d1ec2ff3cfd1941b18df
+ md5sums = 97fde790c28fd547be56a8c0d9e2029a
pkgname = holyspirit-svn
diff --git a/PKGBUILD b/PKGBUILD
index 138ab2bd222b..4839a6c722a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,11 +14,12 @@ optdepends=('qtwebkit: for the launcher')
provides=('holyspirit')
conflicts=('holyspirit')
install=holyspirit.install
-source=(holyspirit.sh config_crash.patch backspace.patch)
+source=(holyspirit.sh config_crash.patch backspace.patch qt-includes.patch)
backup=('opt/share/games/holyspirit/configuration.conf' 'opt/share/games/holyspirit/key_mapping.conf')
md5sums=('c2fa4f8768d35c54a95dec924e50c75f'
'c0fd6d1ede2cb6afbcf082aaae0cc60b'
- '4967f1cd4216d1ec2ff3cfd1941b18df')
+ '4967f1cd4216d1ec2ff3cfd1941b18df'
+ '97fde790c28fd547be56a8c0d9e2029a')
_svntrunk=https://lechemindeladam.svn.sourceforge.net/svnroot/lechemindeladam/trunk
_svnmod=holyspirit
@@ -43,6 +44,7 @@ build() {
# patches
patch -p1 < ../config_crash.patch
patch -p1 < ../backspace.patch
+ patch -p2 < ../qt-includes.patch
cmake -DSFML_STATIC_LIBRARIES=FALSE \
-DCMAKE_INSTALL_PREFIX:STRING="$pkgdir/opt"
diff --git a/qt-includes.patch b/qt-includes.patch
new file mode 100644
index 000000000000..718e7d0ce507
--- /dev/null
+++ b/qt-includes.patch
@@ -0,0 +1,16 @@
+From: Johannes Dewender <jonnyjd@users.sf.net>
+Date: Sat, 02 Mar 2013 00:02:34 +0100
+Subject: [PATCH] add QtNetwork to includes for QHttp
+
+Index: holyspirit/trunk/Launcher/Launcher.h
+===================================================================
+--- holyspirit.orig/trunk/Launcher/Launcher.h
++++ holyspirit/trunk/Launcher/Launcher.h
+@@ -5,6 +5,7 @@
+ #include <QPushButton>
+ #include <QMessageBox>
+ #include <QtWebKit>
++#include <QtNetwork>
+
+ #include "defines.h"
+ #include "optionsjeu.h"