summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenton Liu2022-10-24 02:45:56 -0700
committerDenton Liu2022-10-24 02:45:56 -0700
commitd6cf1cde293d8170e3de6860c12c93e9bf9d34ba (patch)
tree2df707c13840c42371cadf1e2183d3b317ac64d0
parent003ea753dfc8ec1c349964d1a72b61afd6eef3e9 (diff)
downloadaur-d6cf1cde293d8170e3de6860c12c93e9bf9d34ba.tar.gz
PKGBUILD: fix generated package file
Since we're overriding $pkgname, the generated output filename currently is `ddclient-v3.10.0.r0.g3e2cb0a-1-any.pkg.tar.zst`. This is incorrect because we lost the `-git` suffix. Ensure that the $pkgname is not overridden by the end of package(). Reported-by: jahway603 <jahway603@protonmail.com>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d74d2515a26..38e0f1881845 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddclient-git
pkgdesc = Update dynamic DNS entries for accounts on many dynamic DNS services
- pkgver = v3.8.3.r582.g8253c67
+ pkgver = v3.10.0.r0.g3e2cb0a
pkgrel = 1
url = https://github.com/ddclient/ddclient
arch = any
@@ -20,4 +20,3 @@ pkgbase = ddclient-git
sha256sums = 6133eefbb4315ee2a7b24044ba9c2d5c4f9d19381eab8071415bf4dc73c1cf09
pkgname = ddclient-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 94c0d98c95a6..57e2ac3c6ded 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=ddclient-git
_gitname="${pkgname%-git}"
-pkgver=v3.8.3.r582.g8253c67
+pkgver=v3.10.0.r0.g3e2cb0a
pkgrel=1
pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services"
@@ -51,6 +51,7 @@ check() {
package() {
# hack so that we can merge in changes from upstream without changing all the
# $pkgname to $_gitname
+ (
pkgname="$_gitname"
cd ddclient
@@ -64,4 +65,6 @@ package() {
install -Dm644 sample-etc_cron.d_ddclient "$pkgdir"/usr/share/doc/ddclient/sample-etc_cron.d_ddclient
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
+
+ )
}