summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChester Wisniewski2020-05-29 13:52:41 -0700
committerChester Wisniewski2020-05-29 13:52:41 -0700
commitd6d9cda8d58a562016031e812b8bea07558a2f7d (patch)
tree2be09f3af618ebb71f0d17f2f332b0cb39eb0cd1
parent847c328e629dfca7d94856b04ba7685c41f3d297 (diff)
downloadaur-d6d9cda8d58a562016031e812b8bea07558a2f7d.tar.gz
Updated to version 1.5.11, changed to website builds from git to fix missing vendor folder
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e6907e66832..6d53e8720d54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = invoiceplane
pkgdesc = Self hosted invoicing for freelancers and small businesses
- pkgver = 1.5.10
+ pkgver = 1.5.11
pkgrel = 1
url = https://invoiceplane.com/
arch = any
license = MIT
depends = php
- source = invoiceplane-1.5.10.tar.gz::https://github.com/InvoicePlane/InvoicePlane/archive/v1.5.10.tar.gz
- sha256sums = 8b71dc4c4cfc6e3ebed89db8486c830e49aec0b25989df70c02a8e98cef6240a
+ source = invoiceplane-1.5.11.zip::https://www.invoiceplane.org/download/v1.5.11
+ sha256sums = 4de189ee5a0c8b57c075d9b6d48cf2ebbd8802c504fd57dc91634da26f07ef8c
pkgname = invoiceplane
diff --git a/PKGBUILD b/PKGBUILD
index 007042e53463..ac80d1abb704 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Marcin Wieczorek <marcin@marcin.co>
+# Maintainer: Marcin Wieczorek <marcin@marcin.co>
+# Maintainer: Chester Wisniewski <chetw@zuzax.com>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
# Contributor: Witit Sujjapong <switit@gmail.com>
pkgname=invoiceplane
-pkgver=1.5.10
+pkgver=1.5.11
pkgrel=1
pkgdesc="Self hosted invoicing for freelancers and small businesses"
arch=('any')
@@ -11,11 +12,13 @@ url="https://invoiceplane.com/"
license=('MIT')
depends=('php')
#optdepends=('php-mysql: for MySQL database support')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/InvoicePlane/InvoicePlane/archive/v${pkgver}.tar.gz")
-sha256sums=('8b71dc4c4cfc6e3ebed89db8486c830e49aec0b25989df70c02a8e98cef6240a')
+source=("${pkgname}-${pkgver}.zip::https://www.invoiceplane.org/download/v${pkgver}")
+sha256sums=('4de189ee5a0c8b57c075d9b6d48cf2ebbd8802c504fd57dc91634da26f07ef8c')
package() {
- install -d "${pkgdir}/usr/share/webapps"
- cp -a "InvoicePlane-${pkgver}" "${pkgdir}/usr/share/webapps/invoiceplane"
- install -Dm644 "InvoicePlane-${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ${srcdir}
+ install -dm755 "${pkgdir}/usr/share/webapps/invoiceplane"
+ rm "${pkgname}-${pkgver}.zip"
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cp -a * "${pkgdir}/usr/share/webapps/invoiceplane"
}