summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHalosGhost2015-07-31 12:28:55 -0500
committerHalosGhost2015-07-31 12:28:55 -0500
commitd6e54f3c0f4c95df776e8d911964e86de2b2b6a3 (patch)
tree7dacf7518d32beb96683acb0d113e3168169b443
downloadaur-d6e54f3c0f4c95df776e8d911964e86de2b2b6a3.tar.gz
Initial Commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD52
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61d59f2351f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = heavything
+ pkgdesc = A General purpose x64 Asm library for 2ton products
+ pkgver = 1.13
+ pkgrel = 1
+ url = https://2ton.com.au/HeavyThing
+ arch = x86_64
+ license = GPL3
+ makedepends = fasm
+ source = https://2ton.com.au/HeavyThing-1.13.tar.gz
+ sha256sums = 95e46bcaef8a90257ae2d81330700d72da0bb633c4ff38fbfeaded30c4f106c6
+
+pkgname = heavything-rwasa
+
+pkgname = heavything-webslap
+
+pkgname = heavything-hnwatch
+
+pkgname = heavything-dhtool
+
+pkgname = heavything-sshtalk
+
+pkgname = heavything-toplip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d3d479ea7d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+pkgbase=heavything
+pkgname=('heavything-rwasa' 'heavything-webslap' 'heavything-hnwatch'
+ 'heavything-dhtool' 'heavything-sshtalk' 'heavything-toplip')
+pkgver=1.13
+pkgrel=1
+pkgdesc='A General purpose x64 Asm library for 2ton products'
+arch=('x86_64')
+makedepends=('fasm')
+url='https://2ton.com.au/HeavyThing'
+license=('GPL3')
+source=("https://2ton.com.au/HeavyThing-$pkgver.tar.gz")
+sha256sums=('95e46bcaef8a90257ae2d81330700d72da0bb633c4ff38fbfeaded30c4f106c6')
+
+build () {
+ cd "HeavyThing-$pkgver"
+ for i in rwasa webslap hnwatch dhtool sshtalk toplip; do
+ (cd "$i"; fasm -m 262144 "$i.asm" && ld -o "$i" "$i.o")
+ done
+}
+
+package_heavything-rwasa () {
+ cd "HeavyThing-$pkgver/rwasa"
+ install -Dm755 rwasa "$pkgdir/usr/bin/rwasa"
+}
+
+package_heavything-webslap () {
+ cd "HeavyThing-$pkgver/webslap"
+ install -Dm755 webslap "$pkgdir/usr/bin/webslap"
+}
+
+package_heavything-hnwatch () {
+ cd "HeavyThing-$pkgver/hnwatch"
+ install -Dm755 hnwatch "$pkgdir/usr/bin/hnwatch"
+}
+
+package_heavything-dhtool () {
+ cd "HeavyThing-$pkgver/dhtool"
+ install -Dm755 dhtool "$pkgdir/usr/bin/dhtool"
+}
+
+package_heavything-sshtalk () {
+ cd "HeavyThing-$pkgver/sshtalk"
+ install -Dm755 sshtalk "$pkgdir/usr/bin/sshtalk"
+}
+
+package_heavything-toplip () {
+ cd "HeavyThing-$pkgver/toplip"
+ install -Dm755 toplip "$pkgdir/usr/bin/toplip"
+}
+
+# vim:set ts=2 sw=2 et: