summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-07-29 14:04:21 -0400
committerTony Lambiris2019-07-29 14:04:21 -0400
commitd6f5c38ee70890c3726cfe2edbeac40b1435daca (patch)
tree71401e7eba3f57ce71e155602e89a5cef7cc669d
parentdc9148cf81db56541c102fa542207b7b2d7f073c (diff)
downloadaur-d6f5c38ee70890c3726cfe2edbeac40b1435daca.tar.gz
Fix command names
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47315a629daf..5f31cd7197f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netcap-git
pkgdesc = A framework for secure and scalable network traffic analysis
pkgver = v0.3.9.r106.g6bbb8d6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dreadl0ck/netcap
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index a56db8f2d314..042db66a2223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=netcap-git
pkgver=v0.3.9.r106.g6bbb8d6
-pkgrel=1
+pkgrel=2
pkgdesc='A framework for secure and scalable network traffic analysis'
url="https://github.com/dreadl0ck/netcap"
arch=('x86_64')
@@ -44,17 +44,15 @@ build() {
-ldflags "-s -w" \
-gcflags="all=-trimpath=${GOPATH}/src" \
-asmflags="all=-trimpath=${GOPATH}/src" \
- -o "build/${i//\//.}" "./$i"
+ -o "build/net.$(basename $i)" "./$i"
done
}
package() {
cd "${srcdir}/go/src/github.com/dreadl0ck/netcap"
- for i in build/cmd.*; do
- msg2 "Installing $i..."
-
- install -Dm755 "$i" "${pkgdir}/usr/bin/$(basename $i)"
- done
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd build
+ find . -type f -name 'net.*' -exec install -Dm755 "{}" "${pkgdir}/usr/bin/{}" \;
}