summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2015-06-17 09:28:50 -0500
committerSamuel Mesa2015-06-17 09:28:50 -0500
commitd7469e0f484a9121d234406e802124e772eefbac (patch)
tree4191d9255b54c9dc1c3baf4f9e9840676e2a6274
downloadaur-d7469e0f484a9121d234406e802124e772eefbac.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20461935e759
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gpstk-bin
+ pkgdesc = Algorithms and frameworks supporting the development of processing and analysis applications in navigation and global positioning.
+ pkgver = 2.5
+ pkgrel = 1
+ url = http://www.gpstk.org
+ arch = x86_64
+ license = LGPL
+ provides = gpstk
+ conflicts = gpstk
+ source = http://softlayer-dal.dl.sourceforge.net/project/gpstk/gpstk/2.5/gpstk-2.5.linux.x86_64.tar.gz
+ md5sums = 083706d792aaaf3d84ba85ff841f7f54
+
+pkgname = gpstk-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2037bba04f7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Samuel Mesa <samuelmesa@linuxmail.org>
+
+pkgname=gpstk-bin
+pkgver=2.5
+pkgrel=1
+
+pkgdesc="Algorithms and frameworks supporting the development of processing and analysis applications in navigation and global positioning."
+url="http://www.gpstk.org"
+license=('LGPL')
+depends=()
+makedepends=()
+optdepends=()
+provides=('gpstk')
+conflicts=('gpstk')
+arch=('x86_64')
+source=(http://softlayer-dal.dl.sourceforge.net/project/gpstk/gpstk/${pkgver}/gpstk-${pkgver}.linux.x86_64.tar.gz)
+md5sums=('083706d792aaaf3d84ba85ff841f7f54')
+
+package() {
+ cd $srcdir/gpstk-${pkgver}.linux.$CARCH
+ mkdir -p $pkgdir/usr
+
+ cp -r $srcdir/gpstk-${pkgver}.linux.$CARCH/bin $pkgdir/usr
+ cp -r $srcdir/gpstk-${pkgver}.linux.$CARCH/include $pkgdir/usr
+ cp -r $srcdir/gpstk-${pkgver}.linux.$CARCH/lib $pkgdir/usr
+}