summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-21 12:58:30 -0500
committerLuis Martinez2023-03-21 12:58:30 -0500
commitd7a72a334b214fffee75d04a1add96b8acfb7267 (patch)
tree1bf1440889dcc86cb7851bf2d26e57c4767150c6
parentb87c04520418f746c026074019e84d7b26b6a90c (diff)
downloadaur-d7a72a334b214fffee75d04a1add96b8acfb7267.tar.gz
update to 4.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG78
-rw-r--r--PKGBUILD4
3 files changed, 82 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85764e05cf07..a9aaaf657979 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = heimer
pkgdesc = Cross-platform mind map, diagram, and note-taking tool written in Qt
- pkgver = 3.7.0
+ pkgver = 4.1.0
pkgrel = 1
url = https://github.com/juzzlin/heimer
changelog = CHANGELOG
@@ -10,7 +10,7 @@ pkgbase = heimer
makedepends = qt5-tools
depends = hicolor-icon-theme
depends = qt5-svg
- source = heimer-3.7.0.tar.gz::https://github.com/juzzlin/heimer/archive/3.7.0.tar.gz
- sha256sums = 1c5dd94f3265150728662f09370fb732c6e491df91d4a8a89661364583c8d5c9
+ source = heimer-4.1.0.tar.gz::https://github.com/juzzlin/heimer/archive/4.1.0.tar.gz
+ sha256sums = 6c89a5b4e334d41f34615c3a82c8f6827a4ee47e5c1a68dec3a13fdf00fc3e6e
pkgname = heimer
diff --git a/CHANGELOG b/CHANGELOG
index 482315393c56..80394a8a2b68 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,14 +1,90 @@
-x.y.z
+4.1.0
=====
Release date:
+Fri, 17 Mar 2023 19:48:40 -0000
+
+New features:
+
+* Add setting for shadow effect optimization
+
+* Layout optimization
+ - Allow bigger aspect ratio
+ - Allow longer edges
+
+* Darker default outline for nodes
+
+* Add subtle outline for edge labels
+
+Bug fixes:
+
+* Fix GitHub Issue #238: Shadow effects introduce performance issues
+
+* Fix GitHub Issue #239: Cannot drag if the drag position is inside the virtual rectangle spanned by an edge
+
+Other:
+
+* Update Italian translations
+
+* Update Dutch translations
+
+* Performance
+ - Don't update scene rect when adding edges
+ - Remove shadow effects from edges as long edges can make dragging stutter
+
+4.0.0
+=====
+
+Release date:
+
+Fri, 10 Mar 2023 17:28:44 -0000
+
New features:
+* Add setting for 'inverted controls'
+ - Pan the view with a modifier key (Ctrl) and select a group of items without a modifier key being pressed
+
+* Add parameter initialization options to layout optimization dialog
+
+* Add progress indicator when opening a mind map
+
+* Add tool tips for optimizer parameters
+
+* Add tool tip text for selecting node group by intersection
+
+* Change help texts into tool tips
+
Bug fixes:
+* Fix tab key not working properly with node and edge text inputs
+
+* Unselect implicitly selected node after context menu has closed
+
+* Don't autosave unmodified mind map on exit
+
+* Don't autosave unmodified mind map on new file or open file
+
Other:
+* More subtle new version indicator with a timeout
+
+* Change help texts to tool tips in edit settings
+
+* Update Italian translations
+
+* Update Dutch translations
+
+* Breaking changes to ALZ-format (old files can still be opened normally)
+
+ * Move style data into style element
+
+ * Move layout optimizer config into metadata element
+
+ * Save and load application and format versions separately
+
+ * Rename index => i, index0 => i0, index1 => i1
+
3.7.0
=====
diff --git a/PKGBUILD b/PKGBUILD
index f8498116372c..13449a650a63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: davedatum <ask at davedatum dot com>
pkgname=heimer
-pkgver=3.7.0
+pkgver=4.1.0
pkgrel=1
pkgdesc="Cross-platform mind map, diagram, and note-taking tool written in Qt"
arch=("x86_64")
@@ -13,7 +13,7 @@ depends=('hicolor-icon-theme' 'qt5-svg')
makedepends=('cmake' 'qt5-tools')
changelog=CHANGELOG
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('1c5dd94f3265150728662f09370fb732c6e491df91d4a8a89661364583c8d5c9')
+sha256sums=('6c89a5b4e334d41f34615c3a82c8f6827a4ee47e5c1a68dec3a13fdf00fc3e6e')
build() {
cmake \