summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2022-11-03 14:09:55 -0300
committerRafael Fontenelle2022-11-03 14:09:55 -0300
commitd7a780510824f41796b6dcd0360d54816f3c03d9 (patch)
tree9190977d62b69910576b2a2364652b42e4fdd849
parent48ed2e2ab34ecad545df789c35e3f78101662a5e (diff)
downloadaur-d7a780510824f41796b6dcd0360d54816f3c03d9.tar.gz
Enable Discord Rich Presence
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ba747869ef6..a41cc14f174e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddnet-git
pkgdesc = A Teeworlds modification with a unique cooperative gameplay.
- pkgver = 16.4.r35.gd64d76d62
+ pkgver = 16.5.r34.gd83cf0ac5
pkgrel = 1
url = https://ddnet.org
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = ddnet-git
makedepends = vulkan-headers
makedepends = glslang
makedepends = spirv-tools
+ makedepends = discord-game-sdk
depends = freetype2
depends = opusfile
depends = curl
@@ -26,6 +27,7 @@ pkgbase = ddnet-git
depends = mariadb-libs
depends = vulkan-icd-loader
optdepends = ddnet-maps-git: All the maps used on the official DDNet Servers.
+ optdepends = discord-game-sdk: Enable rich presence in Discord desktop client.
provides = ddnet
conflicts = ddnet
backup = usr/share/ddnet/data/autoexec_server.cfg
diff --git a/PKGBUILD b/PKGBUILD
index c28c84fe2e6b..9d06bad59335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
# Maintainer: Edgar Luque <git@edgarluque.com>
pkgname=ddnet-git
-pkgver=16.4.r35.gd64d76d62
+pkgver=16.5.r34.gd83cf0ac5
pkgrel=1
pkgdesc="A Teeworlds modification with a unique cooperative gameplay."
arch=('x86_64')
url="https://ddnet.org"
license=('custom:BSD' 'CCPL:by-nc-sa')
depends=('freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'ffmpeg' 'libnotify' 'miniupnpc' 'sqlite' 'mariadb-libs' 'vulkan-icd-loader')
-makedepends=('git' 'cmake' 'ninja' 'python' 'vulkan-headers' 'glslang' 'spirv-tools')
+makedepends=('git' 'cmake' 'ninja' 'python' 'vulkan-headers' 'glslang' 'spirv-tools' 'discord-game-sdk')
checkdepends=('gmock')
-optdepends=('ddnet-maps-git: All the maps used on the official DDNet Servers.')
+optdepends=('ddnet-maps-git: All the maps used on the official DDNet Servers.'
+ 'discord-game-sdk: Enable rich presence in Discord desktop client.')
provides=('ddnet')
conflicts=('ddnet')
backup=('usr/share/ddnet/data/autoexec_server.cfg')
@@ -42,6 +43,8 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DAUTOUPDATE=OFF \
+ -DDISCORD=ON \
+ -DDISCORD_DYNAMIC=ON \
-DANTIBOT=ON \
-DVIDEORECORDER=ON \
-DUPNP=ON \