summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-04-06 04:29:40 +0800
committerChocobo12023-04-06 04:29:40 +0800
commitd7adbefabd45fb0a62b451d108d36b58eef1464f (patch)
tree8b9869b9e77e1172db03aff941460457f73f34eb
parentf59c80898cf6926ae25d8de9da601314d207793f (diff)
downloadaur-d7adbefabd45fb0a62b451d108d36b58eef1464f.tar.gz
upgpkg: just-git 0.9.4.r322.g9f03441e-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fd9b86bea95..3e2cb33b997c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = just-git
pkgdesc = Just a command runner
- pkgver = 0.9.4.r137.gfecb5e3
+ pkgver = 0.9.4.r322.g9f03441e
pkgrel = 1
url = https://just.systems/
arch = i686
@@ -9,7 +9,7 @@ pkgbase = just-git
makedepends = git
makedepends = rust
depends = gcc-libs
- provides = just
+ provides = just=0.9.4.r322.g9f03441e
conflicts = just
source = git+https://github.com/casey/just.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2faca1db5d64..1a4acd1aa749 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=just-git
-pkgver=0.9.4.r137.gfecb5e3
+pkgver=0.9.4.r322.g9f03441e
pkgrel=1
pkgdesc="Just a command runner"
arch=('i686' 'x86_64')
@@ -12,12 +12,21 @@ url="https://just.systems/"
license=('custom')
depends=('gcc-libs')
makedepends=('git' 'rust')
-provides=('just')
+provides=("just=$pkgver")
conflicts=('just')
source=("git+https://github.com/casey/just.git")
sha256sums=('SKIP')
+prepare() {
+ cd "just"
+
+ if [ ! -f "Cargo.lock" ]; then
+ cargo update
+ fi
+ cargo fetch
+}
+
pkgver() {
cd "just"
@@ -31,18 +40,17 @@ check() {
cd "just"
cargo test \
- --locked \
- --release
+ --frozen
}
package() {
cd "just"
cargo install \
+ --frozen \
--no-track \
- --locked \
--root "$pkgdir/usr" \
- --path "$srcdir/just"
+ --path .
install -Dm644 "man/just.1" -t "${pkgdir}/usr/share/man/man1"
install -Dm644 {README,GRAMMAR}.md -t "${pkgdir}/usr/share/doc/just"