summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Fuhry2022-10-28 13:04:56 -0400
committerDan Fuhry2022-12-24 13:43:05 -0500
commitd7b06afa20959d25ca3fb584a8e871e98e2d3716 (patch)
tree2a1e3a7f91b0f1ba0edb12e16b03d0ffd86aa0d6
parent5b6ac93f22ed89eee0243904acc1a8667decc2e8 (diff)
downloadaur-d7b06afa20959d25ca3fb584a8e871e98e2d3716.tar.gz
updpkg: envoyproxy 1.24.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--0001-arch-dynamically-link-libpsl.patch21
-rw-r--r--PKGBUILD14
3 files changed, 34 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cd723607db1..c5632fe813eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = envoyproxy
pkgdesc = A high performance, open source, general RPC framework that puts mobile and HTTP/2 first.
- pkgver = 1.23.0
+ pkgver = 1.24.0
pkgrel = 1
url = https://envoyproxy.io
arch = i686
@@ -17,9 +17,11 @@ pkgbase = envoyproxy
makedepends = perl
makedepends = python
makedepends = libxcrypt-compat
- source = https://github.com/envoyproxy/envoy/archive/v1.23.0.tar.gz
+ source = https://github.com/envoyproxy/envoy/archive/v1.24.0.tar.gz
source = use_bazelisk.patch
- sha512sums = 050a2dbae6c0b3666a30331b8abf90d98724e7c1cc287fbdc10418d3cde85bdbd923d1a0d81ea280cccc43cbbf22731577a22fc0003cb57dd438a7fe19444426
+ source = 0001-arch-dynamically-link-libpsl.patch
+ sha512sums = 7cc0be5cc90550c81bedc537a2f981cd90a1c11c5b5c08a154d8a8c7b87f9d2bd18432291dcbbd3b19df3f4b3c5593b07fe2c33e452e105c4e3a67267a73742a
sha512sums = 248d0903c0aaa680065cdb308068e7f999f2ba7e2ffbc3b743715d2db968858f41cf104c59e1e98d6cda74baea54755e7c9edc29711c3b1daa87d63107ee4017
+ sha512sums = 0c5d5afd48ea87c8de030bbdf1a3c525be962983d6c09504599ff4be2dce90d2c98a5351ae34fa883feb8223f82b1e55d97b88cab4f3e1a7efff722dd30afbae
pkgname = envoyproxy
diff --git a/0001-arch-dynamically-link-libpsl.patch b/0001-arch-dynamically-link-libpsl.patch
new file mode 100644
index 000000000000..91c6d3ca6def
--- /dev/null
+++ b/0001-arch-dynamically-link-libpsl.patch
@@ -0,0 +1,21 @@
+diff -Naur envoy-1.24.0.a/.bazelrc envoy-1.24.0.b/.bazelrc
+--- envoy-1.24.0.a/.bazelrc 2022-10-28 13:01:39.695492669 -0400
++++ envoy-1.24.0.b/.bazelrc 2022-10-28 13:01:23.165203442 -0400
+@@ -43,7 +43,7 @@
+ build:linux --fission=dbg,opt
+ build:linux --features=per_object_debug_info
+ build:linux --action_env=BAZEL_LINKLIBS=-l%:libstdc++.a
+-build:linux --action_env=BAZEL_LINKOPTS=-lm
++build:linux --action_env=BAZEL_LINKOPTS=-lm:-lpsl
+
+ # We already have absl in the build, define absl=1 to tell googletest to use absl for backtrace.
+ build --define absl=1
+@@ -151,7 +151,7 @@
+ build:libc++ --action_env=LDFLAGS=-stdlib=libc++
+ build:libc++ --action_env=BAZEL_CXXOPTS=-stdlib=libc++
+ build:libc++ --action_env=BAZEL_LINKLIBS=-l%:libc++.a:-l%:libc++abi.a
+-build:libc++ --action_env=BAZEL_LINKOPTS=-lm:-pthread
++build:libc++ --action_env=BAZEL_LINKOPTS=-lm:-pthread:-lpsl
+ build:libc++ --define force_libcpp=enabled
+
+ # Optimize build for binary size reduction.
diff --git a/PKGBUILD b/PKGBUILD
index 8bccb7cf93af..acdb22fa0ab8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
+# vim: set sts=2 sw=2 et:
# Maintainer: blacktea <blackteahamburger@outlook.com>
# Contributor: kXuan <kxuanobj@gmail.com>
# Contributor: Dan Fuhry <dan@fuhry.com>
pkgname=envoyproxy
-pkgver=1.23.0
+pkgver=1.24.0
pkgrel=1
pkgdesc="A high performance, open source, general RPC framework that puts mobile and HTTP/2 first."
arch=('i686' 'x86_64')
@@ -25,10 +26,11 @@ makedepends=(
source=(
"https://github.com/$pkgname/envoy/archive/v$pkgver.tar.gz"
use_bazelisk.patch
+ 0001-arch-dynamically-link-libpsl.patch
)
-sha512sums=('050a2dbae6c0b3666a30331b8abf90d98724e7c1cc287fbdc10418d3cde85bdbd923d1a0d81ea280cccc43cbbf22731577a22fc0003cb57dd438a7fe19444426'
- '248d0903c0aaa680065cdb308068e7f999f2ba7e2ffbc3b743715d2db968858f41cf104c59e1e98d6cda74baea54755e7c9edc29711c3b1daa87d63107ee4017')
-
+sha512sums=('7cc0be5cc90550c81bedc537a2f981cd90a1c11c5b5c08a154d8a8c7b87f9d2bd18432291dcbbd3b19df3f4b3c5593b07fe2c33e452e105c4e3a67267a73742a'
+ '248d0903c0aaa680065cdb308068e7f999f2ba7e2ffbc3b743715d2db968858f41cf104c59e1e98d6cda74baea54755e7c9edc29711c3b1daa87d63107ee4017'
+ '0c5d5afd48ea87c8de030bbdf1a3c525be962983d6c09504599ff4be2dce90d2c98a5351ae34fa883feb8223f82b1e55d97b88cab4f3e1a7efff722dd30afbae')
prepare() {
cd "envoy-$pkgver"
@@ -37,8 +39,8 @@ prepare() {
# test that "$f" ends in ".patch"
if [ "${f%.patch}" != "$f" ]; then
msg "Applying patch: $f"
- patch -Np1 -i "../$f"
- fi
+ patch -Np1 -i "../$f"
+ fi
done
export GOPATH="$srcdir"/go