summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Price2016-09-09 00:16:25 +0100
committerWill Price2016-09-09 00:16:39 +0100
commitd7b16b88e869afbf53b5490eb9e87052f8e26265 (patch)
tree9db13ec98dd234d4e96dcf7889b0c37994ccb985
downloadaur-d7b16b88e869afbf53b5490eb9e87052f8e26265.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD22
-rw-r--r--ttf-sudo.install14
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12034cf14c0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Sep 8 23:16:35 UTC 2016
+pkgbase = ttf-sudo
+ pkgdesc = A font for programmers and command line users
+ pkgver = 0.33
+ pkgrel = 1
+ url = https://www.kutilek.de/sudo-font/
+ install = ttf-sudo.install
+ arch = any
+ license = SIL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/jenskutilek/sudo-font/archive/v0.33.tar.gz
+ md5sums = 7738743f7b82c13d5aff95b3a8284a21
+
+pkgname = ttf-sudo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f1f6e1e9f86
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Pacman folders
+pkg
+src
+
+# Archives
+*.zip
+*.tgz
+*.pkg.*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db308d0ccebf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Will Price <will.price94@gmail.com>
+
+pkgname=ttf-sudo
+pkgver=0.33
+pkgrel=1
+pkgdesc="A font for programmers and command line users"
+arch=(any)
+url="https://www.kutilek.de/sudo-font/"
+license=(SIL)
+install=ttf-sudo.install
+depends=(fontconfig xorg-font-utils)
+source=("https://github.com/jenskutilek/sudo-font/archive/v${pkgver}.tar.gz")
+md5sums=('7738743f7b82c13d5aff95b3a8284a21')
+
+package() {
+ for font in Sudo{,-{Bold{,Italic},Italic}}.ttf; do
+ install -Dm644 "$srcdir/sudo-font-$pkgver/sudo/$font" \
+ "$pkgdir/usr/share/fonts/sudo-font/$font"
+ done
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ttf-sudo.install b/ttf-sudo.install
new file mode 100644
index 000000000000..c3131bc89c16
--- /dev/null
+++ b/ttf-sudo.install
@@ -0,0 +1,14 @@
+_update_fonts() {
+ echo "Rescaning system to build font cache"
+ fc-cache --force --system-only
+}
+
+post_install() {
+ _update_fonts
+}
+
+post_upgrade() {
+ _update_fonts
+}
+
+# vim:set ts=2 sw=2 et: