summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2020-05-30 11:16:42 +0200
committerJaroslav Lichtblau2020-05-30 11:16:42 +0200
commitd7f82bff271af9e3d17f97026eedc1dac7f12b94 (patch)
tree04a5ee8f210df3bf6e1ba7e8b5fd7138c5954f6f
parentbcb755ff18646f61a8d299cb7be15709b610d1cf (diff)
downloadaur-d7f82bff271af9e3d17f97026eedc1dac7f12b94.tar.gz
python-django-taggit-1.3.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 15 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13100d61156c..37ec9737ecce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri Oct 26 17:34:41 UTC 2018
pkgbase = python-django-taggit
pkgdesc = Simple tagging application for Django
- pkgver = 0.23.0
+ pkgver = 1.3.0
pkgrel = 1
- url = http://github.com/alex/django-taggit/
+ url = https://github.com/jazzband/django-taggit/
arch = any
license = BSD
- makedepends = python2-django
makedepends = python-django
- makedepends = python2-mock
makedepends = python-mock
- source = django-taggit-0.23.0.tar.gz::https://github.com/alex/django-taggit/archive/0.23.0.tar.gz
- sha256sums = f6c9cbeea93dd04406f815ebfea3bdfb4fab0af5e1a93d2f3e13a79e0b47486a
+ source = python-django-taggit-1.3.0.tar.gz::https://github.com/jazzband/django-taggit/archive/1.3.0.tar.gz
+ sha256sums = d36b16107717db86829ad9077bdb3acfe67450708c5d4df5caa26888752d4a49
pkgname = python-django-taggit
- depends = python-django
-
-pkgname = python2-django-taggit
- depends = python2-django
diff --git a/PKGBUILD b/PKGBUILD
index 47d8ee26704a..fdb2e84bba6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,26 @@
# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
-pkgbase=python-django-taggit
-pkgname=(python-django-taggit python2-django-taggit)
-_pkgname=django-taggit
-pkgver=0.23.0
+pkgname=python-django-taggit
+pkgver=1.3.0
pkgrel=1
pkgdesc="Simple tagging application for Django"
arch=('any')
-url="http://github.com/alex/django-taggit/"
+url="https://github.com/jazzband/django-taggit/"
license=('BSD')
-makedepends=('python2-django' 'python-django' 'python2-mock' 'python-mock')
-source=($_pkgname-$pkgver.tar.gz::https://github.com/alex/django-taggit/archive/$pkgver.tar.gz)
-sha256sums=('f6c9cbeea93dd04406f815ebfea3bdfb4fab0af5e1a93d2f3e13a79e0b47486a')
+makedepends=('python-django' 'python-mock')
+source=($pkgname-$pkgver.tar.gz::https://github.com/jazzband/django-taggit/archive/$pkgver.tar.gz)
+sha256sums=('d36b16107717db86829ad9077bdb3acfe67450708c5d4df5caa26888752d4a49')
-# tests currently fail
+# tests fail
# check() {
-# cd "${srcdir}"/$_pkgname-$pkgver
+# cd "${srcdir}"/django-taggit-$pkgver
#
-# python2 setup.py test
# python setup.py test
# }
-package_python2-django-taggit() {
- depends=('python2-django')
-
- cd "${srcdir}"/$_pkgname-$pkgver
- python2 setup.py install --root="${pkgdir}" --optimize=1
-
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
-}
-
-package_python-django-taggit() {
- depends=('python-django')
-
- cd "${srcdir}"/$_pkgname-$pkgver
+package() {
+ cd "${srcdir}"/django-taggit-$pkgver
+
python setup.py install --root="${pkgdir}" --optimize=1
-
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
}