summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2024-04-06 15:42:04 +0200
committerMarcell Meszaros2024-04-06 15:59:40 +0200
commitd823d833e37422ff8afa30d9f093256a6cec920b (patch)
tree26534bb4f9d77ae7b05f8b332ccb9d7857820c5d
parent6bd7af5e9d20e1d28b27d44366c383bb87940c8b (diff)
downloadaur-d823d833e37422ff8afa30d9f093256a6cec920b.tar.gz
1.14.0.r3.gd8f36d4-1: update to latest patched version
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD68
3 files changed, 85 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 424845a36006..cc81bbf25996 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,28 @@
pkgbase = python-visvis
pkgdesc = Python library for visualization of 1D to 4D data
- pkgver = 1.13.0
+ pkgver = 1.14.0.r3.gd8f36d4
pkgrel = 1
url = https://github.com/almarklein/visvis
arch = any
- license = BSD
- makedepends = python-setuptools
+ license = BSD-3-Clause
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-wheel
+ depends = python
+ depends = python-imageio
depends = python-numpy
depends = python-opengl
- optdepends = python-pyqt4: for Qt4 backend
- optdepends = python-pyside: for another Qt4 backend
- optdepends = wxpython: for WxWidgets backend
- optdepends = pygtk: for GTK backend
- source = python-visvis-1.13.0.tar.gz::https://github.com/almarklein/visvis/archive/v1.13.0.tar.gz
- sha256sums = a2858c61b9b2ff17d1f9e8bffb0445077e2e9bb93fe59ee3812dcaa7e0d43fda
+ depends = python-pillow
+ depends = python-scipy
+ optdepends = pyside2: for another Qt5 GUI backend
+ optdepends = pyside6: for another Qt6 GUI backend
+ optdepends = python-glfw: for GLFW GUI backend
+ optdepends = python-pyfltk: for an FLTK GUI backend
+ optdepends = python-pyqt5: for a Qt5 GUI backend
+ optdepends = python-pyqt6: for a Qt6 GUI backend
+ optdepends = python-wxpython: for the WxWidgets GUI backend
+ source = python-visvis::git+https://github.com/almarklein/visvis.git#commit=d8f36d4b33554a24918c7043188ccffcc054690e
+ b2sums = SKIP
pkgname = python-visvis
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..058ba2318df1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+# based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
+*.kate-swp
+.directory
diff --git a/PKGBUILD b/PKGBUILD
index 8edaf2626155..3e4a73af1692 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,63 @@
-# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
pkgname=python-visvis
-_pkg="${pkgname#python-}"
-pkgver=1.13.0
+pkgver=1.14.0.r3.gd8f36d4
+_commit=d8f36d4b33554a24918c7043188ccffcc054690e
pkgrel=1
pkgdesc="Python library for visualization of 1D to 4D data"
url="https://github.com/almarklein/visvis"
arch=('any')
-license=('BSD')
-depends=('python-numpy' 'python-opengl')
-makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
-optdepends=('python-pyqt4: for Qt4 backend'
- 'python-pyside: for another Qt4 backend'
- 'wxpython: for WxWidgets backend'
- 'pygtk: for GTK backend')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('a2858c61b9b2ff17d1f9e8bffb0445077e2e9bb93fe59ee3812dcaa7e0d43fda')
+license=('BSD-3-Clause')
+depends=(
+ 'python'
+ 'python-imageio'
+ 'python-numpy'
+ 'python-opengl'
+ 'python-pillow'
+ 'python-scipy'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
+optdepends=(
+ 'pyside2: for another Qt5 GUI backend'
+ 'pyside6: for another Qt6 GUI backend'
+ 'python-glfw: for GLFW GUI backend'
+ 'python-pyfltk: for an FLTK GUI backend'
+ 'python-pyqt5: for a Qt5 GUI backend'
+ 'python-pyqt6: for a Qt6 GUI backend'
+ 'python-wxpython: for the WxWidgets GUI backend'
+)
+source=("${pkgname}::git+${url}.git#commit=${_commit}")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+
+ # Generate git tag based version. Count only proper (v)#.#* [#=number] tags.
+ local _gitversion=$(git describe --long --tags --match '[v0-9][0-9.][0-9.]*' | sed -e 's|^v||' | tr '[:upper:]' '[:lower:]')
+
+ # Format git-based version for pkgver
+ # Expected format: e.g. 1.5.0rc2.r521.g99982a1c
+ # Or in case of 'post': 1.5.0.post1.r521.g99982a1c
+ echo "${_gitversion}" | sed \
+ -e 's;^\([0-9][0-9.]*\)[-_.]\([a-zA-Z]\+\);\1\2;' \
+ -e 's;\([0-9]\+-g\);r\1;' \
+ -e 's;-;.;g' \
+ -e 's;\(post.*\);\.\1;'
+}
build() {
- cd "$_pkg-$pkgver"
- python -m build --wheel --no-isolation
+ cd "${pkgname}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$_pkg-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${pkgname}"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}