summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-06-08 07:47:37 -0400
committerPatrick Northon2020-06-08 07:47:37 -0400
commitd8240cabdecc936605e55165f2686bf0996d4d7f (patch)
tree1574ee38650940295a5d594aa77df50adf601faf
parent2734207f2e8317a6b0f1eb1cee79f82b14c07428 (diff)
downloadaur-d8240cabdecc936605e55165f2686bf0996d4d7f.tar.gz
Add static build.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b28ad29a3f7..d9a120f878e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-xalan-c-git
pkgdesc = The Apache Xalan-C++ Project provides a library and a command line program to transform XML documents using a stylesheet that conforms to XSLT 1.0 standards.
- pkgver = 1.12.0.r0
+ pkgver = 1.12.0
pkgrel = 1
url = https://xalan.apache.org/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 4ba63d03f4f9..842d52adfe30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mingw-w64-xalan-c-git
conflicts=("mingw-w64-xalan-c")
provides=("mingw-w64-xalan-c")
-pkgver=1.12.0.r0
+pkgver=1.12.0
pkgrel=1
pkgdesc="The Apache Xalan-C++ Project provides a library and a command line program to transform XML documents using a stylesheet that conforms to XSLT 1.0 standards."
arch=(any)
@@ -23,10 +23,13 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "xalan-c"
git apply "../fix-cross-compile.patch"
+ sed -i -r "s/_MSC_VER/_WIN32/" "src/xalanc/XalanExe/XalanExe.cpp"
}
build() {
for _arch in ${_architectures}; do
+ ${_arch}-cmake -S "xalan-c" -B "build-${_arch}" -DCMAKE_BUILD_TYPE=Release -Ddoxygen=OFF -DBUILD_SHARED_LIBS=FALSE
+ make -C "build-${_arch}-static"
${_arch}-cmake -S "xalan-c" -B "build-${_arch}" -DCMAKE_BUILD_TYPE=Release -Ddoxygen=OFF
make -C "build-${_arch}"
done
@@ -34,6 +37,7 @@ build() {
package() {
for _arch in ${_architectures}; do
+ make DESTDIR="${pkgdir}" -C "build-${_arch}-static" install
make DESTDIR="${pkgdir}" -C "build-${_arch}" install
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a