summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeimos2019-01-17 18:28:28 -0500
committerDeimos2019-01-17 18:28:28 -0500
commitd830bb7334c290c6d77756bb7570fdfe3c386a5c (patch)
tree9161a04965dc20fb48530d09dc1e1891e5e186a8
downloadaur-d830bb7334c290c6d77756bb7570fdfe3c386a5c.tar.gz
initial
-rw-r--r--.SRCINFO22
-rwxr-xr-xPKGBUILD36
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d1b2efe9165
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = chess.app
+ pkgdesc = Chess for GNUstep ported from OPENSTEP
+ pkgver = 2.8
+ pkgrel = 1
+ url = https://packages.debian.org/sid/gnustep/chess.app
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ groups = gnustep-apps
+ license = BSD
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ depends = gnustep-back
+ source = http://http.debian.net/debian/pool/main/c/chess.app/chess.app_2.8.orig.tar.gz
+ source = http://http.debian.net/debian/pool/main/c/chess.app/chess.app_2.8-1.debian.tar.xz
+ sha256sums = 0a504959ab9699b04055c6844fc62346f1791c67c155f2de62f885c674ab4bd8
+ sha256sums = f47f4926cc819a3a6268f731a72748e3f6d719da8d82ea75183fdb99edf58ce1
+
+pkgname = chess.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..025f74fce83f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=Chess
+pkgname=chess.app
+pkgrel=1
+pkgver=2.8
+pkgdesc='Chess for GNUstep ported from OPENSTEP'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://packages.debian.org/sid/gnustep/chess.app'
+license=('BSD')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://http.debian.net/debian/pool/main/c/chess.app/chess.app_2.8.orig.tar.gz"
+ "http://http.debian.net/debian/pool/main/c/chess.app/chess.app_2.8-1.debian.tar.xz")
+sha256sums=('0a504959ab9699b04055c6844fc62346f1791c67c155f2de62f885c674ab4bd8'
+ 'f47f4926cc819a3a6268f731a72748e3f6d719da8d82ea75183fdb99edf58ce1')
+
+prepare() {
+ cd "$pkgname-33"
+ patch < ../debian/patches/improve-chessinfo-plist
+}
+
+build() {
+ cd "$pkgname-33"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd "$pkgname-33"
+ make DESTDIR="$pkgdir" install
+ sed -i "s/Applications.app/Applications\/Chess.app/" "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop"
+ sed -i "s/ChessApp.tiff/chess.icns/" "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop"
+install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}