summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-07-02 23:28:22 +0200
committersl1pkn072015-07-02 23:28:22 +0200
commitd832500b62d9cf671088eb2f695c80163ac576b3 (patch)
tree94002acee7101e076d330173eb7b692ea1f30f2d
downloadaur-d832500b62d9cf671088eb2f695c80163ac576b3.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD40
-rw-r--r--wobbly-git.install11
-rwxr-xr-xwobbly.desktop10
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..622dfd959faf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wobbly-git
+ pkgdesc = IVTC assistant for VapourSynth, similar to Yatta. (GIT version)
+ pkgver = r4.2.g8f9b54d
+ pkgrel = 1
+ url = https://github.com/dubhater/Wobbly
+ install = wobbly-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ depends = vapoursynth-plugin-fieldhint-git
+ depends = vapoursynth-plugin-d2vsource-git
+ provides = wobbly
+ conflicts = wobbly
+ source = wobbly::git+https://github.com/dubhater/Wobbly.git
+ source = wobbly.desktop
+ sha1sums = SKIP
+ sha1sums = 0fda5064306cf489879fa5234c8baf40879bb805
+
+pkgname = wobbly-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d509984cf403
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!wobbly-git.install
+!wobbly.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a773b0e45bb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=wobbly-git
+pkgver=r4.2.g8f9b54d
+pkgrel=1
+pkgdesc="IVTC assistant for VapourSynth, similar to Yatta. (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/dubhater/Wobbly'
+license=('GPL')
+depends=('qt5-base' 'vapoursynth-plugin-fieldhint-git' 'vapoursynth-plugin-d2vsource-git')
+makedepends=('git')
+provides=('wobbly')
+conflicts=('wobbly')
+source=('wobbly::git+https://github.com/dubhater/Wobbly.git'
+ 'wobbly.desktop')
+sha1sums=('SKIP'
+ '0fda5064306cf489879fa5234c8baf40879bb805')
+install=wobbly-git.install
+
+pkgver() {
+ cd wobbly
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd wobbly
+ ./autogen.sh
+}
+
+build() {
+ cd wobbly
+ ./configure --prefix=/usr
+ make --trace
+}
+
+package() {
+ make -C wobbly DESTDIR="${pkgdir}" install
+
+ install -Dm644 wobbly.desktop "${pkgdir}/usr/share/applications/wobbly.desktop"
+}
diff --git a/wobbly-git.install b/wobbly-git.install
new file mode 100644
index 000000000000..68bb70ff19a8
--- /dev/null
+++ b/wobbly-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/wobbly.desktop b/wobbly.desktop
new file mode 100755
index 000000000000..1e9ba0e779a3
--- /dev/null
+++ b/wobbly.desktop
@@ -0,0 +1,10 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Name=Wobbly
+GenericName=IVTC assistant for VapourSynth
+Comment=IVTC assistant for VapourSynth
+Type=Application
+Exec=wobbly
+Terminal=false
+StartupNotify=false
+Categories=AudioVideo;