summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Petrov2018-03-24 14:42:48 +0200
committerPeter Petrov2018-03-24 14:42:48 +0200
commitd8376ac15d70c36f2688041f41dc1e59f93ead5f (patch)
treeff4580d7a6f7daf958f71e1b2d33d745ba224517
parentf5c7315c1c768657169154d29b4230d1f42b2a64 (diff)
downloadaur-d8376ac15d70c36f2688041f41dc1e59f93ead5f.tar.gz
Update to v0.10.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD63
-rw-r--r--mist.desktop8
-rw-r--r--mist.pngbin0 -> 25926 bytes
4 files changed, 36 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd62388e3373..74f4f8e813ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = mist
pkgdesc = Ethereum wallet and Dapp browser.
- pkgver = 0.9.3
- pkgrel = 2
+ pkgver = 0.10.0
+ pkgrel = 1
url = https://github.com/ethereum/mist
- arch = i686
arch = x86_64
license = GPL
depends = alsa-lib
@@ -16,14 +15,13 @@ pkgbase = mist
optdepends = geth: The go-ethereum commandline client (geth cli).
optdepends = parity: The fast, light, robust Ethereum client.
provides = mist
- provides = libnode
conflicts = mist-git
- conflicts = libnode
- conflicts = libnode-git
- source_i686 = mist-0-9-3-32.deb::https://github.com/ethereum/mist/releases/download/v0.9.3/Mist-linux32-0-9-3.deb
- sha256sums_i686 = 1c7928dcd8b26126d0f6ab5aae7251da85b9adcdfa1b0b36ffb36f87c64977d8
- source_x86_64 = mist-0-9-3-64.deb::https://github.com/ethereum/mist/releases/download/v0.9.3/Mist-linux64-0-9-3.deb
- sha256sums_x86_64 = 01e3df03dce3132f7521118e553468e0fad83f637233f1ff28cdaa7e5dffc245
+ source = mist.desktop
+ source = mist.png
+ sha256sums = 859752bb1e4560f7ba9aecbae300f7b80619a58a12fb222d1cccef9477236939
+ sha256sums = 0b3bebf887730b51c82ad37d58550908563000ad134b22738f4cb91375c96790
+ source_x86_64 = mist-0-10-0-64.zip::https://github.com/ethereum/mist/releases/download/v0.10.0/Mist-linux64-0-10-0.zip
+ sha256sums_x86_64 = f127e5cf6aa87d26c66c3e4d338a50d37670158fba496b44731dbae68e3c6106
pkgname = mist
diff --git a/PKGBUILD b/PKGBUILD
index cda34b7d8502..fe8a6071434e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=mist
-pkgver=0.9.3
-_strver=0-9-3
-pkgrel=2
+pkgver=0.10.0
+_strver=0-10-0
+pkgrel=1
pkgdesc="Ethereum wallet and Dapp browser."
-arch=('i686' 'x86_64')
+arch=('x86_64')
depends=(
'alsa-lib'
'gconf'
@@ -19,12 +19,9 @@ depends=(
)
provides=(
'mist'
- 'libnode'
)
conflicts=(
'mist-git'
- 'libnode'
- 'libnode-git'
)
optdepends=(
'geth: The go-ethereum commandline client (geth cli).'
@@ -32,49 +29,29 @@ optdepends=(
)
url="https://github.com/ethereum/mist"
license=('GPL')
-sha256sums_i686=('1c7928dcd8b26126d0f6ab5aae7251da85b9adcdfa1b0b36ffb36f87c64977d8')
-sha256sums_x86_64=('01e3df03dce3132f7521118e553468e0fad83f637233f1ff28cdaa7e5dffc245')
-source_i686=(
- "${pkgname}-${_strver}-32.deb::https://github.com/ethereum/${pkgname}/releases/download/v${pkgver}/Mist-linux32-${_strver}.deb"
+sha256sums=('859752bb1e4560f7ba9aecbae300f7b80619a58a12fb222d1cccef9477236939'
+ '0b3bebf887730b51c82ad37d58550908563000ad134b22738f4cb91375c96790')
+sha256sums_x86_64=('f127e5cf6aa87d26c66c3e4d338a50d37670158fba496b44731dbae68e3c6106')
+source=(
+ "mist.desktop"
+ "mist.png"
)
source_x86_64=(
- "${pkgname}-${_strver}-64.deb::https://github.com/ethereum/${pkgname}/releases/download/v${pkgver}/Mist-linux64-${_strver}.deb"
-
+ "${pkgname}-${_strver}-64.zip::https://github.com/ethereum/${pkgname}/releases/download/v${pkgver}/Mist-linux64-${_strver}.zip"
)
-prepare() {
- tar xf "$srcdir/data.tar.xz"
-}
package() {
- _arch="32"
- if [ "${CARCH}" = "x86_64" ]; then
- _arch="64"
- fi
-
- rm "${srcdir}/${pkgname}-${_strver}-${_arch}.deb"
-
msg2 'Installing Mist...'
- install -d "${pkgdir}/usr/share/${pkgname}"
- cp -a "${srcdir}/opt/Mist/." "${pkgdir}/usr/share/${pkgname}"
+ install -d "${pkgdir}/opt/Mist"
+ cp -a "${srcdir}/." "${pkgdir}/opt/Mist"
+ rm ${pkgdir}/opt/Mist/mist-*.zip ${pkgdir}/opt/Mist/mist.desktop ${pkgdir}/opt/Mist/mist.png
install -d "${pkgdir}/usr/share/applications"
- cp -a "${srcdir}/usr/share/." "${pkgdir}/usr/share/"
+ cp -aL "${srcdir}/mist.desktop" "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/share/pixmaps"
+ cp -aL "${srcdir}/mist.png" "${pkgdir}/usr/share/pixmaps"
- install -d "${pkgdir}/usr/bin"
- ln -s "/usr/share/${pkgname}/mist" "${pkgdir}/usr/bin/mist"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "${pkgdir}/usr/share/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- rm "${pkgdir}/usr/share/${pkgname}/LICENSE"
- sed -i 's/Exec="\/opt\/Mist\/mist"/Exec="\/usr\/bin\/mist"/' "${pkgdir}/usr/share/applications/mist.desktop";
- sed -i 's/Categories=WebBrowser/Categories=Network;WebBrowser;/' "${pkgdir}/usr/share/applications/mist.desktop";
-
- msg2 'Installing Libnode...'
- install -d "${pkgdir}/usr/lib"
- ln -s "/usr/share/${pkgname}/libnode.so" "${pkgdir}/usr/lib/libnode.so"
-
- ln -sf "/usr/lib/libnotify.so.4" "${pkgdir}/usr/share/${pkgname}/libnotify.so.4"
-
- find "${pkgdir}" -type d -exec chmod 755 {} +
- find "${pkgdir}" -type f -exec chmod 644 {} +
- chmod 755 "${pkgdir}/usr/share/${pkgname}/mist"
- chmod 755 "${pkgdir}/usr/share/${pkgname}/libnode.so"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/Mist/mist" "${pkgdir}/usr/bin/mist"
}
diff --git a/mist.desktop b/mist.desktop
new file mode 100644
index 000000000000..279cc6696343
--- /dev/null
+++ b/mist.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mist
+Comment=Ethereum wallet and Dapp browser
+Exec="/opt/Mist/mist"
+Terminal=false
+Type=Application
+Icon=mist
+Categories=Network;WebBrowser;
diff --git a/mist.png b/mist.png
new file mode 100644
index 000000000000..6b59c9b39a76
--- /dev/null
+++ b/mist.png
Binary files differ