summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2020-01-08 21:03:32 -0800
committerJesus Alvarez2020-01-08 21:03:32 -0800
commitd846d5c60bdd005537d1a06338cd58699de1b4c6 (patch)
treeec6a6c54ba6fdf990389858c5a894b9b4113adeb
parente85a485c536ad52dfb857d112c0afe211c145cf4 (diff)
downloadaur-d846d5c60bdd005537d1a06338cd58699de1b4c6.tar.gz
Update to spacenavd-0.7
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--spacenavd38
-rw-r--r--spacenavd.service1
4 files changed, 10 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 400bedb21596..c2c56ed900db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = spacenavd
pkgdesc = The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc).
- pkgver = 0.6
- pkgrel = 3
+ pkgver = 0.7
+ pkgrel = 2
url = http://spacenav.sourceforge.net/
arch = x86_64
license = GPL
optdepends = libx11
provides = spacenavd
backup = etc/spnavrc
- source = http://downloads.sourceforge.net/spacenav/spacenavd-0.6.tar.gz
- source = spacenavd
+ source = https://github.com/FreeSpacenav/spacenavd/releases/download/v0.7/spacenavd-0.7.tar.gz
source = spacenavd.service
- md5sums = 7e2c04fb8dbb7d39b9ee7b64565e0c4f
- md5sums = 27a739300d4de07920879af2d2bdd47f
- md5sums = 4d9314d72b4b4e8a7f5100f69f1fdba3
+ sha256sums = d2493c8124c0e615e7b9bc28cbc1fb7cb1ebc2670c8af86745dedc7e142fafce
+ sha256sums = 5a1122cf44acdf34537bc2ef7c1ad3776872f335b2993d68833c23f999d96c11
pkgname = spacenavd
diff --git a/PKGBUILD b/PKGBUILD
index 8d21606e1b4e..8264d2a7a47d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Creator: Jan Hambrecht <jaham at gmx dot net>
pkgname=spacenavd
-pkgver=0.6
-pkgrel=3
+pkgver=0.7
+pkgrel=2
pkgdesc="The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc)."
arch=('x86_64')
url="http://spacenav.sourceforge.net/"
@@ -11,11 +11,10 @@ license=('GPL')
optdepends=("libx11")
provides=('spacenavd')
backup=('etc/spnavrc')
-source=(http://downloads.sourceforge.net/spacenav/$pkgname-$pkgver.tar.gz spacenavd spacenavd.service)
+source=(https://github.com/FreeSpacenav/spacenavd/releases/download/v$pkgver/spacenavd-$pkgver.tar.gz spacenavd.service)
-md5sums=('7e2c04fb8dbb7d39b9ee7b64565e0c4f'
- '27a739300d4de07920879af2d2bdd47f'
- '4d9314d72b4b4e8a7f5100f69f1fdba3')
+sha256sums=('d2493c8124c0e615e7b9bc28cbc1fb7cb1ebc2670c8af86745dedc7e142fafce'
+ '5a1122cf44acdf34537bc2ef7c1ad3776872f335b2993d68833c23f999d96c11')
build() {
cd ${pkgname}-${pkgver}
@@ -26,7 +25,6 @@ build() {
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install || return 1
- install -D -m755 ${srcdir}/spacenavd ${pkgdir}/etc/rc.d/spacenavd || return 1
install -D -m644 ${srcdir}/spacenavd.service ${pkgdir}/etc/systemd/system/spacenavd.service || return 1
install -D -m644 ${srcdir}/$pkgname-$pkgver/doc/example-spnavrc ${pkgdir}/etc/spnavrc || return 1
}
diff --git a/spacenavd b/spacenavd
deleted file mode 100644
index 61946197c40b..000000000000
--- a/spacenavd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-DAEMON=/usr/bin/spacenavd
-
-PID=`pidof -o %PPID $DAEMON`
-case "$1" in
- start)
- stat_busy "Starting Spacenavigator Daemon"
- [ -z "$PID" ] && $DAEMON
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon spacenavd
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping Spacenavigator Daemon"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon spacenavd
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/spacenavd.service b/spacenavd.service
index 1798f5e8fb3d..b7d062c3e9b3 100644
--- a/spacenavd.service
+++ b/spacenavd.service
@@ -8,4 +8,3 @@ ExecStart=/usr/bin/spacenavd
[Install]
WantedBy=multi-user.target
-