summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Schichtel2023-11-05 18:22:06 +0100
committerPhillip Schichtel2023-11-05 18:22:06 +0100
commitd88ea5f1e9f36f61e6ecb95a28ce32e8ca784aba (patch)
tree5ab77d4616e36360ecfc4dd5ef28fe0b48780363
parent7047bbd33a2e1de85f2869e3fd8950d74568989b (diff)
downloadaur-d88ea5f1e9f36f61e6ecb95a28ce32e8ca784aba.tar.gz
switch to git-based source with explicit commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b3a62223042..cbcce6dce724 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = can-utils
arch = armv6h
license = GPL2
conflicts = can-utils-git
- source = can-utils-2023.03.tar.gz::https://github.com/linux-can/can-utils/archive/v2023.03.tar.gz
- sha256sums = 2790dfb57fe3ec22b6fd512838c6480c39f7c9ae193e59f1ae01221216505a7e
+ source = git+https://github.com/linux-can/can-utils.git#commit=cfe41963f3425e9adb01a70cfaddedf5e5982720
+ sha256sums = SKIP
pkgname = can-utils
diff --git a/PKGBUILD b/PKGBUILD
index ddfee8e7fdee..d7b2bdfed656 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,17 +10,17 @@ arch=('x86_64' 'armv6h')
url="https://github.com/linux-can/can-utils"
license=('GPL2')
conflicts=("can-utils-git")
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('2790dfb57fe3ec22b6fd512838c6480c39f7c9ae193e59f1ae01221216505a7e')
+source=("git+https://github.com/linux-can/can-utils.git#commit=cfe41963f3425e9adb01a70cfaddedf5e5982720")
+sha256sums=('SKIP')
build() {
- cd ${pkgname}-${pkgver}
+ cd can-utils
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd ${pkgname}-${pkgver}
+ cd can-utils
make DESTDIR="$pkgdir/" install
}