summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Michalopoulos2019-04-22 12:48:02 +0300
committerAlexandros Michalopoulos2019-04-22 12:48:02 +0300
commitd8ce5e8496af78390012976480376d7375f1e023 (patch)
tree220b2ab6bbfb2d4a093f7962f6a99a8222d437c4
parenta12f12b77d402264dbefeacd8af14458c7e34d93 (diff)
downloadaur-d8ce5e8496af78390012976480376d7375f1e023.tar.gz
v=4.0.0, r=1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD16
-rw-r--r--kawaii-player.install12
3 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6be5a1987b7a..d8d5368240ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,31 @@
pkgbase = kawaii-player
- pkgdesc = Multimedia player, media library manager and portable media server with PC-To-PC casting feature
- pkgver = 3.9.0
+ pkgdesc = Multimedia player, media library manager and portable media server with PC-to-PC casting feature
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/kanishka-linux/kawaii-player
install = kawaii-player.install
arch = any
license = GPL3
makedepends = git
- depends = ffmpegthumbnailer
depends = libnotify
depends = mpv
+ depends = sqlite
depends = python-beautifulsoup4
depends = python-certifi
depends = python-dbus
depends = python-lxml
depends = python-mutagen
+ depends = python-opengl
depends = python-pillow
depends = python-pycurl
- depends = python-pyqt5
- depends = qt5-webengine
- depends = sqlite
- optdepends = libtorrent-rasterbar: torrent videos streaming
- optdepends = youtube-dl: YouTube videos streaming
+ depends = python-pyqtwebengine
+ optdepends = python-pympv: modern opengl-render API for libmpv
+ optdepends = libtorrent-rasterbar: torrent streaming
+ optdepends = youtube-dl: YouTube streaming
optdepends = xorg-server-xvfb: run in headless mode
conflicts = kawaii-player-git
- source = https://github.com/kanishka-linux/kawaii-player/releases/download/v3.9.0-1/kawaii-player-3.9.0-1.tar.bz2
- sha256sums = 3a6ff7195936908513e56941371a8e24b3c51d1c87bda46030beabc0339b0781
+ source = https://github.com/kanishka-linux/kawaii-player/releases/download/v4.0.0-1/kawaii-player-4.0.0-1.tar.bz2
+ sha256sums = 9cd2e6bc66b3e56e546e5dbb0f23f6ca644d540b463cb9a72a67a1cf4814f12a
pkgname = kawaii-player
diff --git a/PKGBUILD b/PKGBUILD
index f788d57796f4..2de849f0bf0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Nocifer <apmichalopoulos at gmail dot com>
pkgname=kawaii-player
_pkgname=kawaii_player
-pkgver=3.9.0
+pkgver=4.0.0
pkgrel=1
_pkgrel=1
-pkgdesc="Multimedia player, media library manager and portable media server with PC-To-PC casting feature"
+pkgdesc="Multimedia player, media library manager and portable media server with PC-to-PC casting feature"
arch=(any)
url="https://github.com/kanishka-linux/kawaii-player"
license=('GPL3')
-depends=('ffmpegthumbnailer' 'libnotify' 'mpv' 'python-beautifulsoup4' 'python-certifi' 'python-dbus'
- 'python-lxml' 'python-mutagen' 'python-pillow' 'python-pycurl' 'python-pyqt5' 'qt5-webengine' 'sqlite')
-optdepends=('libtorrent-rasterbar: torrent videos streaming'
- 'youtube-dl: YouTube videos streaming'
+depends=('libnotify' 'mpv' 'sqlite'
+ 'python-beautifulsoup4' 'python-certifi' 'python-dbus' 'python-lxml' 'python-mutagen' 'python-opengl'
+ 'python-pillow' 'python-pycurl' 'python-pyqtwebengine')
+optdepends=('python-pympv: modern opengl-render API for libmpv'
+ 'libtorrent-rasterbar: torrent streaming'
+ 'youtube-dl: YouTube streaming'
'xorg-server-xvfb: run in headless mode')
makedepends=('git')
conflicts=('kawaii-player-git')
install=$pkgname.install
source=("https://github.com/kanishka-linux/${pkgname}/releases/download/v${pkgver}-${_pkgrel}/${pkgname}-${pkgver}-${_pkgrel}.tar.bz2")
-sha256sums=('3a6ff7195936908513e56941371a8e24b3c51d1c87bda46030beabc0339b0781')
+sha256sums=('9cd2e6bc66b3e56e546e5dbb0f23f6ca644d540b463cb9a72a67a1cf4814f12a')
build() {
cd ${srcdir}/${pkgname}-${pkgver}-${_pkgrel}
diff --git a/kawaii-player.install b/kawaii-player.install
index 93aa0c06a16c..7ae69d15f2ab 100644
--- a/kawaii-player.install
+++ b/kawaii-player.install
@@ -1,12 +1,14 @@
post_install() {
echo
- echo "If you are upgrading from Kawaii Player v2.9 or earlier, you are"
- echo "advised to backup and then remove the following configuration files:"
+ echo "There is now experimental support for using libmpv as the backend instead of the mpv binary."
echo
- echo "~/.config/kawaii-player/other_options.txt"
- echo "~/.config/kawaii-player/config.txt"
- echo "~/.config/kawaii-player/src/input.conf"
+ echo "If you wish to use it, you will have to manually enable it in the application's settings. For"
+ echo "best results, consider also installing python-pympv in order for libmpv to be able to utilize"
+ echo "its own opengl-render API, instead of the deprecated opengl-cb API that is hardcoded in OpenGL"
+ echo "and used by default."
echo
+ echo "NOTE: For the time being, some (minor) features of Kawaii Player may not work properly when"
+ echo "using libmpv as the backend."
echo
echo "Visit the project's GitHub page for more info on features and proper configuration."
echo