summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2016-04-06 04:18:24 -0400
committerbrent s2016-04-06 04:18:24 -0400
commitd90aa32541d4a0816237dd089824d539cdca8b48 (patch)
tree0312fc65e1c0e14a3c2344f5e0262d712edcecd3
downloadaur-d90aa32541d4a0816237dd089824d539cdca8b48.tar.gz
adding gitignore, updating to sha512sums
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore14
-rw-r--r--Makefile.local40
-rw-r--r--PKGBUILD213
-rwxr-xr-xspearmint-server.launcher4
-rw-r--r--spearmint.desktop12
-rw-r--r--spearmint.install32
-rwxr-xr-xspearmint.launcher4
-rw-r--r--spearmint.service22
-rw-r--r--spearmint.svg105
10 files changed, 488 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbfc0ad941f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+# Generated by mksrcinfo v8
+# Wed Apr 6 08:18:24 UTC 2016
+pkgbase = spearmint-git
+ pkgdesc = An improved ioquake3-based Quake 3: Arena client (note: requires pak files from original CD) - Git master:HEAD
+ pkgver = 1
+ pkgrel = 1
+ url = http://spearmint.pw
+ install = spearmint.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = sdl2
+ depends = sdl2
+ provides = quake3
+ provides = ioquake3
+ provides = spearmint
+ provides = ioquake3-git
+ conflicts = spearmint
+ conflicts = quake3
+ conflicts = ioquake3
+ conflicts = ioquake3-git
+ source = spearmint-engine::git+https://github.com/zturtleman/spearmint.git
+ source = spearmint-game::git+https://github.com/zturtleman/mint-arena.git
+ source = spearmint-patch::git+https://github.com/zturtleman/spearmint-patch-data.git
+ source = Makefile.local
+ source = spearmint.desktop
+ source = spearmint.service
+ source = spearmint.launcher
+ source = spearmint-server.launcher
+ source = http://ioquake3.org/files/1.36/data/ioquake3-q3a-1.32-9.run
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = 7a5db71f2c9d8630f9cfbe8f345e076344e05791f5ef47f7c2abc232f0c5b4c3d344dba7c4b7defd94e88d1bc77ef55c68c89b53480c61e688cb410f5a1c6d4c
+ sha512sums = 0c192c23cc180181f5edee12cd085e78f0cdd2d6e8f18dbd27532b76c36f2b0e731b764119a0a44df90411f94d3b7475bd40ae0d9b8f5bb3867442f93172746b
+ sha512sums = fd75d6633015057c49fdb1cd29dfa16b8b30fd49df2deb0bbbb9da1a5e84179672ee7fee5df6dc57b0e4b6931ab5200f9e6ada5127e57aec5bf29b3e1b020073
+ sha512sums = 894a0b07399ea7fcf60c97516e5cf19740693192e896e687fba0aeedee675684d94968e69dc927bdb4a44b4298c82d5b4bdca0cc86e707c21cb44f4f9876aea9
+ sha512sums = c7611bf35ace821dcf5829e729c1b0e2f2cc858f2e8ffb491c94990b72990148a8700c1797d715ee2002b3acc10c599d69fa6bc0059c0f9117f64707b6745445
+ sha512sums = 2ff6eff394119697b1c0a76f9c6d70cec21f90aecd89b72f6459661d04821a799a9c70d80f390b2ae7822d5830e247033a79022cd6d3d1754f7780fadd2d418b
+
+pkgname = spearmint-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cfdf54a8ce4e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+spearmint-git
+.*.swp
+*.pkg.tar.xz
+src
+pkg
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
diff --git a/Makefile.local b/Makefile.local
new file mode 100644
index 000000000000..78a2c8fb4c95
--- /dev/null
+++ b/Makefile.local
@@ -0,0 +1,40 @@
+PLATFORM=linux
+export PLATFORM
+
+COMPILE_ARCH=%%_ARCH%%
+
+ARCH=%%_ARCH%%
+export ARCH
+
+CROSS_COMPILING=0
+
+export CROSS_COMPILING
+
+# If we want to change the executables' names, dis where we do it
+#ifndef CLIENTBIN
+#CLIENTBIN=spearmint
+#endif
+#ifndef SERVERBIN
+#SERVERBIN=spearmint-server
+#endif
+
+COPYDIR="%%_SRCDIR%%/opt/quake3"
+
+COPYBINDIR=$(COPYDIR)
+
+TEMPDIR=./tmp
+
+# If we want to use system-supplied libs, we change this to 0.
+# Best to use supplied ones for compatibility with servers, though, I'd think.
+# Plus then I'd have to track them in the makedepends array.
+#USE_INTERNAL_LIBS=1
+#USE_INTERNAL_SPEEX=$(USE_INTERNAL_LIBS)
+#USE_INTERNAL_OGG=$(USE_INTERNAL_LIBS)
+#USE_INTERNAL_VORBIS=$(USE_INTERNAL_LIBS)
+#USE_INTERNAL_OPUS=$(USE_INTERNAL_LIBS)
+#USE_INTERNAL_ZLIB=$(USE_INTERNAL_LIBS)
+#USE_INTERNAL_JPEG=$(USE_INTERNAL_LIBS)
+#USE_INTERNAL_FREETYPE=$(USE_INTERNAL_LIBS)
+#USE_LOCAL_HEADERS=$(USE_INTERNAL_LIBS)
+#USE_RENDERER_DLOPEN=1
+#SERVER_USE_RENDERER_DLOPEN=0
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11ebdb4575bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,213 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('7482 31EB CBD8 08A1 4F5E 85D2 8C00 4C2F 9348 1F6B')
+# Thanks to Slash's ioquake3-git package (https://aur.archlinux.org/packages/ioquake3-git)
+# for install files and desktop icon, and general guidance (I owe you a beer!).
+
+pkgname=spearmint-git
+_pkgname=spearmint
+pkgver=1
+pkgrel=1
+_ioq3v1='1.36'
+_ioq3v2='1.32-9'
+
+## What games do you want to build in support for?
+## baseq3 should at the LEAST be enabled.
+## See https://github.com/zturtleman/spearmint-patch-data.git
+## and https://github.com/zturtleman/spearmint/wiki ("Engine Feature Support").
+## "missionpack" is Q3:Team Arena
+_games=("baseq3"
+ "missionpack")
+
+pkgdesc="An improved ioquake3-based Quake 3: Arena client (note: requires pak files from original CD) - Git master:HEAD"
+url="http://spearmint.pw"
+license=("GPL3")
+arch=('i686' 'x86_64')
+depends=('sdl2')
+makedepends=('sdl2')
+conflicts=('spearmint' 'quake3' 'ioquake3' 'ioquake3-git')
+provides=('quake3' 'ioquake3' 'spearmint' 'ioquake3-git')
+install=spearmint.install
+source=("${_pkgname}-engine::git+https://github.com/zturtleman/spearmint.git"
+ "${_pkgname}-game::git+https://github.com/zturtleman/mint-arena.git"
+ "${_pkgname}-patch::git+https://github.com/zturtleman/spearmint-patch-data.git"
+ "Makefile.local"
+ "spearmint.desktop"
+ "spearmint.service"
+ "spearmint.launcher"
+ "spearmint-server.launcher"
+ "http://ioquake3.org/files/${_ioq3v1}/data/ioquake3-q3a-${_ioq3v2}.run")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ '7a5db71f2c9d8630f9cfbe8f345e076344e05791f5ef47f7c2abc232f0c5b4c3d344dba7c4b7defd94e88d1bc77ef55c68c89b53480c61e688cb410f5a1c6d4c'
+ '0c192c23cc180181f5edee12cd085e78f0cdd2d6e8f18dbd27532b76c36f2b0e731b764119a0a44df90411f94d3b7475bd40ae0d9b8f5bb3867442f93172746b'
+ 'fd75d6633015057c49fdb1cd29dfa16b8b30fd49df2deb0bbbb9da1a5e84179672ee7fee5df6dc57b0e4b6931ab5200f9e6ada5127e57aec5bf29b3e1b020073'
+ '894a0b07399ea7fcf60c97516e5cf19740693192e896e687fba0aeedee675684d94968e69dc927bdb4a44b4298c82d5b4bdca0cc86e707c21cb44f4f9876aea9'
+ 'c7611bf35ace821dcf5829e729c1b0e2f2cc858f2e8ffb491c94990b72990148a8700c1797d715ee2002b3acc10c599d69fa6bc0059c0f9117f64707b6745445'
+ '2ff6eff394119697b1c0a76f9c6d70cec21f90aecd89b72f6459661d04821a799a9c70d80f390b2ae7822d5830e247033a79022cd6d3d1754f7780fadd2d418b')
+
+prepare() {
+
+ if [[ "${CARCH}" == 'i686' ]];
+ then
+ _ARCH='x86'
+ _MKARCH='i86pc'
+ elif [[ "${CARCH}" == 'x86_64' ]];
+ then
+ _ARCH=${CARCH}
+ _MKARCH='amd64'
+ fi
+
+ # soooo $pkgdir, if i recall correctly, isn't available in prepare(). which is kind of stoopit.
+ # so i guess we cross our fingers.
+ sed -i \
+ -e "s@%%_MKARCH%%@${_MKARCH}@g" \
+ -e "s@%%_ARCH%%@${_ARCH}@g" \
+ -e "s@%%_SRCDIR%%@${pkgdir}@g" ${srcdir}/Makefile.local
+
+ cp ${srcdir}/Makefile.local ${srcdir}/${_pkgname}-engine/.
+ cp ${srcdir}/Makefile.local ${srcdir}/${_pkgname}-game/.
+ mkdir ${srcdir}/${_pkgname}-engine/tmp
+ mkdir ${srcdir}/${_pkgname}-game/tmp
+
+ cd ${srcdir}
+ mkdir paks
+ chmod 700 ioquake3-q3a-${_ioq3v2}.run
+ ./ioquake3-q3a-${_ioq3v2}.run --tar xfC ${srcdir}/paks/.
+ install -d -m 750 ${srcdir}/${_pkgname}/{baseq3,missionpack}
+ tar -C ${srcdir}/${_pkgname}/baseq3 -xf ${srcdir}/paks/idpatchpk3s.tar
+ tar -C ${srcdir}/${_pkgname}/missionpack -xf ${srcdir}/paks/idtapatchpk3s.tar
+ cd ${srcdir}
+ # don't need this anymore.
+ rm -rf ${srcdir}/paks
+
+
+}
+
+build() {
+
+ if [[ "${CARCH}" == 'i686' ]];
+ then
+ _ARCH='x86'
+ elif [[ "${CARCH}" == 'x86_64' ]];
+ then
+ _ARCH=${CARCH}
+ fi
+
+ ## ENGINE ##
+ cd ${srcdir}/${_pkgname}-engine
+ make
+
+ cd build/release-linux-${_ARCH}
+ if [ ! -f "${_pkgname}-server" ];
+ then
+ if [[ "${CARCH}" == 'i686' ]];
+ then
+ rm -f ${_pkgname}{,-server}_x86_64
+ elif [[ "${CARCH}" == 'x86_64' ]];
+ then
+ rm -rf ${_pkgname}{,-server}_x86
+ fi
+ fi
+
+
+ ## GAME ##
+ cd ${srcdir}/${_pkgname}-game
+ make
+
+ ## PATCH ##
+ # does not require any building.
+
+}
+
+package() {
+ if [[ "${CARCH}" == 'i686' ]];
+ then
+ _ARCH='x86'
+ elif [[ "${CARCH}" == 'x86_64' ]];
+ then
+ _ARCH=${CARCH}
+ fi
+
+ ## Base dirs ##
+ install -d -m 755 ${pkgdir}/usr/bin
+ install -d -m 755 ${pkgdir}/usr/share/doc/${_pkgname}
+ install -d -m 750 ${pkgdir}/opt/quake3/{baseq3,missionpack,settings}
+
+ ## ENGINE ##
+ install -m 750 ${srcdir}/${_pkgname}-engine/build/release-linux-${_ARCH}/${_pkgname}_${_ARCH} ${pkgdir}/opt/quake3/${_pkgname}
+ install -m 750 ${srcdir}/${_pkgname}-engine/build/release-linux-${_ARCH}/${_pkgname}-server_${_ARCH} ${pkgdir}/opt/quake3/${_pkgname}-server
+ install -m 750 ${srcdir}/${_pkgname}-engine/build/release-linux-${_ARCH}/mint-renderer-opengl1_${_ARCH}.so ${pkgdir}/opt/quake3/
+ install -m 750 ${srcdir}/${_pkgname}-engine/build/release-linux-${_ARCH}/mint-renderer-opengl2_${_ARCH}.so ${pkgdir}/opt/quake3/
+ # docs
+ install -m 644 ${srcdir}/${_pkgname}-engine/id-readme.txt ${pkgdir}/usr/share/doc/${_pkgname}/
+ install -m 644 ${srcdir}/${_pkgname}-engine/md4-readme.txt ${pkgdir}/usr/share/doc/${_pkgname}/
+ install -m 644 ${srcdir}/${_pkgname}-engine/opengl2-readme.md ${pkgdir}/usr/share/doc/${_pkgname}/
+ install -m 644 ${srcdir}/${_pkgname}-engine/README.md ${pkgdir}/usr/share/doc/${_pkgname}/README.engine
+ install -m 644 ${srcdir}/${_pkgname}-engine/voip-readme.txt ${pkgdir}/usr/share/doc/${_pkgname}/
+ # icons, etc.
+ for i in ${srcdir}/${_pkgname}-engine/misc/*.{svg,png,ico};
+ do
+ install -D -m 644 ${i} ${pkgdir}/usr/share/pixmaps/$(basename ${i})
+ done
+
+ ## GAME ##
+ cd ${srcdir}/${_pkgname}-game/build/release-linux-${_ARCH}
+ for i in tools/{lburg,cpp,rcc,etc,asm} baseq3/{,vm,common,ui,game,cgame} missionpack/{,vm,qcommon,q3ui,ui,game,cgame};
+ do
+ install -d -m 750 ${pkgdir}/opt/quake3/${i}
+ done
+ for i in baseq3 tools missionpack;
+ do
+ for f in $(find ${i} -type f);
+ do
+ install -D -m 640 ${f} ${pkgdir}/opt/quake3/${f}
+ done
+ for x in $(find ${i} -type f -executable);
+ do
+ chmod 750 ${pkgdir}/opt/quake3/${x}
+ done
+ done
+
+ ## PATCH ##
+ cd ${srcdir}/${_pkgname}-patch
+ for g in ${_games};
+ do
+ for i in $(find ${g} -type d);
+ do
+ install -d -m 750 ${pkgdir}/opt/quake3/${i}
+ done
+ for i in $(find ${g} -type f);
+ do
+ # TODO: should this be in .pk3 (zip) format?
+ install -D -m 640 ${srcdir}/${_pkgname}-patch/${i} ${pkgdir}/opt/quake3/${i}
+ done
+ done
+
+ # PK3 PAKs from demo
+ install -m 640 ${srcdir}/${_pkgname}/baseq3/* ${pkgdir}/opt/quake3/baseq3/
+ install -m 640 ${srcdir}/${_pkgname}/missionpack/* ${pkgdir}/opt/quake3/missionpack/
+ if [[ -d "${srcdir}/${_pkgname}/settings}" ]];
+ then
+ install -m 640 ${srcdir}/${_pkgname}/settings/* ${pkgdir}/opt/quake3/settings/
+ else
+ install -d -m 750 ${pkgdir}/opt/quake3/settings
+ fi
+
+ cd ${pkgdir}/usr/bin
+ ln -sf /opt/quake3/${_pkgname}.launcher ${_pkgname}
+ ln -sf /opt/quake3/${_pkgname}-server.launcher ${_pkgname}-server
+ ln -sf /opt/quake3/${_pkgname}.launcher quake3
+ ln -sf /opt/quake3/${_pkgname}-server.launcher q3ded
+ ln -sf /opt/quake3/${_pkgname}.launcher ioquake3
+ ln -sf /opt/quake3${_pkgname}-server.launcher ioq3ded
+ cd ${pkgdir}/opt/quake3
+ ln -sf ${_pkgname} ioquake3
+ ln -sf ${_pkgname}-server ioq3ded
+
+ install -D -m 644 ${srcdir}/spearmint.service ${pkgdir}/usr/lib/systemd/system/spearmint.service
+ install -D -m 644 ${srcdir}/spearmint.desktop ${pkgdir}/usr/share/applications/spearmint.desktop
+ install -m 750 ${srcdir}/${_pkgname}.launcher ${pkgdir}/opt/quake3/
+ install -m 750 ${srcdir}/${_pkgname}-server.launcher ${pkgdir}/opt/quake3/
+
+}
diff --git a/spearmint-server.launcher b/spearmint-server.launcher
new file mode 100755
index 000000000000..68c98bfa3e87
--- /dev/null
+++ b/spearmint-server.launcher
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/quake3
+/opt/quake3/spearmint-server +set fs_basepath /opt/quake3 +set fs_homepath ${HOME}/.spearmint ${*}
diff --git a/spearmint.desktop b/spearmint.desktop
new file mode 100644
index 000000000000..e8519f1e8499
--- /dev/null
+++ b/spearmint.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Quake III: Arena (Spearmint)
+GenericName=Spearmint
+Comment=ioQuake3 - Quake III Open Source Engine (with Spearmint modifications)
+Exec=/usr/bin/spearmint
+Icon=/usr/share/pixmaps/spearmint.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Qt;KDE;GNOME;Application;Game;
+
diff --git a/spearmint.install b/spearmint.install
new file mode 100644
index 000000000000..6844de9167e3
--- /dev/null
+++ b/spearmint.install
@@ -0,0 +1,32 @@
+post_install() {
+ groupadd -f games
+ useradd -r -s /sbin/nologin -c "Spearmint Daemon user" -M -d /opt/quake3 -g games spearmint > /dev/null 2>&1
+ chown -R spearmint:games /opt/quake3
+
+ echo '!!!'
+ echo '!!! NOTE: TO PLAY SPEARMINT, YOU MUST BE PART OF THE "games" GROUP!'
+ echo '!!! To play Spearmint with the Retail Version of Quake III: Arena,'
+ echo '!!! move the pak0.pk3 file from the original game CD to /opt/quake3/baseq3/'
+ echo '!!!'
+ echo '!!!'
+ echo '!!! When you have the .pk3 file(s) installed, you can run the game via: quake3'
+ echo '!!! See https://github.com/zturtleman/spearmint/wiki for more documentation.'
+ echo '!!!'
+}
+
+post_upgrade() {
+ post_install ${1}
+}
+
+post_remove() {
+ #userdel -rf spearmint > /dev/null 2>&1
+ userdel spearmint > /dev/null 2>&1
+ if egrep -q '^games:.*:$' /etc/group;
+ then
+ groupdel games
+ fi
+ if [[ -d '/opt/quake3' ]];
+ then
+ chown -R root:root /opt/quake3 > /dev/null 2>&1
+ fi
+}
diff --git a/spearmint.launcher b/spearmint.launcher
new file mode 100755
index 000000000000..2ce9c44d5c17
--- /dev/null
+++ b/spearmint.launcher
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/quake3
+/opt/quake3/spearmint +set fs_basepath /opt/quake3 +set fs_homepath ${HOME}/.spearmint ${*}
diff --git a/spearmint.service b/spearmint.service
new file mode 100644
index 000000000000..00c6789523e6
--- /dev/null
+++ b/spearmint.service
@@ -0,0 +1,22 @@
+[Unit]
+Description=This service spawns an ioquake3 (Spearmint) dedicated server with sane defaults
+# However, these defaults may not apply to all use cases.
+# See comments below for further details
+
+[Service]
+User=spearmint
+ExecStart=/opt/quake3/spearmint-server +set dedicated 2
+Restart=on-abort
+# there are several options to tweak the server's performance:
+# net_port defines the UDP-port used for connections to the server
+# fs_game should be the mod you want to play. Not necessary for vanilla-q3/FFA
+# dedicated 0 is non-dedicted an not available with ioq3ded, 1 is LAN, 2 is Internet
+# sv_pure 1 prevents clients from using their own pk3-files
+# com_hunkmegs defaults to 56, should be 128/192/256 on a modern system(?)
+# rate 25000 defines the rate in which client & server communicate
+# snaps 40 defines gamestate-snapshots client & server exchange in secs
+# cl_maxpackets 125 max amount of FPS being counted on the server-side
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/spearmint.svg b/spearmint.svg
new file mode 100644
index 000000000000..470c840ee01f
--- /dev/null
+++ b/spearmint.svg
@@ -0,0 +1,105 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="1024"
+ height="1024"
+ id="svg2"
+ version="1.1"
+ inkscape:version="0.48.3.1 r9886"
+ sodipodi:docname="spearmint_icon.svg">
+ <defs
+ id="defs4">
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient3025-7"
+ id="linearGradient3031-4"
+ x1="188.57143"
+ y1="688.07648"
+ x2="987.14288"
+ y2="168.07646"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(0.59873694,0,0,0.59873694,297.37016,143.09113)" />
+ <linearGradient
+ inkscape:collect="always"
+ id="linearGradient3025-7">
+ <stop
+ style="stop-color:#4e9a06;stop-opacity:1;"
+ offset="0"
+ id="stop3027-7" />
+ <stop
+ style="stop-color:#4e9a06;stop-opacity:0;"
+ offset="1"
+ id="stop3029-3" />
+ </linearGradient>
+ </defs>
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="0.7"
+ inkscape:cx="782.76749"
+ inkscape:cy="513.52888"
+ inkscape:document-units="px"
+ inkscape:current-layer="layer1"
+ showgrid="false"
+ inkscape:window-width="1920"
+ inkscape:window-height="993"
+ inkscape:window-x="0"
+ inkscape:window-y="27"
+ inkscape:window-maximized="1" />
+ <metadata
+ id="metadata7">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Layer 1"
+ inkscape:groupmode="layer"
+ id="layer1"
+ transform="translate(0,-28.362183)">
+ <rect
+ style="fill:#eeeeec;fill-opacity:1;stroke:#2e3436;stroke-width:5;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-opacity:1;stroke-dasharray:none;stroke-dashoffset:0"
+ id="rect3178"
+ width="997.64111"
+ height="997.64111"
+ x="13.179454"
+ y="41.541637"
+ ry="263.64294" />
+ <path
+ style="fill:#4e9a06;fill-opacity:1;stroke:#2e3436;stroke-width:5;stroke-linecap:round;stroke-linejoin:round;stroke-miterlimit:4;stroke-opacity:1;stroke-dasharray:none;stroke-dashoffset:0"
+ d="M 512 13.1875 L 512 512 L 1010.8125 512 L 1010.8125 276.8125 C 1010.8125 130.75431 893.24569 13.1875 747.1875 13.1875 L 512 13.1875 z M 512 512 L 13.1875 512 L 13.1875 747.1875 C 13.1875 893.24569 130.75431 1010.8125 276.8125 1010.8125 L 512 1010.8125 L 512 512 z "
+ transform="translate(0,28.362183)"
+ id="rect3178-4" />
+ <g
+ inkscape:label="Layer 1"
+ id="layer1-5"
+ transform="matrix(4.5778762,0,0,4.5778762,455.12887,-9.0510728)"
+ style="fill:#73d216">
+ <path
+ sodipodi:nodetypes="ccccccccccc"
+ inkscape:connector-curvature="0"
+ id="path4262"
+ d="m 25.957183,41.594163 c -7.740369,-12.20204 2.972126,-23.314574 14.138351,-16.97324 9.804333,5.351421 31.806208,22.766039 43.985891,36.91104 l 22.306005,5.399724 7.58532,12.727922 c -7.02745,-0.72793 -10.15493,-0.7291 -16.021917,-1.216798 5.554077,12.062425 -5.841501,23.284359 -20.297652,17.801666 l 0.25713,17.741953 -9.513801,-6.81394 -9.77093,-25.712973 C 46.58443,69.207581 29.551735,47.593492 25.957183,41.594163 z"
+ style="fill:#73d216;fill-opacity:1;stroke:none" />
+ </g>
+ </g>
+</svg>