summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Mensinger2022-12-24 14:26:22 +0100
committerDaniel Mensinger2022-12-24 15:15:25 +0100
commitd93d52ceac9861346c74ea12c5d5349ccb0ec159 (patch)
tree50dc98cb55d9543b3f232cfee7f2d6bff1866879
downloadaur-d93d52ceac9861346c74ea12c5d5349ccb0ec159.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD44
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2b1628122b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qscan
+ pkgdesc = QT document scanner using SANE
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/mensinda/qScan
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = Apache
+ makedepends = meson
+ makedepends = nlohmann-json
+ depends = sane
+ depends = qt5-base
+ depends = imagemagick
+ depends = spdlog
+ source = https://github.com/mensinda/qScan/archive/refs/tags/v1.0.1.tar.gz
+ source = https://github.com/mensinda/enumGen/archive/refs/tags/v1.1.2.tar.gz
+ sha256sums = 8072a5c9ece93be1e7bb39c303a709fcd926aa942faff6bc367a8c26629b480e
+ sha256sums = 987e608f52e651e1c90514893485331227f0064e887068124fac1a8cb96d7a8a
+
+pkgname = qscan
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..013a46b919c1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6004244e86ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Daniel Mensinger <daniel@mensinger-ka.de>
+_pkgname=qScan
+pkgname=qscan
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="QT document scanner using SANE"
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
+url="https://github.com/mensinda/qScan"
+license=('Apache')
+groups=()
+depends=(sane qt5-base imagemagick spdlog)
+makedepends=(meson nlohmann-json)
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ https://github.com/mensinda/$_pkgname/archive/refs/tags/v${pkgver}.tar.gz
+ https://github.com/mensinda/enumGen/archive/refs/tags/v1.1.2.tar.gz # Compile time code generator
+)
+noextract=()
+sha256sums=('8072a5c9ece93be1e7bb39c303a709fcd926aa942faff6bc367a8c26629b480e'
+ '987e608f52e651e1c90514893485331227f0064e887068124fac1a8cb96d7a8a')
+
+prepare() {
+ cp -R "enumGen-1.1.2" "$_pkgname-$pkgver/subprojects"
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ arch-meson build -Dwerror=false
+ meson compile -C build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ meson install -C build --destdir "$pkgdir"
+}