summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLingMan2022-05-23 01:28:25 +0200
committerLingMan2022-05-23 01:35:06 +0200
commitd9616c3df879478a64d9ce70909ccfb25c38a69b (patch)
tree50cd042c28ba63caea87d9b5472b5bfa90d8ee53
downloadaur-d9616c3df879478a64d9ce70909ccfb25c38a69b.tar.gz
AUR submission after python2 support was dropped from the main repos in
https://github.com/archlinux/svntogit-community/commit/f5b5064000c1ba5a1a17f38ea7bc015b4c672f2d
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed10ee31954d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-psutil
+ pkgdesc = A cross-platform process and system utilities module for Python2
+ pkgver = 5.9.0
+ pkgrel = 1
+ url = https://github.com/giampaolo/psutil
+ arch = x86_64
+ license = custom: BSD
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = https://github.com/giampaolo/psutil/archive/release-5.9.0.tar.gz
+ sha512sums = 8f105b84773c901a7969937bac2289281dc48f160f20e2d3d5f9b11f4a108fddf9864b477884c00ec33c3809f9f514a5f5faea623b7445dd8e637b96105a865b
+
+pkgname = python2-psutil
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3146f38b1c3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+pkgname='python2-psutil'
+pkgver=5.9.0
+pkgrel=1
+pkgdesc='A cross-platform process and system utilities module for Python2'
+arch=('x86_64')
+url='https://github.com/giampaolo/psutil'
+license=('custom: BSD')
+makedepends=('python2' 'python2-setuptools')
+source=("https://github.com/giampaolo/psutil/archive/release-$pkgver.tar.gz")
+sha512sums=('8f105b84773c901a7969937bac2289281dc48f160f20e2d3d5f9b11f4a108fddf9864b477884c00ec33c3809f9f514a5f5faea623b7445dd8e637b96105a865b')
+
+build() {
+ cd psutil-release-$pkgver
+
+ python2 setup.py build
+}
+
+package() {
+ cd psutil-release-$pkgver
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m 644 LICENSE "$pkgdir/"usr/share/licenses/$pkgname/LICENSE
+}