summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Mathis2019-12-20 21:43:44 -0500
committerMatt Mathis2019-12-20 21:43:44 -0500
commitd977af80cb11a0da20a62b711a85ae47ae3d2b16 (patch)
treedd586d1ff2ec7b02dabacafcd1633c821db07cc0
parent05aa0db5d710a7e8115d5dca3642e16eb93b4833 (diff)
downloadaur-d977af80cb11a0da20a62b711a85ae47ae3d2b16.tar.gz
Updated wofi to the upcoming build system
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 574af3d6c019..728452ad8956 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = wofi-hg
pkgdesc = Rofi-like wlroots launcher
- pkgver = r57.15a802c4f55f
+ pkgver = r112.7906ded22800
pkgrel = 1
url = https://hg.sr.ht/~scoopta/wofi
arch = x86_64
license = GPL3
makedepends = mercurial
+ makedepends = meson
depends = wayland
depends = gtk3
source = wofi-hg::hg+https://hg.sr.ht/~scoopta/wofi
diff --git a/PKGBUILD b/PKGBUILD
index 37373f7bf313..03a28082fee7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=wofi-hg
-pkgver=r57.15a802c4f55f
+pkgver=r112.7906ded22800
pkgrel=1
pkgdesc="Rofi-like wlroots launcher"
arch=('x86_64')
url="https://hg.sr.ht/~scoopta/wofi"
license=('GPL3')
depends=('wayland' 'gtk3')
-makedepends=('mercurial')
+makedepends=('mercurial' 'meson')
source=("${pkgname}::hg+$url")
sha256sums=('SKIP')
pkgver() {
@@ -14,10 +14,11 @@ pkgver() {
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
build() {
- cd "${pkgname}/Release"
- make
+ cd "${pkgname}"
+ meson build
+ ninja -C build
}
package() {
mkdir -p "$pkgdir/usr/bin"
- cp ${pkgname}/Release/wofi "$pkgdir/usr/bin/"
+ cp ${pkgname}/build/wofi "$pkgdir/usr/bin/"
} \ No newline at end of file