summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2022-12-10 19:19:31 -0500
committeréclairevoyant2022-12-10 19:19:31 -0500
commitd97bfa593a1a635c69cb66bdd2453e70dedc6604 (patch)
treeb651952e4a1968c48d75ae8b43d13e9a0f9c90e7
parentfb34fcbc8401eb4e5d2a95ee45d2ffe58e92fffd (diff)
downloadaur-d97bfa593a1a635c69cb66bdd2453e70dedc6604.tar.gz
upgpkg: y-cruncher 0.7.10.9513-1
upstream release add LICENSE, .gitignore Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
-rw-r--r--y-cruncher.LICENSE17
4 files changed, 46 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0ff42877d3c..e13ccc8f1d97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = y-cruncher
- pkgdesc = The first scalable multi-threaded Pi-benchmark for multi-core systems.
- pkgver = 0.7.9.9509
+ pkgdesc = The first scalable multi-threaded Pi-benchmark for multi-core systems
+ pkgver = 0.7.10.9513
pkgrel = 1
- url = http://www.numberworld.org/y-cruncher/
+ url = http://www.numberworld.org/y-cruncher
arch = x86_64
- license = unknown
+ license = custom
depends = gcc-libs
options = !strip
- source = http://www.numberworld.org/y-cruncher/y-cruncher%20v0.7.9.9509-static.tar.xz
- sha512sums = f9747773cb5bbbf5e09513860db69d43a1d7fef654705b988a3def6e3ef93c9e3a347082933dca61791730809205fe388ecc4683254c5c0082f432faadcec96f
+ source = http://www.numberworld.org/y-cruncher/y-cruncher%20v0.7.10.9513-static.tar.xz
+ source = y-cruncher.LICENSE
+ b2sums = f8e4907a47a268c19368f313973e554b0e16bfb5d2bc6a510939fb87cbdcc08f5c83c13874c6eb8859910c870b9989dfeae6e3ada461e4b2d93123a6f38e7725
+ b2sums = 54566d34c40a1ce90c19df611838a54c898f530b361c83998fc68103b108b5da4a03cd5616ffcdec5185c0fea2fc837ca2db337364d0d9c783ccbc746e9d92fc
pkgname = y-cruncher
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..33892a44ad0e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!y-cruncher.LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index cb90ca25785d..92c4c5475281 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
-# Maintainer: SilverMight <silver at silvermight dot com>
+# Maintainer: éclairevoyant
+# Contributor: SilverMight <silver at silvermight dot com>
# Contributor: Bastian Plettner <b.pletttner at archlinux dot info>
# Contributor: thesqrtminus1 <thesqrtminus1 at gmail dot com>
# Contributor: kstolp <kevinstolp at gmail dot com>
# Contributor: kfgz <ffiasd at gmail dot com>
+
pkgname=y-cruncher
-pkgver=0.7.9.9509
+pkgver=0.7.10.9513
pkgrel=1
-pkgdesc="The first scalable multi-threaded Pi-benchmark for multi-core systems."
+pkgdesc="The first scalable multi-threaded Pi-benchmark for multi-core systems"
arch=('x86_64')
-url="http://www.numberworld.org/y-cruncher/"
-license=('unknown')
-options=(!strip)
+url="http://www.numberworld.org/$pkgname"
+license=('custom')
+options=('!strip')
depends=('gcc-libs')
-source=("http://www.numberworld.org/y-cruncher/y-cruncher%20v${pkgver}-static.tar.xz")
-sha512sums=('f9747773cb5bbbf5e09513860db69d43a1d7fef654705b988a3def6e3ef93c9e3a347082933dca61791730809205fe388ecc4683254c5c0082f432faadcec96f')
+source=("$url/$pkgname%20v$pkgver-static.tar.xz"
+ "$pkgname.LICENSE"
+)
+b2sums=('f8e4907a47a268c19368f313973e554b0e16bfb5d2bc6a510939fb87cbdcc08f5c83c13874c6eb8859910c870b9989dfeae6e3ada461e4b2d93123a6f38e7725'
+ '54566d34c40a1ce90c19df611838a54c898f530b361c83998fc68103b108b5da4a03cd5616ffcdec5185c0fea2fc837ca2db337364d0d9c783ccbc746e9d92fc')
+
package() {
-install -D -m755 ${srcdir}/y-cruncher\ v${pkgver}-static/Binaries/"05-A64 ~ Kasumi" ${pkgdir}/usr/bin/y-cruncher
+ install -Dm755 "$pkgname v$pkgver-static/Binaries/05-A64 ~ Kasumi" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/y-cruncher.LICENSE b/y-cruncher.LICENSE
new file mode 100644
index 000000000000..2f5db764d692
--- /dev/null
+++ b/y-cruncher.LICENSE
@@ -0,0 +1,17 @@
+Copyright 2008-2019 by Alexander J. Yee
+
+You may mirror and distribute this software free of charge for any purpose.
+You may use this software free of charge for any non-commercial purpose.
+You may also use this software for any academic purpose (including technology reviews), even if they are commercial.
+
+If wish to publicize a world record set using y-cruncher, you must indicate that it was done using this software.
+
+If you wish to use y-cruncher for commercial purposes, please contact the developer at: a-yee@u.northwestern.edu
+Commercial use licenses may be available depending on the intended usage.
+
+The terms of this license may change at any time with or without prior notification.
+The latest version of the license can be found at: www.numberworld.org/y-cruncher/license.html
+
+Disclaimers:
+
+This software is provided "as is" and the author disclaims all warranties with regard to this software including all implied warranties of merchantability and fitness. In no event shall the author be liable for any special, direct, indirect, or consequential damages, or any damages whatsoever resulting from loss of use, data or profits, whether in an action of contract, negligence or other tortious action, arising out of or in connection with the use or performance of this software.