summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2020-01-31 17:49:59 +0330
committerBehnam Momeni2020-01-31 17:49:59 +0330
commitd9ad2ca3354061fbefd8434b0a0c28168abdbc6d (patch)
tree00ca7155129dc3557a07173f7733672edc0552ab
downloadaur-d9ad2ca3354061fbefd8434b0a0c28168abdbc6d.tar.gz
Initial commit; version 0.3.95
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1727cb9dd86c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jan 31 14:16:30 UTC 2020
+pkgbase = lib32-lensfun
+ pkgdesc = Database of photographic lenses and a library to access them (32-bit)
+ pkgver = 0.3.95
+ pkgrel = 1
+ url = https://lensfun.sourceforge.net
+ arch = x86_64
+ license = LGPL3
+ makedepends = python
+ makedepends = libpng
+ makedepends = cmake
+ depends = lensfun
+ depends = lib32-glib2
+ optdepends = python: for lensfun-update-data and lensfun-add-adapter
+ source = https://sourceforge.net/projects/lensfun/files/0.3.95/lensfun-0.3.95.tar.gz
+ sha256sums = 82c29c833c1604c48ca3ab8a35e86b7189b8effac1b1476095c0529afb702808
+
+pkgname = lib32-lensfun
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..81c39e5d8fa9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+lensfun-*.tar.gz
+lib32-lensfun-*.pkg.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11c8a1354c40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=lib32-lensfun
+_pkgbase=lensfun
+pkgver=0.3.95
+pkgrel=1
+pkgdesc="Database of photographic lenses and a library to access them (32-bit)"
+arch=('x86_64')
+url="https://lensfun.sourceforge.net"
+license=('LGPL3')
+depends=('lensfun' 'lib32-glib2')
+makedepends=('python' 'libpng' 'cmake')
+optdepends=('python: for lensfun-update-data and lensfun-add-adapter')
+source=("https://sourceforge.net/projects/${_pkgbase}/files/${pkgver}/${_pkgbase}-${pkgver}.tar.gz")
+sha256sums=('82c29c833c1604c48ca3ab8a35e86b7189b8effac1b1476095c0529afb702808')
+
+build() {
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ cd "$_pkgbase-$pkgver"
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib32 \
+ -DCMAKE_CXX_FLAGS="-m32 ${CXXFLAGS} -fno-delete-null-pointer-checks" \
+ -DCMAKE_C_FLAGS="-m32 ${CFLAGS} -fno-delete-null-pointer-checks"
+ make all
+}
+
+package() {
+ cd "$_pkgbase-$pkgver"
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir/usr/"{bin,share,include,lib}
+}
+