summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBradford Smith2021-10-23 10:59:48 -0400
committerBradford Smith2021-10-23 11:05:25 -0400
commitd9ae7a3f344dfb6a2fd932fbccc307976d258d9d (patch)
treeeb80386882e0660855987f9784a47fbe3a921a6c
parent30310951f58287dc070ff26f1bcbd512c065c051 (diff)
downloadaur-d9ae7a3f344dfb6a2fd932fbccc307976d258d9d.tar.gz
Make manpage zipping reproducible
Jelle van der Waa's blog had a post about how manpage gzipping was not by default reproducible as it included the timestamp [1]. This makes the same fix that Jelle did for the hyperfine package [2]. [1]: https://vdwaa.nl/arch-repro-july-2021.html#arch-repro-july-2021 [2]: https://github.com/archlinux/svntogit-community/commit/b3d5765435d94fbfe936d45fd0e8668bbc6ed047#diff-3e341d2d9c67be01819b25b25d5e53ea3cdf3a38d28846cda85a195eb9b7203a
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28dd64756284..6df261b1d90b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = informant
pkgdesc = An Arch Linux News reader and pacman hook
pkgver = 0.4.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bradford-smith94/informant
install = informant.install
arch = any
@@ -13,6 +13,7 @@ pkgbase = informant
depends = python-html2text
depends = python-cachecontrol
depends = python-lockfile
+ options = zipman
source = https://github.com/bradford-smith94/informant/archive/v0.4.4.tar.gz
sha256sums = 4f8745bec30fb82396b141f99a529d542085bcda982a9d178ebba5c07fd4425f
diff --git a/PKGBUILD b/PKGBUILD
index c2aeb0531d26..ece193bc35a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=informant
pkgver=0.4.4
-pkgrel=1
+pkgrel=2
pkgdesc="An Arch Linux News reader and pacman hook"
arch=('any')
url="https://github.com/bradford-smith94/$pkgname"
@@ -10,6 +10,7 @@ license=('MIT')
install=informant.install
depends=('python' 'python-docopt' 'python-dateutil' 'python-feedparser' 'python-html2text' 'python-cachecontrol' 'python-lockfile')
source=("https://github.com/bradford-smith94/$pkgname/archive/v$pkgver.tar.gz")
+options=(zipman)
sha256sums=('4f8745bec30fb82396b141f99a529d542085bcda982a9d178ebba5c07fd4425f')
@@ -25,5 +26,4 @@ package() {
install -Dm 0644 $pkgname.hook -T $pkgdir/usr/share/libalpm/hooks/00-$pkgname.hook
install -Dm 0644 LICENSE -t $pkgdir/usr/share/licenses/$pkgname/
install -Dm 0644 man/$pkgname.1 -t $pkgdir/usr/share/man/man1/
- gzip $pkgdir/usr/share/man/man1/$pkgname.1
}