summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2022-11-19 18:53:15 +0100
committerJean-Marc Lenoir2022-11-19 18:53:15 +0100
commitd9c69e9ba4345fce53919a09a14d969ab393f79b (patch)
tree44b8ceeb55762d67ceb028304b701adcf5fd2589
parent3fba72454f3c64964cc45c9500ccb6be45b59802 (diff)
downloadaur-d9c69e9ba4345fce53919a09a14d969ab393f79b.tar.gz
Sync with vmware-workstation 17.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--vmmon.patch80
-rw-r--r--vmnet.patch395
4 files changed, 153 insertions, 334 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7a68f97251d..8a194f2824dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation15
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 15.5.7
- pkgrel = 9
+ pkgrel = 10
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -86,7 +86,7 @@ pkgbase = vmware-workstation15
sha256sums = fe1b1be8297f4170406f97dd1f8b385d911faf45afe19cbc0c26b8092b3ddf8d
sha256sums = 10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e
sha256sums = 273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac
- sha256sums = 0d4c178c4ab2ea9af79e92268c57822abf8e5f19882db9b2a3faf73ca6cb6202
- sha256sums = b81914d48791f4056e6f21860b5c628c17404139d569267fd20b8f6385ba6202
+ sha256sums = 5b7c4ada0218214fa04ccb1f6c8033571f3991a83c5a613692db7a71e48d62c7
+ sha256sums = 2463f3e7104d0a0627ab2cc17edb3d0e65615613e157817f4b39af8339e8628b
pkgname = vmware-workstation15
diff --git a/PKGBUILD b/PKGBUILD
index cef45ff5f294..809d3c01c182 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=vmware-workstation15
pkgver=15.5.7
_buildver=17171714
_pkgver=${pkgver}_${_buildver}
-pkgrel=9
+pkgrel=10
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -123,8 +123,8 @@ sha256sums=(
'10562d11d50edab9abc2b29c8948714edcb9b084f99b3766d07ddd21259e372e'
'273d4357599a3e54259c78cc49054fef8ecfd2c2eda35cbcde3a53a62777a5ac'
- '0d4c178c4ab2ea9af79e92268c57822abf8e5f19882db9b2a3faf73ca6cb6202'
- 'b81914d48791f4056e6f21860b5c628c17404139d569267fd20b8f6385ba6202'
+ '5b7c4ada0218214fa04ccb1f6c8033571f3991a83c5a613692db7a71e48d62c7'
+ '2463f3e7104d0a0627ab2cc17edb3d0e65615613e157817f4b39af8339e8628b'
)
options=(!strip emptydirs)
diff --git a/vmmon.patch b/vmmon.patch
index 0620eea41650..ecec5748baa1 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -20,6 +20,20 @@
include $(SRCROOT)/Makefile.kernel
+--- a/vmmon/include/vm_basic_defs.h
++++ b/vmmon/include/vm_basic_defs.h
+@@ -50,7 +50,10 @@
+ * References:
+ * C90 7.17, C99 7.19, C11 7.19
+ */
+-#if !defined(VMKERNEL)
++/* Use linux/stddef.h when building Linux kernel modules. */
++#ifdef KBUILD_MODNAME
++# include <linux/stddef.h>
++#elif !defined(VMKERNEL)
+ # include <stddef.h>
+ #else
+ /*
--- a/vmmon/linux/hostif.c
+++ b/vmmon/linux/hostif.c
@@ -47,6 +47,8 @@
@@ -120,7 +134,7 @@
lockedPages += global_node_page_state(NR_SLAB_UNRECLAIMABLE);
#else
lockedPages += global_page_state(NR_SLAB_UNRECLAIMABLE);
-@@ -2389,16 +2426,22 @@
+@@ -2389,16 +2426,26 @@
static Bool
isVAReadable(VA r) // IN:
{
@@ -128,7 +142,11 @@
uint32 dummy;
int ret;
-+#ifdef HAVE_GET_KERNEL_NOFAULT
++#if defined(HAVE_GET_KERNEL_NOFAULT) || LINUX_VERSION_CODE >= KERNEL_VERSION(5, 17, 0)
++ /*
++ * Exists from 5.10, first indicated by HAVE_GET_KERNEL_NOFAULT,
++ * and from post-5.17 just existing everywhere.
++ */
+ ret = get_kernel_nofault(dummy, (void *)r);
+#else
+ {
@@ -280,61 +298,3 @@
/*
* Do not exit thread until we are told to do so.
*/
-From 4232f780eb114f22498f3274eaeef81d8c63f2ab Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Tue, 9 Nov 2021 09:01:57 +0100
-Subject: [PATCH] modules: fix stddef.h include
-
-After mainline commit 04e85bbf71c9 ("isystem: delete global -isystem
-compile option") in 5.16-rc1, vm_basic_types.h in both vmmon and vmnet
-does not find (userspace) stddef.h any more. As it should not include this
-header anyway, fix the include directives to include stddef.h from kernel.
-
-Kernel version of stddef.h has been available since the beginning of git so
-that it is safe to include it regardless of kernel version.
----
- vmmon-only/include/vm_basic_defs.h | 2 +-
- vmnet-only/vm_basic_defs.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/vmmon-only/include/vm_basic_defs.h b/vmmon-only/include/vm_basic_defs.h
-index 0ec30b3..b920e2d 100644
---- a/vmmon-only/include/vm_basic_defs.h
-+++ b/vmmon-only/include/vm_basic_defs.h
-@@ -51,7 +51,7 @@
- * C90 7.17, C99 7.19, C11 7.19
- */
- #if !defined(VMKERNEL)
--# include <stddef.h>
-+# include <linux/stddef.h>
- #else
- /*
- * Vmkernel's bogus __FreeBSD__ value causes gcc <stddef.h> to break.
-From 16d490ae022d7fc4ca867971e20e2dcd59e6ca5a Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Mon, 4 Apr 2022 01:57:28 +0200
-Subject: [PATCH] vmmon: do not rely on HAVE_GET_KERNEL_NOFAULT
-
-Mainline commit 34737e269803 ("uaccess: add generic
-__{get,put}_kernel_nofault") in 5.18-rc1 removes HAVE_GET_KERNEL_NOFAULT
-macro as all architectures can use get_kernel_nofault() now. Check for
-existence of __get_kernel_nofault() instead and add also a version check in
-case it stops being a macro or is removed in the future.
----
- vmmon-only/linux/hostif.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
-index a21c300..b6326e9 100644
---- a/vmmon-only/linux/hostif.c
-+++ b/vmmon-only/linux/hostif.c
-@@ -2436,7 +2436,8 @@ isVAReadable(VA r) // IN:
- uint32 dummy;
- int ret;
-
--#ifdef HAVE_GET_KERNEL_NOFAULT
-+#if defined(HAVE_GET_KERNEL_NOFAULT) || defined(__get_kernel_nofault) || \
-+ (LINUX_VERSION_CODE >= KERNEL_VERSION(5, 18, 0))
- ret = get_kernel_nofault(dummy, (void *)r);
- #else
- {
diff --git a/vmnet.patch b/vmnet.patch
index 0c14539792bb..4fb225528066 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -20,152 +20,70 @@
include $(SRCROOT)/Makefile.kernel
---- a/vmnet/userif.c
-+++ b/vmnet/userif.c
-@@ -559,7 +559,12 @@
- return -EINVAL;
- }
-
-+#if COMPAT_LINUX_VERSION_CHECK_LT(5, 10, 0)
- csum = csum_and_copy_to_user(skb->data + offset, curr, len, 0, &err);
-+#else
-+ csum = csum_and_copy_to_user(skb->data + offset, curr, len);
-+ err = (csum == 0) ? -EFAULT : 0;
-+#endif
- if (err) {
- return err;
- }
-@@ -573,8 +578,14 @@
- const void *vaddr;
-
- vaddr = kmap(skb_frag_page(frag));
-+#if COMPAT_LINUX_VERSION_CHECK_LT(5, 10, 0)
- tmpCsum = csum_and_copy_to_user(vaddr + skb_frag_off(frag),
- curr, skb_frag_size(frag), 0, &err);
+--- a/vmnet/bridge.c
++++ b/vmnet/bridge.c
+@@ -684,14 +684,11 @@
+ }
+ spin_unlock_irqrestore(&bridge->historyLock, flags);
+
+- /*
+- * We used to cli() before calling netif_rx() here. It was probably
+- * unneeded (as we never did it in netif.c, and the code worked). In
+- * any case, now that we are using netif_rx_ni(), we should certainly
+- * not do it, or netif_rx_ni() will deadlock on the cli() lock --hpreg
+- */
+-
+- netif_rx_ni(clone);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 18, 0)
++ netif_rx_ni(clone);
+#else
-+ tmpCsum = csum_and_copy_to_user(vaddr + skb_frag_off(frag),
-+ curr, skb_frag_size(frag));
-+ err = (tmpCsum == 0) ? -EFAULT : 0;
++ netif_rx(clone);
+#endif
- kunmap(skb_frag_page(frag));
-
- if (err) {
-# Fixing VMWare Player on Linux when using DHCP addresses: https://www.nikhef.nl/~janjust/vmnet/
-@@ -985,6 +996,9 @@
- userIf = (VNetUserIF *)port->jack.private;
- hubJack = port->jack.peer;
-
-+ /* never send link down events */
-+ if (!linkUp) return 0;
-+
- if (port->jack.state == FALSE || hubJack == NULL) {
- return -EINVAL;
- }
-From 4232f780eb114f22498f3274eaeef81d8c63f2ab Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Tue, 9 Nov 2021 09:01:57 +0100
-Subject: [PATCH] modules: fix stddef.h include
-
-After mainline commit 04e85bbf71c9 ("isystem: delete global -isystem
-compile option") in 5.16-rc1, vm_basic_types.h in both vmmon and vmnet
-does not find (userspace) stddef.h any more. As it should not include this
-header anyway, fix the include directives to include stddef.h from kernel.
-
-Kernel version of stddef.h has been available since the beginning of git so
-that it is safe to include it regardless of kernel version.
----
- vmmon-only/include/vm_basic_defs.h | 2 +-
- vmnet-only/vm_basic_defs.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/vmnet-only/vm_basic_defs.h b/vmnet-only/vm_basic_defs.h
-index 0ec30b3..b920e2d 100644
---- a/vmnet-only/vm_basic_defs.h
-+++ b/vmnet-only/vm_basic_defs.h
-@@ -51,7 +51,7 @@
- * C90 7.17, C99 7.19, C11 7.19
- */
- #if !defined(VMKERNEL)
--# include <stddef.h>
-+# include <linux/stddef.h>
- #else
- /*
- * Vmkernel's bogus __FreeBSD__ value causes gcc <stddef.h> to break.
-From 4af1a71978962f9805fe2e7e6ceb05c24f42c7f0 Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Tue, 11 Jan 2022 17:25:45 +0100
-Subject: [PATCH] vmnet: use accessors for net_device::dev_addr
-
-Mainline commit adeef3e32146 ("net: constify netdev->dev_addr") in 5.17-rc1
-makes dev_addr member of struct net_device const but accessors should be
-used to modify it since 5.15 to make sure rbtree with hardware address list
-is updated properly.
-
-Use dev_addr_set() and __dev_addr_set() in VNetNetifSetMAC() and
-VNetNetIf_Create(). For kernels before 5.15 provide our own version of the
-accessors. As SMAC_SetMac() only reads dev_addr, constify the corresponding
-argument.
----
- vmnet-only/netif.c | 18 +++++++++++++++---
- vmnet-only/smac.c | 2 +-
- vmnet-only/smac.h | 2 +-
- 3 files changed, 17 insertions(+), 5 deletions(-)
-
-diff --git a/vmnet-only/netif.c b/vmnet-only/netif.c
-index c70f7f4..8c3bbf8 100644
---- a/vmnet-only/netif.c
-+++ b/vmnet-only/netif.c
-@@ -44,7 +44,6 @@
- #include "compat_netdevice.h"
- #include "vmnetInt.h"
+ # if LOGLEVEL >= 4
+ do_gettimeofday(&vnetTime);
+ # endif
+--- a/vmnet/netif.c
++++ b/vmnet/netif.c
+@@ -253,7 +253,11 @@
--
- /*
- * Default min MTU value as defined by kernel versions >= 4.10.0.
- * Use the same value for earlier versions of the kernel which do not
-@@ -86,6 +85,19 @@ static int VNetNetIfProcRead(char *page, char **start, off_t off,
- static int VNetNetifChangeMtu(struct net_device *dev, int new_mtu);
- #endif
+ memset(&netIf->stats, 0, sizeof netIf->stats);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 15, 0)
-+static void
-+__dev_addr_set(struct net_device *dev, const void *addr, size_t len)
-+{
-+ memcpy(dev->dev_addr, addr, len);
-+}
-+
-+static void dev_addr_set(struct net_device *dev, const u8 *addr)
-+{
-+ __dev_addr_set(dev, addr, dev->addr_len);
-+}
+ memcpy(dev->dev_addr, netIf->port.paddr, sizeof netIf->port.paddr);
++#else
++ eth_hw_addr_set(dev, netIf->port.paddr);
+#endif
-+
-
- /*
- *----------------------------------------------------------------------
-@@ -253,7 +265,7 @@ VNetNetIf_Create(char *devName, // IN:
-
- memset(&netIf->stats, 0, sizeof netIf->stats);
-
-- memcpy(dev->dev_addr, netIf->port.paddr, sizeof netIf->port.paddr);
-+ __dev_addr_set(dev, netIf->port.paddr, sizeof(netIf->port.paddr));
if (register_netdev(dev) != 0) {
LOG(0, (KERN_NOTICE "%s: could not register network device\n",
-@@ -532,7 +544,7 @@ VNetNetifSetMAC(struct net_device *dev, // IN:
+@@ -345,7 +349,11 @@
+ /* send to the host interface */
+ skb->dev = netIf->dev;
+ skb->protocol = eth_type_trans(skb, netIf->dev);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 18, 0)
+ netif_rx_ni(skb);
++#else
++ netif_rx(skb);
++#endif
+ netIf->stats.rx_packets++;
+
+ return;
+@@ -532,7 +540,11 @@
return -EINVAL;
}
memcpy(netIf->port.paddr, addr->sa_data, dev->addr_len);
- memcpy(dev->dev_addr, addr->sa_data, dev->addr_len);
-+ dev_addr_set(dev, addr->sa_data);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 15, 0)
++ memcpy(dev->dev_addr, netIf->port.paddr, dev->addr_len);
++#else
++ eth_hw_addr_set(dev, netIf->port.paddr);
++#endif
return 0;
}
-diff --git a/vmnet-only/smac.c b/vmnet-only/smac.c
-index f18be8a..7f38e7a 100644
---- a/vmnet-only/smac.c
-+++ b/vmnet-only/smac.c
-@@ -4116,7 +4116,7 @@ SMAC_InitState(SMACState **ptr) // OUT: pointer to alloced/inited state
+--- a/vmnet/smac.c
++++ b/vmnet/smac.c
+@@ -4116,7 +4116,7 @@
void SMACINT
SMAC_SetMac(SMACState *state, // IN: state to update
@@ -174,11 +92,9 @@ index f18be8a..7f38e7a 100644
{
VNETKdPrintCall(("SMAC_SetMac"));
ASSERT(state);
-diff --git a/vmnet-only/smac.h b/vmnet-only/smac.h
-index c8df9d2..f03fd3f 100644
---- a/vmnet-only/smac.h
-+++ b/vmnet-only/smac.h
-@@ -72,7 +72,7 @@ Bool BridgeIPv4MatchAddrMAC(const ULONG ipAddr, const uint8 *mac);
+--- a/vmnet/smac.h
++++ b/vmnet/smac.h
+@@ -72,7 +72,7 @@
void SMACINT
SMAC_InitState(struct SMACState **ptr); // IN: state to alloc/init
void SMACINT
@@ -187,158 +103,101 @@ index c8df9d2..f03fd3f 100644
void SMACINT
SMAC_CleanupState(struct SMACState **ptr); // IN: state to cleanup/dealloc
-From 409623bd4693afada659af82e823a6291f70797a Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Mon, 4 Apr 2022 02:05:17 +0200
-Subject: [PATCH] vmnet: use netif_rx() on newer kernels
-
-In mainline 5.18-rc1, commit baebdf48c360 ("net: dev: Makes sure netif_rx()
-can be invoked in any context.") allows calling netif_rx() from any context
-and commit 2655926aea9b ("net: Remove netif_rx_any_context() and
-netif_rx_ni().") drops netif_rx_ni() as it is no longer needed.
-
-Replace calls of netif_rx_ni() in VNetBridgeReceiveFromVNet() and
-VNetNetIfReceive() by netif_rx() when building against kernel 5.18 and
-newer.
----
- vmnet-only/bridge.c | 2 +-
- vmnet-only/compat_netdevice.h | 9 +++++++++
- vmnet-only/netif.c | 2 +-
- 3 files changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/vmnet-only/bridge.c b/vmnet-only/bridge.c
-index c84f8ee..d6bd3c4 100644
---- a/vmnet-only/bridge.c
-+++ b/vmnet-only/bridge.c
-@@ -691,7 +691,7 @@ VNetBridgeReceiveFromVNet(VNetJack *this, // IN: jack
- * not do it, or netif_rx_ni() will deadlock on the cli() lock --hpreg
- */
-
-- netif_rx_ni(clone);
-+ compat_netif_rx_ni(clone);
- # if LOGLEVEL >= 4
- do_gettimeofday(&vnetTime);
- # endif
-diff --git a/vmnet-only/compat_netdevice.h b/vmnet-only/compat_netdevice.h
-index bb5001b..c6cc706 100644
---- a/vmnet-only/compat_netdevice.h
-+++ b/vmnet-only/compat_netdevice.h
-@@ -343,4 +343,13 @@ typedef u32 compat_netdev_features_t;
- #define compat_netif_trans_update(d) do { (d)->trans_start = jiffies; } while (0)
- #endif
-
-+static inline int compat_netif_rx_ni(struct sk_buff *skb)
-+{
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 18, 0)
-+ return netif_rx(skb);
-+#else
-+ return netif_rx_ni(skb);
-+#endif
-+}
+--- a/vmnet/userif.c
++++ b/vmnet/userif.c
+@@ -520,6 +520,50 @@
+ /*
+ *----------------------------------------------------------------------
+ *
++ * VNetCsumAndCopyToUser --
++ *
++ * Checksum data and copy them to userspace.
++ *
++ * Results:
++ * folded checksum (non-zero value) on success,
++ * err set to 0 on success, negative errno on failure.
++ *
++ * Side effects:
++ * Data copied to the buffer.
++ *
++ *----------------------------------------------------------------------
++ */
+
- #endif /* __COMPAT_NETDEVICE_H__ */
-diff --git a/vmnet-only/netif.c b/vmnet-only/netif.c
-index 8c3bbf8..35256a0 100644
---- a/vmnet-only/netif.c
-+++ b/vmnet-only/netif.c
-@@ -357,7 +357,7 @@ VNetNetIfReceive(VNetJack *this, // IN: jack
- /* send to the host interface */
- skb->dev = netIf->dev;
- skb->protocol = eth_type_trans(skb, netIf->dev);
-- netif_rx_ni(skb);
-+ compat_netif_rx_ni(skb);
- netIf->stats.rx_packets++;
-
- return;
-From e02b540ab528917c1afd7848ef64ca146a634994 Mon Sep 17 00:00:00 2001
-From: Michal Kubecek <mkubecek@suse.cz>
-Date: Tue, 31 May 2022 23:29:42 +0200
-Subject: [PATCH] vmnet: open code csum_and_copy_to_user on kernel >= 5.19
-
-Mainline commit 6308499b5e99 ("net: unexport csum_and_copy_{from,to}_user")
-in 5.19-rc1 unexports csum_and_copy_to_user as no in-tree module is using
-it. A clean solution would probably be rewriting the code to use iovec
-iterator as csum_and_copy_to_iter() is still exported (or perhaps
-skb_copy_and_csum_datagram() might be used instead). Anything like this
-would be way too intrusive so it would have to wait for VMware developers.
-
-For now, use the simplest solution and replace the calls to
-csum_and_copy_to_user() on 5.19 and newer with open coded implementation.
-As the optimized x86 version uses csum_partial_copy_generic() which is not
-exported on x86_64 either, copy the generic one from include/net/checksum.h
-instead. This will be less efficient but hopefully the performace hit will
-not be noticeable.
----
- vmnet-only/userif.c | 45 +++++++++++++++++++++++++++++++--------------
- 1 file changed, 31 insertions(+), 14 deletions(-)
-
-diff --git a/vmnet-only/userif.c b/vmnet-only/userif.c
-index e99c436..2c5a24a 100644
---- a/vmnet-only/userif.c
-+++ b/vmnet-only/userif.c
-@@ -85,6 +85,33 @@ extern unsigned int vnet_max_qlen;
- # define skb_frag_off(frag) (frag)->page_offset
- #endif
-
-+#if COMPAT_LINUX_VERSION_CHECK_LT(5, 10, 0)
-+static inline unsigned int
-+compat_csum_and_copy_to_user(const void *src, void __user *dst, int len,
-+ int *err)
++static unsigned int
++VNetCsumAndCopyToUser(const void *src, // IN: Source
++ void *dst, // IN: Destination
++ int len, // IN: Bytes to copy
++ int *err) // OUT: Error code
+{
-+ return csum_and_copy_to_user(src, dst, len, 0, err);
-+}
-+#else
-+static inline unsigned int
-+compat_csum_and_copy_to_user(const void *src, void __user *dst, int len,
-+ int *err)
-+{
-+ unsigned int csum;
++ unsigned int csum;
+
-+#if COMPAT_LINUX_VERSION_CHECK_LT(5, 19, 0)
-+ csum = csum_and_copy_to_user(src, dst, len);
++#if COMPAT_LINUX_VERSION_CHECK_LT(5, 10, 0)
++ csum = csum_and_copy_to_user(src, dst, len, 0, err);
++#elif LINUX_VERSION_CODE < KERNEL_VERSION(5, 19, 0)
++ csum = csum_and_copy_to_user(src, dst, len);
++ *err = (csum == 0) ? -EFAULT : 0;
+#else
-+ csum = csum_partial(src, len, ~0U);
-+ if (copy_to_user(dst, src, len))
-+ csum = 0;
-+#endif /* 5.19 */
-+
-+ *err = (csum == 0 ? -EFAULT : 0);
-+ return csum;
++ if (!user_access_begin(dst, len)) {
++ *err = -EFAULT;
++ csum = 0;
++ } else {
++ *err = 0;
++ csum = csum_partial_copy_nocheck(src, dst, len);
++ user_access_end();
++ }
++#endif
++ return csum;
+}
-+#endif /* 5.10 */
+
- /*
- *-----------------------------------------------------------------------------
++
++/*
++ *----------------------------------------------------------------------
++ *
+ * VNetCsumCopyDatagram --
*
-@@ -559,12 +586,7 @@ VNetCsumCopyDatagram(const struct sk_buff *skb, // IN: skb to copy
+ * Copy part of datagram to userspace doing checksum at same time.
+@@ -559,7 +559,7 @@
return -EINVAL;
}
--#if COMPAT_LINUX_VERSION_CHECK_LT(5, 10, 0)
- csum = csum_and_copy_to_user(skb->data + offset, curr, len, 0, &err);
--#else
-- csum = csum_and_copy_to_user(skb->data + offset, curr, len);
-- err = (csum == 0) ? -EFAULT : 0;
--#endif
-+ csum = compat_csum_and_copy_to_user(skb->data + offset, curr, len, &err);
++ csum = VNetCsumAndCopyToUser(skb->data + offset, curr, len, &err);
if (err) {
return err;
}
-@@ -578,14 +600,9 @@ VNetCsumCopyDatagram(const struct sk_buff *skb, // IN: skb to copy
+@@ -573,8 +578,8 @@
const void *vaddr;
vaddr = kmap(skb_frag_page(frag));
--#if COMPAT_LINUX_VERSION_CHECK_LT(5, 10, 0)
- tmpCsum = csum_and_copy_to_user(vaddr + skb_frag_off(frag),
- curr, skb_frag_size(frag), 0, &err);
--#else
-- tmpCsum = csum_and_copy_to_user(vaddr + skb_frag_off(frag),
-- curr, skb_frag_size(frag));
-- err = (tmpCsum == 0) ? -EFAULT : 0;
--#endif
-+ tmpCsum = compat_csum_and_copy_to_user(vaddr + skb_frag_off(frag),
-+ curr, skb_frag_size(frag),
-+ &err);
++ tmpCsum = VNetCsumAndCopyToUser(vaddr + skb_frag_off(frag),
++ curr, skb_frag_size(frag), &err);
kunmap(skb_frag_page(frag));
if (err) {
+# Fixing VMWare Player on Linux when using DHCP addresses: https://www.nikhef.nl/~janjust/vmnet/
+@@ -985,6 +996,9 @@
+ userIf = (VNetUserIF *)port->jack.private;
+ hubJack = port->jack.peer;
+
++ /* never send link down events */
++ if (!linkUp) return 0;
++
+ if (port->jack.state == FALSE || hubJack == NULL) {
+ return -EINVAL;
+ }
+--- a/vmnet/vm_basic_defs.h
++++ b/vmnet/vm_basic_defs.h
+@@ -50,7 +50,10 @@
+ * References:
+ * C90 7.17, C99 7.19, C11 7.19
+ */
+-#if !defined(VMKERNEL)
++/* Use linux/stddef.h when building Linux kernel modules. */
++#ifdef KBUILD_MODNAME
++# include <linux/stddef.h>
++#elif !defined(VMKERNEL)
+ # include <stddef.h>
+ #else
+ /*