summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammad Zolfaghari2021-01-07 13:36:58 +0330
committerMohammad Zolfaghari2021-01-07 13:36:58 +0330
commitd9e1fab41dd9efec2bfc1f0534da6db0d625affd (patch)
treecc2cde7fac94c35aff60f72021493b30e4e0f6ad
downloadaur-d9e1fab41dd9efec2bfc1f0534da6db0d625affd.tar.gz
initial commit Meikade pkg
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--meikade.desktop8
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2f656500a72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = meikade
+ pkgdesc = Meikade is a poetry application
+ pkgver = 4.2.2
+ pkgrel = 1
+ url = https://github.com/Aseman-Land/Meikade
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ source = meikade.desktop
+ source = https://github.com/Aseman-Land/Meikade/releases/download/4.2.2/Meikade-Linux-4.2.2.xz
+ source = git+https://github.com/Aseman-Land/QtAseman.git
+ source = https://raw.githubusercontent.com/Aseman-Land/Meikade/master/configurations/ios/icons/AppIcon40x40%402x.png
+ sha256sums = d404ae996967334f9813a043b2aa0a5aa7ac19b90c8a9f6ac0d05aaf32529bdf
+ sha256sums = bfd18aa478e76c2353562fd24822247b25b66b5b88a582af5554cbc9b60dfbcf
+ sha256sums = SKIP
+ sha256sums = ffcf1cb0edd57d1efa9ecb6029744a4c0182eccdefa2a37b17e7b81df5f3e93c
+
+pkgname = meikade
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..218ec8df4e10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mohammad Zolfaghari <zidom72@gmail.com>
+arch=('x86_64')
+license=('GPL3')
+pkgdesc="Meikade is a poetry application"
+pkgname=meikade
+pkgver=4.2.2
+pkgrel=1
+depends=('qt5-base')
+source=(
+ 'meikade.desktop'
+ "https://github.com/Aseman-Land/Meikade/releases/download/${pkgver}/Meikade-Linux-${pkgver}.xz"
+ "git+https://github.com/Aseman-Land/QtAseman.git"
+ "https://raw.githubusercontent.com/Aseman-Land/Meikade/master/configurations/ios/icons/AppIcon40x40%402x.png"
+)
+sha256sums=(
+ 'd404ae996967334f9813a043b2aa0a5aa7ac19b90c8a9f6ac0d05aaf32529bdf'
+ 'bfd18aa478e76c2353562fd24822247b25b66b5b88a582af5554cbc9b60dfbcf'
+ 'SKIP'
+ 'ffcf1cb0edd57d1efa9ecb6029744a4c0182eccdefa2a37b17e7b81df5f3e93c'
+)
+url='https://github.com/Aseman-Land/Meikade'
+
+build() {
+ cd "${srcdir}/QtAseman"
+ mkdir build
+ cd build
+ qmake -r ..
+ make -j2
+}
+
+package() {
+ install -D -m644 "${srcdir}/meikade.desktop" "$pkgdir/usr/share/applications/meikade.desktop"
+ install -D -m644 "${srcdir}/AppIcon40x40%402x.png" "$pkgdir/usr/share/icons/hicolor/48x48/apps/Meikade.png"
+ install -D -m755 "${srcdir}/Meikade-Linux-${pkgver}" "$pkgdir/usr/lib/meikade/Meikade"
+ cd "${srcdir}/QtAseman/build"
+ make INSTALL_ROOT="$pkgdir" install
+}
diff --git a/meikade.desktop b/meikade.desktop
new file mode 100644
index 000000000000..60c78c9dd5d0
--- /dev/null
+++ b/meikade.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Meikade
+Icon=Meikade
+GenericName=Meikade is a poetry application.
+Exec=/usr/lib/meikade/Meikade
+Type=Application
+Categories=Poetry;