summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrant Moyer2022-02-23 20:24:45 -0500
committerGrant Moyer2022-02-23 20:24:45 -0500
commitd9e8120767d00834b42bf7c64a36bc76ba64f021 (patch)
tree2e0107c9fca25e723ebde634001720860796a250
downloadaur-d9e8120767d00834b42bf7c64a36bc76ba64f021.tar.gz
Version 1.5.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edb088624860
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = calibre-plugin-goodreads
+ pkgdesc = Downloads metadata and covers from Goodreads - Calibre Plugin
+ pkgver = 1.5.3
+ pkgrel = 1
+ url = https://www.mobileread.com/forums/showthread.php?t=130638
+ arch = any
+ license = custom
+ depends = calibre>=0.8.1
+ noextract = Goodreads-1.5.3.zip
+ source = Goodreads-1.5.3.zip::https://plugins.calibre-ebook.com/130638.zip
+ sha256sums = 757ed8c90c940e3f676ac5c46539c1d895e8654c9744c98de504ee40bde2ba29
+
+pkgname = calibre-plugin-goodreads
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..377edd1d267c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Grant Moyer <youremail@domain.com>
+pkgname=calibre-plugin-goodreads
+pkgver=1.5.3
+pkgrel=1
+pkgdesc="Downloads metadata and covers from Goodreads - Calibre Plugin"
+arch=('any')
+url="https://www.mobileread.com/forums/showthread.php?t=130638"
+license=('custom')
+depends=('calibre>=0.8.1')
+source=("Goodreads-$pkgver.zip::https://plugins.calibre-ebook.com/130638.zip")
+noextract=("Goodreads-$pkgver.zip")
+sha256sums=('757ed8c90c940e3f676ac5c46539c1d895e8654c9744c98de504ee40bde2ba29')
+
+package() {
+ install -m644 -D "${srcdir}/Goodreads-$pkgver.zip" "${pkgdir}/usr/share/calibre/system-plugins/Goodreads.zip"
+}